Jump to content

{Guide} Toshiba L755/L750 ML 10.8.3 (no need any macintosh environment)

- - - - -

  • Please log in to reply
7 replies to this topic

#1
tranduyquang

tranduyquang

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
Install ML 10.8.3 from USB for Toshiba L755/L750 laptop (no need any Macintosh environment).


Toshiba L755 spec:

1. Cpu i5 2450M: native speedstep with patched BIOS and SSDT

2. VGA GT 525M: DSDT, HDMI video

3. Sound Conexant Cx20585: DSDT, patched AppleHDA (HDMI audio not working)

4. Wifi AR9285: DSDT, no kext, QE/QI

5. Lan AR8151: kext

6. USB 3.0: kext

7. Fn key: able to adjust audio volume, brightness

8. Bluetooth: not working, no kext

9. Keyboard, touchpad: kext from mutibe*ast



Requirement:

1. One usb 8Gb, one usb 1Gb (or more capacities)

2. ML install package

3. SUSE Studio Image Writer

4. GParted Live CD/USB/HD/PXE Bootable Image

5. Download ultilitiesfor ML (multibe*at, kext wizard, kext ultility, chameleon wizard, chameleon)

6. Download necessary kext for Toshiba L755(patched AppleHDA, AppleSmartBatteryManager, AtherosL1cEthernet, IOUSBFamily)

7. Download AHCI patcher(need for case “Still waiting for root device…”)

8. Download “extra” folder for L755 laptop

9. Download UltraISO

10. Pached BIOS: native speedstep for ML



Preparation:

1. In windows:

a. Use Disk Management to creat one partition for Macos installation, recommend more than 20Gb capacity.

b. Delete (unformat) that partition

2. In windows:

a. Make an installation USB of Macos on 8Gb thumb drive: follow this guidance

b. Make a bootable GParted Live USB: use UltraISO to open the downloaded Gparted ISO file. Bootable-->Write Disk Image…


3. In windows: Place all kext, tool, extra folder…into a folder in order to easily find out when we’re in Macos (E.g. I place at D:\macos\installation)

4. Patching BIOS: CodeRush

a. Download Toshiba L755 BIOSnewest (ver 3.6) :

b. Patching tool

c. Progressing:

- After extract everything from downloaded bios, you will have this: sk1wv360\os2012321a_360\Madrid20R20RG_BIOS_WIN_V360\x64\BIOS.fd

- Unzip downloaded tool, rename folder to "PMPatch" and place at C:\

- Copy the original BIOS.fd to "pmpatch" folder (Note: My windows is 64 bit version. If you install x86 then chose BIOS.fd from x86 folder)

- Open CMD, run command "cd C:\PMPatch"

- Patch bios, run command "pmpatch C:\PMPatch/BIOS.fd C:\PMPatch/patchedBIOS.fd"

- Rename patchedBIOS.fd to BIOS.fd and replace for the original once in "sk1wv360\os2012321a_360\Madrid20R20RG_BIOS_WIN_V360\ x64\BIOS.fd " (pls take note x86 or x64)

- Flash your bios: run InsydeFlashx64.exe in "x64" folder (or InsydeFlash.exe in x86 folder). PLEASE ENSURE that you are on AC and your battery remain more than 50% power. Windows then auto restart. Done.

5. Boot from Gparted usb and format the “deteled/unformatted partition” that just prepared for Macos installation, format it as HFS+

6. Boot from Macos Installation USB, use Disk Ultility to make “Journaled” said partition

7. Install ML

8. Install mutibeast:

9. Install chameleon wizard, copy things to extra folder


Be careful that you have a correct SSDT for your CPU

10. Install kexts. Repare cache with Kext Utility.



Credit:

CodeRush
Bcc9
Pernacabeluda
Pere
Zenith432
Shailua
RehabMan

Attached Files



#2
nhymxu

nhymxu

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
Can you help me with Satellite L840-1029 with same LAN, wifi, and soundcard
CPU: Intel Core i3 -2370M without GPU (using internal Intel HD 3000)

Thanks you

#3
darkplace

darkplace

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

6. Download necessary kextfor Toshiba L755(patched AppleHDA, AppleSmartBatteryManager, AtherosL1cEthernet, IOUSBFamily)

7. Download AHCI patcher(need for case “Still waiting for root device…”)

8. Download “extra” folder for L755 laptop


necessary kexy and extra folder doesn't appear. Bad links. Please consider fix it, big thanks a lot for the guide!

#4
tranduyquang

tranduyquang

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

Can you help me with Satellite L840-1029 with same LAN, wifi, and soundcard
CPU: Intel Core i3 -2370M without GPU (using internal Intel HD 3000)

Thanks you

So that you need to patch Bios, a correct SSDT for CPU and edit (or kext) for VGA.

necessary kexy and extra folder doesn't appear. Bad links. Please consider fix it, big thanks a lot for the guide!


Updated link.

#5
vautinsh

vautinsh

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
Hi,
Thank you for your awesome guide!
The only problem I have right now is that USB ports on the right side of my laptop aren't working! How could i fix this?
By the way i have Toshiba L750 without USB3!

EDIT:
The problem with USB only happens if something is connected in usb ports when mac is booting...
And another thing, sleep function isn't working! When it wakes up, screen is black!

#6
tranduyquang

tranduyquang

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

Hi, Thank you for your awesome guide! The only problem I have right now is that USB ports on the right side of my laptop aren't working! How could i fix this? By the way i have Toshiba L750 without USB3! EDIT: The problem with USB only happens if something is connected in usb ports when mac is booting... And another thing, sleep function isn't working! When it wakes up, screen is black!


I have no idea about ur issue. But maybe u can disable USB EHCI in bios to solve that problem.

#7
vautinsh

vautinsh

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
Also, when I shut down my laptop, screen turns black but it doesn't shut down!

#8
dr.genome

dr.genome

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:White Trash, USA .......midwest
  • Interests:CULTure,vintage electric and electronic, combination mk linux, bsd, next, mach os, and darwin......

!Props to Tranduyquang!

 

   thanx 4 the guide!

 

i have a L755-s5214

believe it is the base/lowest model-- no usb3 or BT and only hd3k and i3-2310m

 

just started pmpatch, returns couple errors, pwr mgmt modules not found.

should i still use patched bios?

fairly certain i should check w/u b4 applying.

 

thank you for the guidance and advice.

 

geoff







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy