Jump to content

Kernel Panic on ASUS P5Q


  • Please log in to reply
3 replies to this topic

#1
vol264

vol264

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Hi,

I have a perfect working Snow Lepoard on my hack but would like to upgrade to Lion. I've tried a lot of options, but everytime when I boot i get kernel panic (see attached picture).

So what is the current situation:

1. Have a bootable USB stick with Lion and Chameleon 2.1 (checked on real MAC and is booting OK)
2. smbios.plist (Mac 3,1 optimized)
3. com.apple.Boot.plist
<key>Boot Banner</key>
<string>No</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>3</string>
<key>RestartFix</key>
<string>Yes</string>
4. Have an optimized DSDT (only fakesmc.kext is needed on SL)
5. Exrta/Extensions (FakeSMC, tried also (IOAHCIBlockStorageInjector, AHCIPortInjector))
6. Tried with kernel flags (acpi=off, PCIRootID=0 and 1, no kernel cache, no graphics enabler)
7. Have unplugged CD/DVD and 1TB disk
8. Checked BIOS settings

I really have no more ideas what to try.

Any ideas what could be worng?

Thanks

Attached Files



#2
vol264

vol264

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Restored Lion on the USB stick again and now it goes forward but now I'm stuck on the white screen after apple logo.

Tried PCIRootUID, npci, GraphicsEnabler.

When I do -f or -s I get then th same kernel panic as in first post.

Are there normally problems with USB stick when restoring images onto them? I suspect that this could be the same issue.

#3
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
-f -v -x PCIRootUID=1 UseKernelCache=No GraphicsEnabler=No npci=0x2000 cpus=1

Use only FakeSMC.kext and NULLCPUPowerManegemente.kext in S/L/E of your USBInstaller, in the root USBInstaller folder Extra with smbios.plist/org.chameleon.boot.plist/DSDT.aml, make a new USBInstaller with MAP/MBR Format/HFS+ , RESTORE with Disk Utility .dmg LION, InstallChameleon, make a Extra Folder, and try again, in your photo I see what the problem is Installer corrupt or you have made this wrong, serch for a guide how to mke a USBInstaller, take a look here.


The all-in-one guide to Vanilla OS X Mountain Lion + Chameleon + DSDT for beginners http://www.insanelym...howtopic=280756


#4
vol264

vol264

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Thanks for the help. In the end it was a corrupt installer.

Regards,





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy