Jump to content

Lenovo T530 Mountain Lion (10.8.2) Mostly Successful


  • Please log in to reply
1 reply to this topic

#1
ktroncroz

ktroncroz

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I have ML (10.8.2) installed on my T530 laptop. Specs below

Lenovo T530

Processor
  • 3rd Generation Intel® Core™ i5-3320M (3.30 GHz, 3MB L3, 1600MHz FSB)
Memory
  • 4GB DDR3 (soon to be 8GB)
SSD
  • 256GB Crucial M4 SSD
Display
  • 15.6" FHD (1920 x 1080) (95% Gamut) (270 NITS)
Webcam
  • Low Light 720p HD Camera with Face Tracking
I/O (INPUT/OUTPUT) Ports
  • (1) MiniDisplayPort with audio
  • (1) VGA
  • (1) 3.5mm Combo Jack Headphone/MIC
  • (2) USB 3.0
  • (1) USB 2.0
  • (1) Always on USB 2.0
  • (1) 4-in-1 SD Card Reader (SD/SDHC/SDXC/MMC slot)
  • (1) Express Card 34mm
  • (1) Smart Card Reader5
Optical Drive
  • Multi Burner/DVD CD Multi-Rec
Networking
  • Intel Ethernet RJ45
  • Intel Wifi
Audio
  • Dolby® Advanced Audio® 2.0 - ALC3203 Codec

Graphics
  • Intel® HD Graphics 4000
  • NVIDIA® NVS 5400M Graphics with Optimus™ Technology
Installed via the Generic Mountain Lion USB stick method. Hard drive was formatted MBR and applied the MBR patches to the install image.

Working:
  • Trackpad / Keyboard work with VoodooPS2 kext
  • Battery works with VoodooBattery kext
  • HD4000 with EFI string in plist
  • Audio with VoodooHDA 2.8.2 (increased igain to 80).
  • Bluetooth (BCM20702A) working with modified IOBluetooth kext
  • Sleep works with SleepEnabler (and some DSDT edits)
  • Webcam works
  • All USB ports (including USB 3.0 ports working)
  • Display dimming works with DSDT edit
  • Ethernet with modified IntelE1000 kext
  • Wifi via Airlink 101 WL5088 ($13 from amazon)
  • iMessage with lastest Chameleon and FileNVRAM.dylib hack

Not Working:
  • NVIDIA NVS5400M
  • VGA port
  • Display port Port
  • I still have the NullCPUPowerManagement kext installed - so speed stepping doesn't work
  • Internal Wifi - won't work until we can get a BIOS white list patch and can change the card
  • Not all of the sensors - I get 2 core temperature sensors and HD SMART. No fan control or RPMs.
  • Facetime crashes when trying to connect
  • ExpressCard (unknown)
  • SD Card (unknown) but I assume its not
Kexts installed:
  • ACPISensors.kext - from T410/T510 thread - don't know if its actually doing anything
  • AppleACPIPlatform.kext - from T410/T510 thread - don't know if its actually doing anything
  • AppleIntelE1000.kext - from T410/T510 thread - I am sure its required, but I never tried with the vanilla
  • AppleRTC.kext - from T410/T510 thread - don't know if its actually doing anything, but am I guessing it is.
  • FakeSMC.kext - from T410/T510 thread
  • NullCPUPowerManagement.kext
  • SleepEnabler.kext
  • VoodooBattery.kext
  • VoodooHDA.kext - v2.8.2
  • VoodooPS2Controller.kext
  • IOBluetooth.. - Modified for BCM20702A
DSDT Edits include:
  • Clean up for compilation and patching
  • LPC changes
  • USB changes
  • Backlight Dimming
  • ...

SMBIOS for MacBookPro10,1

My focus right now is to get the external video ports working with the HD4000. Seems like the HD3000 guys have a found a solution, but I haven't seen anything yet for the HD4000. Hoping to figure something out soon.

Kevin

#2
aboozar

aboozar

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Would you please provide some details and your modified DSDT file?

 

I have a Lenovo T530 2429-1D2 with following Spec:

  •  Processor  Intel® Core™ i7-3520M Processor (4M Cache, 2.90 GHz)
  •  Graphics  Intel® HD Graphics 4000
  • Memory 8 GB PC3-12800 DDR3 SDRAM 1600MHz SODIMM Memory
  • Display 15.6" FHD (1920 X 1080) LED backlight
  • Pointing device UltraNav (TrackPoint and TouchPad)
  • Hard Drive 180GB SATA 2.5" Solid State Drive
  • Optical Drive DVD Recordable Serial ATA
  • Battery 9 Cell Lithium Ion Battery (Up to 11.3 Hours Run Time)
  • Network Card Intel® Centrino Advanced-N 6205 (2x2 AGN)
  • Bluetooth No Bluetooth
  • WWAN Integrated Wireless Wide Area Network upgradable
  • Finger Print Reader No Fingerprint Reader






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy