Jump to content

Replacing AppleACPI an IOPCI causes permanent boot crash - why?


  • Please log in to reply
1 reply to this topic

#1
Funky frank

Funky frank

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 328 posts
Hi,

I am running a 90% working OSX 10.6.8 system. The only problem with it, that it has no proper sleepmode.
So I tried a trick that successfully works on my Vaio notebook:

I backupped the AppleACPIPlatform.kext and the IOPCIFamily.kext and then replaced these two with versions from OSX10.6.7. Ater replacing I did run "pfix" command for fixing permissions and rebuilding boot caches.

The next boot the system started to crash the ATI5000.kext. It now only boots if I disable GraphicsEnabler using "GraphicsEnabler=no" at boot menu.

So I removed the two 10.6.7 kexts and replaced it again with the original 10.6.8 backups. Afterwards ran pfix.

No it comes: The crash still remains after reboot, still at ATI5000.kext! Why this??? I placed the working kexts back and rebuilt boot caches. What's wrong now? On every boot I still have to disable GraphicsEnabler. Before this test, the system booted fine with it!

Did I forgot something?

Here are my Chameleon extensions: AppleACPIPS2Nub, FakeSMC, SleepEnablerNG


Thanks for any help!

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
the problem is the kexts SleepEnabler.kext is a conflictive kext delete it , you can use my script for repair and rebuild your system,Open Terminal app , copy and paste of entire code in Terminal app wait for end and reboot.


Attached File  Maintenace 10.6.8.rtf   2.94KB   15 downloads





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy