Jump to content

Dual graphics on Notebook(HP). Possible Solution

dual graphics hp pavilion dv6

  • Please log in to reply
1 reply to this topic

#1
YuTech

YuTech

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Hello everybody.

I have a HP Pavilion DV6-6B55SG and it has two Graphics. A integrated Intel HD 3000 and a AMD Raedon 6770M.
I'm running Mountain Lion and it only uses the Intel HD 3000.
It looks like this:
http://www7.pic-uplo...q3nc79j8fi2.png

So I read a lot of threads about it, and every thread ended like "there is no solution, until you can disable your onboard graphics".
Well, I figured out how to disable it and this might be interesting for all HP owners.
When you reboot press F10 and when it says Bootmenu is loading press a. Then you will see the advanced boot menu.
My Bios vendor is Insyde and the version is F.19.

The settings look like this:
http://www10.pic-upl...o3n1m73fwpb.jpg
http://www7.pic-uplo...rii1ix2a6rl.jpg
http://www10.pic-upl...snsz4fs29gi.jpg
http://www7.pic-uplo...zbipvxmq2vr.jpg


But when i put "Internal Graphics Device" (Link 3) from Auto to Disable, and then restart I will get a blackscreen and have to do a hard Bios reset, by taking out the RTC Battery

Does anyone know, which settings I need to change?
For example Primary Display. It's on SG (Switchable Graphics), but can be put on PEG, PCI, Auto.

Or is there any other solution for this problem?

Thank you for every help.

*My bootloader is Chimera 1.11.1 (svn-r1394).
bdmesg says this:
ATI Framebuffer Addr: @0xA0000000  MMIO Addr: @0xC6500000 I/O Port Addr: @0x00005000 ROM Addr: @0xFFFE0000
ATI card POSTed, reading Video BIOS from legacy space
Card reported ports: 0
Framebuffer set to:  using device's default.
Number of ports set to: 0 using framebuffer's default.
AMD Radeon HD 6770M 4095MB [1002:6740] (subsys [103c:3388]) (Turks:) :: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)
Intel Intel HD Graphics 3000 Mobile [8086:0116] :: PciRoot(0x0)/Pci(0x2,0x0)


#2
Gizzzm0

Gizzzm0

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hello .
And , for the first, sorry for my english :wink2:
I have this laptop
HP DV7-6153er / i7 2.00 2630QM/ 8Gb DDR3 1333Mhz/ Intel Hd 3000/ Ati HD 6770M 2Gb/ IDT 92HD81B1X5/ Realtek 8111/ - green color mean what work fine or 97% fine, for example HD3000 :)
use this SMBIOS
MacBook Pro 8.1
Installed oses ML 10.8.2/Lion 10.7/Win7 x64/Ubuntu 11.10
use Clover bootloader r.r1050
bios F1B
-----------------------------------------

I try now your method.Rebooting and press F10, then A.After this I see usualy bios setup utility menu, not advanced.For default in my laptop, pressing F10 it's entering in bios setup utility,what's in your laptop?Mb need use other key, don't know.I saw this bios menu, when write my bios with modded bios with unlocked menu.I try disable internal grafic card,use sg primary display,peg and auto.When reboot I saw only black screen. :wallbash:How disable integrated intel I don't know, mb it's impossible.
I backup system bios under windows, then i extract videobioses hd3000 and 6770m with phoenix tool, because it's possible only this way.
Open bioses with HEX editor and founds words LVDS,HDMI,DP and VGA only in intel bios, in ati bios rom I found only this:
localhost:RadeonPatch mindtrip$ ./radeon_bios_decode < ati.rom
ATOM BIOS Rom:
SubsystemVendorID: 0x103c SubsystemID: 0x1656
IOBaseAddress: 0x0000
Filename: BR41116.001
BIOS Bootup Message:
HP/Flex Grant Whistler XT GDDR5 128Mx16 1GB						

PCI ID: 1002:6740
localhost:RadeonPatch mindtrip$ ./redsock_bios_decoder < ati.rom
BR41116.001 :

HP/Flex Grant Whistler XT GDDR5 128Mx16 1GB						

Subsystem Vendor ID: 103c
	 Subsystem ID: 1656
Object Header Structure Size: 30
Connector Object Table Offset: 16
Router Object Table Offset: 0
Encoder Object Table Offset: 1a
Display Path Table Offset: 12

When I install Ubuntu Linux, in system folders where builds devices, I found intel bios rom (~65 Kb) and ati bios rom (~131Kb) but ati rom extracted under Windows has size ~61Kb.
I think we have dual videobios and it's no good.Intel rom with info about connectors and ports, ati rom with info about offset in intel rom where system can found data for connectors and ports.
For today I use Clover bootloader which can load two videobioses and grafic enabler with framebuffer Pondweed, but ati don't full work.You can all see in attachments.
------------
You have acces in advanced bios menu.Try this way. In advanced bios menu, login in video configuration - Pci express grafic where choose in Power Xpress setting - Muxed fixed scheme. This scheme use Apple , Muxless scheme it's for PC, save and exit. In Chimera choose Grafic Enabler Yes, framebuffer=Pondweed.Download and install gfxCardStatus, then run, what it say.
If you want try Clover bootloader I can send you video roms of two cards and my config plist.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy