Jump to content

DSDT and GTX 580


  • Please log in to reply
8 replies to this topic

#1
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
I have been following a guide on how to edit DSDT for the GTX 580 series. But I have no success in booting afterwards. I edit the DSDT,boot with GraphicsEnabler=No but my screen just goes to sleep after a while and I have to manually restart. Can you help,dont know what I am doing wrong. I have attached my IOReg and DSDT before patch.Thanks

ASRock Extreme 4 X79 @ 4515 MHz BIOS 2.10
8 GB DDR3 1600 Mhz
MSI GTX 580 Lightning 1536 MB


http://dl.dropbox.co...495/IOReg.ioreg
http://dl.dropbox.co...601495/dsdt.aml

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
look if work for you, I inject your card in DSDT. Attached File  GTX580.zip   11.59KB   69 downloads

#3
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
Tried your dsdt, when I boot with GraphicsEnabler=No my monitor goes to sleep while booting.

#4
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
try the lasted ENOCH boot loader and GraphicsEnabler=Yes

#5
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
Tried with GraphicsEnabler=Yes and it works but isnt the point of using dsdt to not havet to use GraphicsEnabler=Yes. How can I have HDMI audio with my card?

#6
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
read the topic Enoch boot loader

enable hdmi sound gtx 560 mountain lion - Buscar con Google

#7
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
Yes thank you, im trying to get HDMI to work with a tutorial from other site but its confusing to read.
Edit:sorry

#8
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
please don't post links from Tonymac here, edit your post please, read rules

#9
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
Ok got HDMI working :thumbsup_anim: . It works beautifly on my Phillips LCD TV. This is what I have now:

Posted Image

Although SPDIF is listed I cannot see it in sound output,so no SPDIF for me. I have attached my IOReg and DSDT file if anyone would like to take a look why SPDIF is missing. Thanks

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy