Jump to content

Toshiba Portege M400, Native success


  • Please log in to reply
109 replies to this topic

#41
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
Can you please post your file you created to get the sound working on your m400.

TIA

Spadge

#42
Siegfried

Siegfried

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Can you please post your file you created to get the sound working on your m400.


This is the file I used: Attached File  codec.txt   3.09KB   6 downloads

#43
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

This is the file I used: Attached File  codec.txt   3.09KB   6 downloads



ub case of problem check also the BIOS setting... in the third page the first item should be (if I remember well)
All Devices
and not
OS Setup

#44
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
What version are you using at the moment with your Toshiba POrtege M400?

<= 10.4.8
10.4.9
10.4.10
10.5 (Leopard)

starting from which DVD?

Uphuck
Jas
Kal

whose patches did you selected on the DVD and whose installed after?

#45
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

This is the file I used: Attached File  codec.txt   3.09KB   6 downloads


Thanks for posting the file, I dragged the file onto the AppleHDAPatcher 1.16 icon and its states

Codec : Sigmatel STAC9200
Vendor ID: 0x83847690
Subsytem ID: 0x11790463

* Detected unsupported Sigmatel Codec

However, I found this page h**p://psykopat.free.fr/apple/AppleHDA/sigmatel/ and the Stac9200.txt file worked a treat.

I now have sound :censored2:

Spadge

#46
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
Just to say ...
"happy kalyway" to all of you...
I installed Leopard and it works very well... sleep, monitor, network,...
the only missing thing is a way to have a minimal control on the CPU freq (with tiger I used speedit to drop the freq at 1Ghz if needed)

#47
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Just to say ...
"happy kalyway" to all of you...
I installed Leopard and it works very well... sleep, monitor, network,...
the only missing thing is a way to have a minimal control on the CPU freq (with tiger I used speedit to drop the freq at 1Ghz if needed)


I too have installed Kalyway (Leopard 10.5.1) using the Vanilla kernal and it works. Audio can be fixed using AppleHDA patcher 1.20 and the Sigmatel file I mentioned earlier in this thread.

However, I am unable to get the Bluetooth module recognised. Copying the kext file from within this thread no longer works. Carpao have you found a solution?

#48
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

I too have installed Kalyway (Leopard 10.5.1) using the Vanilla kernal and it works. Audio can be fixed using AppleHDA patcher 1.20 and the Sigmatel file I mentioned earlier in this thread.

However, I am unable to get the Bluetooth module recognised. Copying the kext file from within this thread no longer works. Carpao have you found a solution?


1) for the audio you meand the speaker and the headphone right? no mic or input line support...
2) I used the old ToshACPI.kext and it works for me...
did you try to load it ?
sudo kextload /System/Library/Extensions/ToshACPI.kext

let me know

#49
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

1) for the audio you meand the speaker and the headphone right? no mic or input line support...
2) I used the old ToshACPI.kext and it works for me...
did you try to load it ?

sudo kextload /System/Library/Extensions/ToshACPI.kext

let me know


Thanks for the reply, your command did the trick. I didn't load it properly. Thank you! Bluetooth now works

Yes Audio fix is for speakers and headphone only.

Carpao have you installed the powermanagement.bundle from Tiger. Sleep works ok but I do not get a power management icon displaying battery length anymore. Just wondered if you have tried it?

Spadge

#50
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Thanks for the reply, your command did the trick. I didn't load it properly. Thank you! Bluetooth now works

Yes Audio fix is for speakers and headphone only.

Carpao have you installed the powermanagement.bundle from Tiger. Sleep works ok but I do not get a power management icon displaying battery length anymore. Just wondered if you have tried it?

Spadge


I have a very old and ruined battery (10 minutes left more or less... not only in OSX) so I didn't care to get again the battery icon...
however I think that the trick to use

however did you try http://www.orange-ca.../SBM/index.html ? installing it in tiger solved the problem to me... but I don't know if it works in leopard...

what is the average temperature of your CPUS?

#51
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

I have a very old and ruined battery (10 minutes left more or less... not only in OSX) so I didn't care to get again the battery icon...
however I think that the trick to use

however did you try http://www.orange-ca.../SBM/index.html ? installing it in tiger solved the problem to me... but I don't know if it works in leopard...

what is the average temperature of your CPUS?


Thanks for your reply, I tried the slimbattery application but it doesn't work under Leopard :-( Also the powermanagement.bundle file from Tiger doesn't fix it either.

How can I find out the CPU Temp?

#52
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Thanks for your reply, I tried the slimbattery application but it doesn't work under Leopard :-( Also the powermanagement.bundle file from Tiger doesn't fix it either.How can I find out the CPU Temp?

??? down ???

check these two links...

http://www.bresink.e...tureMonitor.dmg

http://www.bresink.c...tureMonitor.dmg

#53
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

??? down ???

check these two links...

http://www.bresink.e...tureMonitor.dmg

http://www.bresink.c...tureMonitor.dmg


CPU Core 1 43c
CPU Core 2 41c

Spadge

#54
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

CPU Core 1 43c
CPU Core 2 41c

Spadge


ok like me (in the average)... but often I 'm over 50... almost 60...
and sometime I'm a little afraid of that :-D
(with Tiger I reached higher temp, and I think that that ruined my battery...)

#55
Siegfried

Siegfried

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

ok like me (in the average)... but often I 'm over 50... almost 60...
and sometime I'm a little afraid of that :-D
(with Tiger I reached higher temp, and I think that that ruined my battery...)

Are you still using the 3.60 BIOS? Or the much quieter 2.1N BIOS?

#56
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Are you still using the 3.60 BIOS? Or the much quieter 2.1N BIOS?


I use the 3.60 BIOS as this is the latest one from Toshiba.

#57
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Are you still using the 3.60 BIOS? Or the much quieter 2.1N BIOS?


3.60 here... and I think that it should be worse with the quieter bios, right?

#58
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
Carpao,

Just noticed your signature states that PCMCIA doesn't work, I'm annoyed as I haven't checked mine and I've just ordered a PCMCIA wireless card from the states (I live in the UK).

Do you know if there's anything that can be done?

#59
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Carpao,

Just noticed your signature states that PCMCIA doesn't work, I'm annoyed as I haven't checked mine and I've just ordered a PCMCIA wireless card from the states (I live in the UK).

Do you know if there's anything that can be done?


uhm... i made some temptatives in tiger, but no one in leopard... cross your fingers... and let us know

#60
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

uhm... i made some temptatives in tiger, but no one in leopard... cross your fingers... and let us know


I'll let you know if I have any luck. I'll try it when it arrives and fingers crossed it might work ;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy