Jump to content

[NEED HELP] System freezes a few seconds after wake!

i5 3570K Gigabyte H77 DS3H Mountain Lion Freeze Sleep Wake

  • Please log in to reply
1 reply to this topic

#1
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,892 posts
  • Gender:Male
Hi, folks! Everyone's fine?

I have a hack running 10.8.2 on an Intel Core I5 3570K CPU/Gigabyte H77 DS3H motherboard, with 8 gigs of RAM at 1600 ghz, using the Intel HD 4000 integrated graphics with a 21.5'' display plugged in its DVI out.

Every time i wake the computer from sleep, it will freeze seconds after it, at the screen it's showing at the moment (because of this, i even didn't notice it was a freeze the first time, and thought my keyboard and mouse or the USB ins they were plugged in stopped to work). The only solution when it happens is to hard-reboot the computer.

I googled a lot since it started to happen and found it was common with real Macs by the time Mountain Lion was launched, and it should have been corrected since 10.8.1. I use 10.8.2, so it shouldn't be a problem, right?

I know my board does not need a patched dsdt to work, so i'm really lost here with this annoying yet minor issue. Any help would be much appreciated.

Here's the console log for one of the freezes:

Oct 29 15:17:45 localhost kernel[0]: /drv/ MacModule.cpp:304 powerStateWillChangeTo: flags=2 stateNumber=3
Oct 29 15:17:45 localhost kernel[0]: /drv/ MacModule.cpp:305 powerStateWillChangeTo: found flag=kIOPMPowerOn (2)
Oct 29 15:17:45 localhost kernel[0]: /drv/ MacModule.cpp:304 powerStateDidChangeTo: flags=2 stateNumber=3
Oct 29 15:17:45 localhost kernel[0]: /drv/ MacModule.cpp:305 powerStateDidChangeTo: found flag=kIOPMPowerOn (2)
Oct 29 15:17:45 localhost kernel[0]: Previous Sleep Cause: 0
Oct 29 15:17:45 localhost kernel[0]: The USB device USB+PS/2 Optical Mouse (Port 4 of Hub at 0x14000000) may have caused a wake by issuing a remote wakeup (2)
Oct 29 15:17:45 localhost kernel[0]: HID tickle 3 ms
Oct 29 15:17:45 localhost kernel[0]: 1274.141911: ar9300WowWakeUp: Skip PCIE WA programming
Oct 29 15:17:45 localhost kernel[0]: 1274.141928: setDISASSOC from ATH_INTERFACE_CLASS disconnectVap
Oct 29 15:17:45 localhost kernel[0]: Envy24AudioDevice::performPowerStateChange!, old = 0, new = 1
Oct 29 15:17:45 localhost kernel[0]: Envy24AudioDevice::performPowerStateChange -> waking up!
Oct 29 15:17:45 localhost kernel[0]: M-Audio Audiophile 2496 detected!
Oct 29 15:17:45 localhost kernel[0]: Envy24: Going to init CS8427 (3)!
Oct 29 15:17:45 localhost kernel[0]: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).
Oct 29 15:17:45 localhost kernel[0]: en1::IO80211Interface::postMessage bssid changed
Oct 29 15:17:45 localhost kernel[0]: 1274.189385: setDISASSOCIATE ****STA SYNC DISASSOC SUCCESS
Oct 29 15:17:45 localhost kernel[0]: going to init consumer mode!
Oct 29 15:17:45 localhost kernel[0]: 1274.196828: ATHR: unknown locale: 21
Oct 29 15:17:45 localhost kernel[0]: 1274.207790: ATHR: unknown locale: 21
Oct 29 15:17:45 localhost kernel[0]: 1274.208072: ATHR: unknown locale: 21
Oct 29 15:17:45 localhost kernel[0]: Envy24: Turned on monitoring
Oct 29 15:17:48 localhost kernel[0]: AirPort: Link Up on en1
Oct 29 15:17:48 localhost kernel[0]: en1::IO80211Interface::postMessage bssid changed
Oct 29 15:17:48 localhost mDNSResponderHelper[1029]: do_mDNSInterfaceAdvtIoctl: ioctl call SIOCGIFINFO_IN6 failed - error (22) Invalid argument
Oct 29 15:17:48 --- last message repeated 1 time ---
Oct 29 15:17:48 localhost kernel[0]: AirPort: RSN handshake complete on en1
Oct 29 15:17:50 localhost mDNSResponderHelper[1029]: do_mDNSInterfaceAdvtIoctl: ioctl call SIOCGIFINFO_IN6 failed - error (22) Invalid argument
Oct 29 15:17:55 --- last message repeated 1 time ---
Oct 29 15:17:55 localhost UserEventAgent[361]: Could not get event name for stream/token: com.apple.time/5: 0x3: No such process
Oct 29 15:17:55 localhost prl_naptd[341]: Reloading configuration...
Oct 29 15:17:56 --- last message repeated 2 times ---
Oct 29 15:17:56 localhost kernel[0]: 1195.836048: ATHR: unknown locale: 21
Oct 29 15:17:56 localhost kernel[0]: 1195.847736: ATHR: unknown locale: 21
Oct 29 15:17:56 localhost kernel[0]: 1195.858809: ATHR: unknown locale: 21
Oct 29 15:17:59 localhost kernel[0]: Envy24AudioDevice::performPowerStateChange!, old = 1, new = 2
Oct 29 15:17:59 localhost kernel[0]: Envy24AudioDevice::performPowerStateChange!, old = 2, new = 1

What i'd already tried:

1) Using Darkwake=10 instead of zero;

2) Using <key>Wake</key> <string>Yes</string> at Boot.plist.

#2
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,892 posts
  • Gender:Male
This seem to describe what i am experiencing: https://discussions....tart=0&tstart=0





Also tagged with one or more of these keywords: i5 3570K, Gigabyte H77 DS3H, Mountain Lion, Freeze, Sleep, Wake


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy