Jump to content

Dual Link for Alienware m14x r1?

- - - - -

  • Please log in to reply
18 replies to this topic

#1
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
So i need help to get dual link working on my alienware.
I´ve extracted a dsdt.aml for my system an d nearly everything is working. (usb 2.0 usb3.0 LAN Wlan)

things that don´t work till yet are the integrated Card Reader and the Nvidia GT555 1.5Gb.
The graphics Card is shown in systemmonitor with installed kext for the intel hd 3000 device.
But i don´t have accelration for my PCI Card and hardware Monitor show 0MB Vram.

So all please have a look at my dsdt and help me please!!

Big thanks for all your great work till now!!

Attached Files

  • Attached File  DSDT.rar   14.47KB   12 downloads


#2
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
so here is the acpi_dsdt from aida64.

please help me

Attached Files



#3
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
I patched and cleaned your DSDT but I did not do the dual link patch. You need to post a IOreg and a link to your laptops product page. Install DSDT in your extra folder and then restart then extract your IOreg. Then post the IOreg and your entire Extra folder.

For IOreg follow my guide here:

http://rampagedev.wo...w-to-use-ioreg/

Attached Files



#4
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
At first many thanks for your work.

The system boot fine with your patched dsdt.
So i could make the ioreg steps.

Attached you´ll find the services and device tree extracted with ioreg and my extra folder with your patched file.


I hope that this are all informations you need to help me again.

I can´t send you a link to my customer for the specs, cause they have updated this laptop for a while and old model isn´t there any more.
i can only send you a detailed list which hardware is used in my System.

Thanks you very much!!

Attached Files



#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
Install this DSDT and create a new IOreg and then post it.

Attached Files



#6
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
thanks for your help.

system boot fine but graphics isn´t very good. shows wrong resolution and only 8 bit colors.

here is my ioservice

Attached Files



#7
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
Another version. Post new IOreg after install.

This has the full HD3000 edit.

Attached Files



#8
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
Hi,
i´ve tested your new dsdt, but without sucess.

System won´t boot anymore in verbose Mode i get the following errors:

[AGPM Controller] unknown Platform
Apple LPC:: start - RCBA not enabled
ACPI_SMC_PlatformPlugin:: register LPCDriver - Warning - LPC Device initialization failed: C-State power management not initialized

hope this helps you

#9
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
Boot with:

DSDT=No

Then replace the old DSDT with this version:

Attached File  DSDT.aml.zip   15.65KB   10 downloads

#10
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
Hi,

i´m back here again.

this dsdt works normal for booting up my system.

if i use both Graphics Cards it looks like this:


When i disable the gt555m all works except the GT555m Graphics Adapter.

i´ve looked araund the system monitor. there the gt555m is shown with 2048mb ram. and open gl rendering is supported.
but it looks like the picture i´ve uploaded.

very strange for me.

Attached Files



#11
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
I do not understand what you are saying... Is it working now?

#12
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
no, it shows both card at system monitor but i got the resolution and colordepth like on the picture i uploaded

#13
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
Post a new IOreg.

#14
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
here it is

Attached Files

  • Attached File  new.zip   435.98KB   13 downloads


#15
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male
According to the IOreg the GPU is working...

#16
newbee82

newbee82

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
is there a possibility to switch between the GPU´s in osx?

#17
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,950 posts
  • Gender:Male

is there a possibility to switch between the GPU´s in osx?


No

#18
xplus93

xplus93

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Can we turn off the nvidia one to save power? I only use it in windows for gaming.

#19
qwertyparam

qwertyparam

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

So i need help to get dual link working on my alienware.
I´ve extracted a dsdt.aml for my system an d nearly everything is working. (usb 2.0 usb3.0 LAN Wlan)

things that don´t work till yet are the integrated Card Reader and the Nvidia GT555 1.5Gb.
The graphics Card is shown in systemmonitor with installed kext for the intel hd 3000 device.
But i don´t have accelration for my PCI Card and hardware Monitor show 0MB Vram.

So all please have a look at my dsdt and help me please!!

Big thanks for all your great work till now!!

hi, i also have an m14x r1, but i'm not able to install mountain lion on it.. can u tell me how you installed it?

thanks:)







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy