Jump to content

need driver for Atheros AR8161

Atheros Lan Atheros AR8161 AR8161

  • Please log in to reply
27 replies to this topic

#21
AshkanAzad

AshkanAzad

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Make a EFI STRING for your card with OSX86 app from here:http://www.insanelym...owtopic=124911

after that i used it . ethernet recognise by mac and got ip . but it can not connect to the internet and it can not connect and find the other systems in network
also after i restart system network get disable. i have to shutdown system to solve this problem . any suggestion

#22
AshkanAzad

AshkanAzad

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Up ^^^^^ noboday has as8161 lan adaptor ?!!!

#23
PaulOSX

PaulOSX

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hi,

I have the same problem... I've got an ASUS N56VM with also this lan. i've tried also your options but no luck....

I have also no experience with porting linux to apple.

Who could do this?

#24
netgear

netgear

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
Gigabyte GA-Z77-DS3H GA-H77-DS3H rev 1.1 same problem... New chip Atheros 8161...

None solution online... :(

#25
resphoina

resphoina

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
For any developer, this information may be helpful: when loading atherosl1c.kext during boot -v, there are 2 error msg: "mac state machine can't be idle after 10ms" and "could't probe adapter" seems that its not compatible for ar8161..... Hope anyone can fix it soon!!

#26
Shailua

Shailua

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Female
I'm afraid the L1c kext won't work for the 8161/62. In terms of the Linux drivers from which things are based, these chipsets use the alx driver and the AtherosL1cEthernet.kext is based on the atl1c driver. The 61/62 uses a different set of hardware registers to control things, so the software won't work.

http://www.linuxfoun.../networking/alx
As indicated in the August 7, 2012 update on that page, the alx driver had some code offering compatibility with the atl1c chipsets as well, but it is now being stripped out and two separate drivers are being worked on, alx and the original atl1c. Presumably because of the large differences between the two classes of chipset.

Hope that clears things up! It's a shame Atheros/Qualcomm didn't keep the registers and stuff the same, but I'm sure they had some obscure reasons for it.

#27
muteki808

muteki808

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Kobe, Japan
has anyone found a solution to this problem?

GA H77-DS3H rev 1.1 here too :help:

#28
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 767 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

has anyone found a solution to this problem?

GA H77-DS3H rev 1.1 here too :help:

http://www.insanelym...ver-for-107108/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy