Jump to content

[Risolto] ML su P5K-SE

- - - - -

  • Please log in to reply
11 replies to this topic

#1
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Salve, come da titolo ho installato ML su questa MoBo, funziona tutto, compreso lo stop, ma al risveglio da quest'ultimo non funziona più la rete.
Il kext installato è AttansicL1Ethernet
Qualcuno ha qualche idea?

#2
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Al risveglio per far funzionare la rete devo aprire il terminale e digitare "attansic", c'è un metodo automatizzato per fare questo?

#3
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Risultati preliminari (nel senso che non ho avuto tempo di fare tests approfonditi) per far funzionare AttansicL1Ethernet.kext dopo risveglio dallo sleep su Asus Serie P5K:

1) Scarica Sleepwatcher

http://www.macupdate...fo.php/id/10387




(se non lo trovi più li cercalo nel web) ed installare i due package contenuti nel .dmg



2) Loggati come root



3) scarica mucommander:

http://www.mucommand...ander-0_8_3.dmg






4) Apri mucommander e vai in /etc



5) aggiungi al file rc.sleep, come ultima riga: kextunload /System/Library/Extensions/AttansicL1Ethernet.kext



e salva



6) aggiungi al file rc.wakeup, come ultima riga:



kextload /System/Library/Extensions/AttansicL1Ethernet.kext



e salva



Il passo 5 e 6 lo puoi fare da un qualsisasi editor di file, sempre come utente root, (ho cercato di semplificare)


(eventualmente al posto di en0 metti l'identificativo della tuascheda di rete en1 en2 etc)







7) sempre da root apri il terminale e digita:


cd /etc <invio>



chmod +x rc.sleep <invio>


chmod +x rc.wakeup <invio>



8) chiudi il terminale



9) riavvia e al ritorno dallo sleep, dopo alcuni secondi la LAN dovrebbe ripartire con corretta acquisizione dell'IP.



Se non funziona, prova ad aggiungere a rc.wakeup come ultime 2 righe:


ipconfig set en0 BOOTP


ipconfig set en0 DHCP


(se la tua LAN è en1 ovviamente metti en1 al posto di en0 etc)



#4
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Grazie Giorgio,
avevo trovato la tua procedura qui ma non ho avuto risultati, forse sbaglio qualcosa nella modifica dei files rc.sleep ed rc.wakeup.
Potresti per favore guardare se ho aggiunto le stringhe nel posto giusto?

Attached Files



#5
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Nel file rc.sleep che hai postato il comando non compare

devi metterlo come ultima riga (dopo done). Ricordati lo spazio dopo kextunload

#6
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Nel file rc.sleep che hai postato il comando non compare

devi metterlo come ultima riga (dopo done). Ricordati lo spazio dopo kextunload

Hai ragione, ho postato il file sbagliato, comunque il comando l'ho messo dopo Done e senza cancelletto davanti (ho fatto un copia-incolla di quello del post)
Ovviamente i files originali sono eseguibili.
Grazie ancora della disponibilità

#7
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Prova a mettere attansic come ultimo comando del file rc.wakeup

#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Ok, dopo tante prove ed esperimenti purtroppo non risolutivi (ringrazio Giorgio per il suo supporto), ho trovato un kext che fa funzionare tutto a dovere, risveglio della LAN compreso. Chiunque avesse il mio stesso problema può trovare il kext qui

#9
artic

artic

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
scusa, per installare ML su p5k-se quale guida hai utilizzato?
Sono molto interessato, vorrei provare anchio grazie e ciao

#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Classica installazione da USB qui o qui, unica opzione di avvio necessaria in ocbp: graphicsenabler=yes; se ti dà schermo nero dopo aver caricato i kext usa PCIRootUID=0
Dimenticavo.... bios moddato per settare i dischi in AHCI
In allegato trovi l'ultima release del bios ufficiale e il bios moddato

Attached Files



#11
artic

artic

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

Classica installazione da USB qui o qui, unica opzione di avvio necessaria in ocbp: graphicsenabler=yes; se ti dà schermo nero dopo aver caricato i kext usa PCIRootUID=0
Dimenticavo.... bios moddato per settare i dischi in AHCI
In allegato trovi l'ultima release del bios ufficiale e il bios moddato

Ti ringrazio di cuore, ho provato ... grazie tante!!

Ci sono riuscito, ma dopo un po' che il computer è acceso mi dà kernel panic ... non capisco a cosa sia dovuto ...
non sò cosa sbaglio

#12
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,493 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Dunque... sei riuscito ad installare ed arrivare al desktop?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy