Jump to content

GA-Z77-D3H and 10.8


  • Please log in to reply
7 replies to this topic

#1
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I have managed to get 10.8 running fine on the following set-up, except the sound:

GA-Z77-D3H
i5 3570K
HD4000

I have tried all of the following, none of which worked:
- deleted applehda.kext, fixed permissions and installed voodoohda 2.7.3
- did the same for 2.7.4
- I have have changed the device ID

The computer boots fine with voodoohda, no kernel panic, however when I try to open the voodoo panel I get the following error: "Can't get registry entry-path"

The motherboard uses the VIA2021 chip

Has anyone succeeded getting this to work?

#2
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 869 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackintosh&Ap...
Open system preferences in 32 mode and see,have error?

#3
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Open system preferences in 32 mode and see,have error?


Makes no difference. I get the following errors:

- Wrong channels number 0..24
- Can't get registry-entry path

#4
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 869 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackintosh&Ap...
Version prefpane is the sime like kext -2.7.3?install Voodo HDA setings loader?

#5
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Anyone have any suggestions?

#6
René_

René_

    InsanelyMac Protégé

  • Donators
  • 73 posts
  • Gender:Male
  • Location:Maassluis, Netherlands
http://www.osx86.net...0_applehda.html

#7
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Thanks, I tried this method with the following results:


I deleted the original APPLEHDA and installed the new APPLEHDA and VIA2021 using kext utility. I restart and so far so good, no panics.

I then copied the DSDT.aml into the /extra folder, restart and get a kernel panic.

I have the GA-Z77-D3H (not x, m or DS3H) on F14. Processor is the i3570 and I am using HD4000. The bios setting are on default expect SATA which is set to ACHI.

Something must be causing the kernel panic on boot with the DSDT, especially since I am running the the same motherboard. I have tried editing the DSDT manually and the sound shows up in the preference panel, however no sound comes out of the speakers...



Any ideas?

#8
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
bump for OP





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy