Jump to content

OSx 10.5 install on Lion-Fusion 4.1.1

lion fusion leopard virtualisation problem

  • Please log in to reply
2 replies to this topic

#1
machstem

machstem

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi all,

Love the idea of having to pass a quiz to post. :) Hopefully I don't noob my question too much.

I followed and tried the guides I have found online, and then I fell on here to install OSx on VMWare Fusion.

My main purpose is that I have an older app I want to run (Homeworld 2), but because it requires a PowerPC, only 10.5/10.6 will support it. (my legit installs)

I have the retails disc for 10.6, but the original install disc for my MBP for 10.5...and now that I am writing this, that might be my issue...but who knows. :)

Basically, I have the following:

OSx 10.7 Lion
Fusion 4.1.1

Model Name: MacBook Pro
  Model Identifier: MacBookPro5,2
  Processor Name: Intel Core 2 Duo
  Processor Speed: 2.66 GHz
  Number of Processors: 1
  Total Number of Cores: 2
  L2 Cache: 6 MB
  Memory: 8 GB
  Bus Speed: 1.07 GHz
  Boot ROM Version: MBP52.008E.B05
  SMC Version (system): 1.42f4

My install disc is the disc that came with my laptop, version 10.5.

I followed a guide here: http://blog.michael....are-fusion-4-0/

I didn't end up making it work, but it did give me a better idea as to why I can't load it natively.

From the comments, I came here and I have since tried and retried to make it work, but after having registered, I did realized that I was attempting to run the install from a 10.5 disc that is for my MBP. Could this be the reason why I can't install it under VMWare Fusion 4.1.1 ?

My only solution other than VMWare Fusion is to dual-boot into 10.5 (haven't looked at guides for this yet), but I imagine that can work. Obviously running 10.5 virtual would be better, if only to provide me with my game over the virtual session.

Anyway, when I attempted my install, I see the Apple logo boot screen, the little spinning icon, then the Apple logo turns into a Circle+X and just hangs there are the install.

The guide here seems to focus so much more on VMWare Workstation, etc. Can someone link me to a guide specifically for Fusion 4.1.1, or at least confirm if it works?

One thing I did notice, is that VMWare Fusion had 10.7 as an option, after running your patch. It still didn't seem to go.

Thanks to any and all help!

#2
wheel

wheel

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I think the hardware-specific restore discs will boot and give you a message as such and what you're seeing is it not finding a device to boot from. The guide you posted said something about using the physical DVD drive, is that what you're using? You could try a .dmg too and see if that works better, but it seems like something is not set up right to get it to see the disc.

But that's your first problem, I think the fact that it's a restore disc will be your next problem. Your best bet is probably to use the 10.6 DVD to get rosetta rolling in Snow Leopard, with the non-server hack in that guide.

However, virtualizing emulation without GPU acceleration might result in a pretty lousy experience for you when you do get it working...

#3
machstem

machstem

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I am doing this first and foremost for the experience and the learning. The game itself I might be able to find a copy for PC and then use something like wine to run it.

At first, I was running the DVD in drive, then I made a R/W image, touched the ServerVersion.plist file in the image, chmod 044 on the image, then mount as my bootable disc. That's where eventually the Apple logo disappears and I'm left with a circle+X and the progress circle under logo continues to spin, for hours and hours to no end.

I'm off of work for a bit, but I will find time and go get my retail disc for 10.6 and 10.5 (corporate licence) to play around with.

I just wish we were given the option out of the box as it used to be.

Thanks for any other advice.





Also tagged with one or more of these keywords: lion, fusion, leopard, virtualisation, problem


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy