Jump to content

Ethernet problem on ML


  • Please log in to reply
6 replies to this topic

#1
sz4ever

sz4ever

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi everyone, i installed ML on my pc with P35-DS4 mobo and Q6600 core 2 quad cpu. The problem i have is with the ethernet. I have a PCI ethernet card with Realtek 8169SC chip. I remember that with SL i had no problem at all. With Lion the ethernet worked but it lose connectivety very often. Sometimes it fixed with a reboot, sometimes not. I thought that the problem was the Lion. This was one of the main reason i bought and upgraded to ML... The problem though, appears at least one time everyday, and i am without internet connection. I installed the official Realtek kext using ###### for the network. From a search on the internet i found that many users with real Mac pc like iMacs, Macbook pro etc have the problem. I haven't found a straightforward answer on the internet all these days. I also opened a discussion on Apple support and a user gave me some tips about locations, but it didn't work... Does anyone know what's going on and how to solve it?
Thank you in advance, Spyros...

#2
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
Try using RealtekRTL81XX.kext by lnx2mac instead of the official one.

#3
sz4ever

sz4ever

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Try using RealtekRTL81XX.kext by lnx2mac instead of the official one.

Hi, thank you for your answer. First of all my chip is not listed at the support list of the lnx2mac. Apart from that, i already tried that with no luck...

#4
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
Seeing as it's a PCI ethernet card it would be easy enough to get a compatible one.
What's wrong with your on-board ethernet?

#5
sz4ever

sz4ever

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Seeing as it's a PCI ethernet card it would be easy enough to get a compatible one.
What's wrong with your on-board ethernet?

The onboard ethernet doen't work not even in windows... It's over 1 year in this condition... It's damaged... The one i have now it's compatible, as the official realtek kext is support the 8169SC chip... What i can't understand is why owners of real mac have the same problem with me and the problem is only on Mac os X... Many of them installed Windows and don't have the problem...

#6
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
Because the kext is written by Realtek and is shoddy at best.

#7
sz4ever

sz4ever

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Because the kext is written by Realtek and is shoddy at best.

Oh, i got it... So there is nothing i can do right now right?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy