Jump to content

Probem: keyboard language always resets to US after reboots


  • Please log in to reply
1 reply to this topic

#1
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Hi,
never had that problem before 10.8.
Every reboot or boot into OS X 10.8 the keyboard language is set to US.
I can set it back to german (DE) but that holds only until next boot.

Any hint how i can fix that ? Or as an workaround freeze some .plist (by disable write permission) where the keyboard language is stored?

#2
sosuke111

sosuke111

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
The problem is a file in System/Library/Preferences/com.apple.HIToolbox.plist
I tried to save a copy in another folder and then deleting the original one and then I reselected the keyboard layout from the System Preference panel.
It seems it's working (I'm testing only from a couple of days) but is NOT THE SOLUTION. The solution shoud be modify the com.apple.HIToolbox.plist adding all the keyboard layout you want to use, my problem is to find the number ID for all keyboards layout, for example the US layout has number 0, the Italian Pro layout has number 223. I'm looking for japanese layout ID but I couldn't find it anywhere...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy