Jump to content

Can't Enable SpeedStep...


  • Please log in to reply
8 replies to this topic

#1
aphioner

aphioner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:Turkey
I have successfully installed 10.8. But my laptop's CPU always works in full speed. My CPU is Intel Core2Duo P8700 (2.53 GHz)

Please help me to enable speedstep.

Here is the terminal output for CPU clock speed:

localhost:~ Solo$ sysctl hw.cpufrequency
hw.cpufrequency: 2527000000
localhost:~ Solo$ssysctl hw.cpufrequency_min
hw.cpufrequency_min: 2527000000
localhost:~ Solo$ sysctl hw.cpufrequency_max
hw.cpufrequency_max: 2527000000



#2
aphioner

aphioner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:Turkey
I have fixed my problem. I installed VoodooPState.kext and PStateMenu app and bingo! Speedstep is working like a charm.

Posted Image

Attached Files



#3
Dorian_Grey

Dorian_Grey

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Moscow, RU

I have fixed my problem. I installed VoodooPState.kext and PStateMenu app and bingo! Speedstep is working like a charm.

Posted Image

I have installed the kext you attached and the app too BUT when I accessing PStateMenu it says "VoodooPState not loaded"
Asus VX7 Lamborghini with Mountain Lion. I got almost everything working on my laptop but I dont think my CPU working at its full perfomance...
Do you have any suggestions about that ""VoodooPState not loaded"?

#4
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
put this flag in your org.chameleon.boot.plist


<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>

#5
aphioner

aphioner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:Turkey

put this flag in your org.chameleon.boot.plist


GenerateCStates
Yes
GeneratePStates
Yes


Sorry buddy, it's been a while since you posted this reply but I've been serving in the military and now I'm back. I tried it but it didn't work.

I have 3 missing p-states. Pstatemenu and Pstatechanger recognizes the lowest frequency as 1596 MHz which is wrong.

Posted Image

VoodooMonitor shows 798 MHz as the lowest frequency which is the right value.

Posted Image

I think that this problem is related with voodoopstate.kext. Could anyone please help me?

Attached Files

  • Attached File  1.tiff   76.75KB   4 downloads
  • Attached File  2.tiff   50.32KB   2 downloads


#6
3.14r2

3.14r2

    The Round One

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,333 posts
  • Location:Molvania
@aphioner
Which Mac Model string you are using? I.E. MacBook2,1, iMac11,2...

#7
aphioner

aphioner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:Turkey

@aphioner
Which Mac Model string you are using? I.E. MacBook2,1, iMac11,2...


MacPro4,1. You think that's the case?

#8
3.14r2

3.14r2

    The Round One

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,333 posts
  • Location:Molvania
OS X has different power management scenarios for different Mac models. These scenarios have different number of C/P states available in each. You should chose your MacModel according to the CPU used. Find the Mac which has the same or at least most similar CPU to the CPU used in your system and try setting the same model.

I'd recommend MacBookPro 5,3/4/5 since the same CPU P8700 was used in mid 2009 13/15" MacBook Pros.
http://en.wikipedia....iki/MacBook_Pro

BTW with Chameleon C/P states generation enabled and the right MacModel set, no speedstep kexts are needed, it should work as is.

#9
aphioner

aphioner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:Turkey

OS X has different power management scenarios for different Mac models. These scenarios have different number of C/P states available in each. You should chose your MacModel according to the CPU used. Find the Mac which has the same or at least most similar CPU to the CPU used in your system and try setting the same model.

I'd recommend MacBookPro 5,3/4/5 since the same CPU P8700 was used in mid 2009 13/15" MacBook Pros.
http://en.wikipedia....iki/MacBook_Pro

BTW with Chameleon C/P states generation enabled and the right MacModel set, no speedstep kexts are needed, it should work as is.


Thanks buddy. I'm using MacPro4,1 now and power management works like a charm :thumbsup_anim: I'm a Hackintosh user for more than 3 years and finally I got my system fully working as it supposed to be.

I got all the power states from 798 MHz to 2527 MHz. All I did was to remove NullCPUPowerManagement.kext and VoodooPstate.kext and install this specific version of VoodooPowerMini.kext (Version 1.2.49).

I don't know if it works with other CPUs but it get the job done on a Intel C2Duo P8700 laptop.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy