Jump to content

Gigabyte Z77X-UD5H + 9800GTX+


  • Please log in to reply
8 replies to this topic

#1
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
HI

I am trying to install Mountain Lion on a Gigabyte Z77X-UD5H with a 9800GTX+ graphics card.

I have a ML usb stick I have created which works, but when it comes to OSX installation window, the screen goes into power saving mode and no video ports display anything , even the onboard.

I am going to guess this is because I need a DSDT for the 9800GTX to work.

How can I get a clean DSDT file and edit it for my graphics card?

Help appreciated.

#2
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
I know I only asked an hour or so ago, but I am desperate.

I feel lost!.

I think what I need to do is get a DSDT file from my computer (using DSDTSE for Windows, Extract DSDT). Then I need to input the fix for the 9800GTX+, does that sound right?

#3
everdone

everdone

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
What attempts have you made to date? Try with GraphicsEnabler=Yes and then No. Try with only the on-board video. Try with bootflag -x. If you can borrow, or have aviable, a different video card. I have found most 9500GT cards will work with MLion (although I have one that doesn't).Try different versions of Chameleon. I am using r1995 but the revision is above r2000 now, maybe the newest will work.

I have read that the Gigabyte Z77X boards do not really need a DSDT (do not have actual experience personally), so it's not likely a patched DSDT would be successful.

I have also found that once installed ML behaves differently from the installer. I have a ATI6570 card which the ML installer will not recognize, but once installed it plays nicely. I used a 9500GT to install then switched to the 6570.

Don't give up, you will find a solution!

#4
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
HI

I really think it is to do with the DSDT. I used a DSDT for a few things on my old board - but as you have said there doesnt seem to be a need for DSDT on this board, except for the Graphics card (9800GTX+) which is not supported out the box as far as I know.

I am trying to insert the graphics info myself in to an extracted DSDT but I really do not know what I am doing - not an expert with this kind of thing.

I just tried with graphics enabler set to no, still doesnt' work. Nor does the onboard graphics. I am really at a loss as what to do.
----------


Part 2

Ok I have made a bit of progress. Have got video but using the HD4000 onboard graphics, using Chimera 1.10. Installing OSX at the moment.

Still need to get the Geforce 9800GTX working though.

Does anyone know how to get it working on mountain lion? Can anyone edit my DSDT.dsl file and send me a working .aml file?

Thanks

#5
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
Right just an update as to where I am at.

I am in OSX, using the HD4000 graphics card. The 9800GTX is detected by OSX, but I cannot use it as a main display, only as a secondary.

If I connect the monitor to the 9800GTX, when it should be loading the desktop, the screen goes into powersaving mode.

If I disable the onboard graphics in the BIOS, it still doesnt' work. I still need to get the 9800gtx working.

I am dessssperrrateee for someone to help. THanks

#6
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
Sweet jesus i've done it.

Managed to figure out what to copy from my old DSDT into a new one. Sorted :D

#7
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

Sweet jesus i've done it.

Managed to figure out what to copy from my old DSDT into a new one. Sorted :D



http://www.insanelym...howtopic=252525 :whistle: :D

#8
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
THanks :)

I now have a problem with audio. I dunno if I need to modify the DSDT to enable me to use a patched AppleHDA.kext?

Ergh,
Anyone have any ideas

#9
stuppy_

stuppy_

    InsanelyMac Geek

  • Donators
  • 114 posts
Well, everything is pretty much sorted now.

Graphics: Copied the GFX block from old DSDT to new one. Quite simple when I sat and thought about it instead of panicing.
Sound: Used ###### to install an Enabler and patched HDA (I do not have HDEF in DSDT)
Network: Using onboard Atheros card, didn't bother with the Intel chip. Used an Atheros kext that someone had posted on here

I have tried getting sleep to work, everyone who has a UD5H seems to be able to sleep and wake without problem, but I can't get it working. Luckily the computer never sleeps so its not really an issue for me.

Overclocked to 4.0ghz, but I have no idea if OSX is taking advantage of the extra speed. I will look more into this later.

For now though it seems to be rock solid! Thank god





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy