Jump to content

[HELP] Lenovo Thinkpad T420 10.7.2 HD 3000 i5 2450M!


  • Please log in to reply
No replies to this topic

#1
stevenplanet

stevenplanet

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Hi guys! I'm a new member to this forum and have recently been browsing hundreds of threads on the installation of Lion on Intel Computers. I have learned quite a lot but unfortuntely not enough. I was hoping you guys could help me out. I own a Lenovo Thinkpad T420 4177 with an i5 2450m Processor. I installed using iAtkos L2. And before you nail me on this one I did try the Lion retail version first. I bought it from the app store on my sister's Macbook and created a bootable USB Drive. Black Screen everywhere. :( So I had to sidestep to this method.

Things that ARENT WORKING :(

Video: I'm stuck at a really basic resolution. Quite painful on the eyes. I have used ###### to try to install Kexts from here:

Sound: I tried the modded AppleHDA.kext found here:
But I keep getting the popup message that says "System extension cannot be used The system extension "/System/Library/Extensions/AppleHDA.kext was installed improperly and cannot be used. Please try reinstalling it, or contact the produc's vendor for an update."

I used ###### for both. And I deleted the vanilla AppleHDA kext before using ###### to put in the modded version.

Things that WORKED with some work :)
Keyboard, Multitouch on the trackpad and the right and left clicking keys are working!
Wifi is working after buying a Broadcom half card off ebay!
I can boot into OSX! (<-greatest achievement thanks to you guys!)


hope you guys can help me fix these nasty bugs!

P.S - while typing this message I got a bunch of more "improperly installed kext" messages about various kexts. I closed them too fast to see which ones. :(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy