Jump to content

ventole e usb non si spengono


  • Please log in to reply
35 replies to this topic

#1
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Ciao a tutti ho un problema da quando sono passato a lion 10.7.4 quando spengo il computer mi rimangono accese le ventole e anche le usb, ho provato a togliere applehpet.kext senza questo quando spengo si spegne tutto ma al riavvio dopo poche minuti che lavoro al computer va in KP
vi prego un aiuto

#2
pianman

pianman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 406 posts
  • Gender:Male

Ciao a tutti ho un problema da quando sono passato a lion 10.7.4 quando spengo il computer mi rimangono accese le ventole e anche le usb, ho provato a togliere applehpet.kext senza questo quando spengo si spegne tutto ma al riavvio dopo poche minuti che lavoro al computer va in KP
vi prego un aiuto


Hai provato la patch fix per AppleRTC.kext? Inoltre stacca tutte le periferiche usb, se si spegne correttamente qualcuna di esse ti dà problemi.

#3
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Astrai il DSDT originale e allega anche quello patchato.
org.chameleon.boot.plist ed smbios anche.

#4
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Ti allego quello che uso e quello estratto

Attached Files



#5
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Se non alleghi il DSDT originale non ti posso aiutare.
Per ottenerlo o togli il DSDt dalla cartella Extra, riavvii il pc e lo estrai, oppure al boot dai un percorso fasullo al Chameleon ex: DSDT=/aaaaaaaaaaaaaa

p.s. ho individuato un errore grave nel dsdt ed anche la causa del mancato spegnimento.

#6
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Ho riavviato come hai detto tu questo è il dsdt

Attached Files

  • Attached File  dsdt.zip   27.09KB   1 downloads


#7
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Ecco fatto, mettilo in Extra e riavvia.
Se tutto va per il meglio, il passo successivo sarà quello di eliminare il nullcpu, ricostruire la cache e riavviare
Attached File  DSDT.aml.zip   14.01KB   1 downloads

#8
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Allora l'ho appena provato le ventole adesso si spengono vedo però gli HD interni gialli come fossero esterni
devo ancora togliere il nullcpu

#9
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Gli HDD li vede gialli perché ho tolto l'iniezione (sbagliata) nel device SATA.

Installa IOAHCIBlockStorageInjector.kext , se il problema dovesse persistere installa anche l'altro kext.


Attached File  kext.zip   20.49KB   4 downloads

#10
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Ok fatto è bastato installare il primo kext IOAHCI....
adesso cosa devo fare mi parlavi di togliere il nullcpu o sbaglio

#11
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Esatto, ora elimina il nullcpu e ricostruisci al kernel cache.
allega anche un kernel.log così facciamo una bella scansione ..ok?

#12
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Fatto ecco il kernel log
una cosa neanche l'audio va perfettamente prima di aggiornare andava bene ora invece ho dovuto usare VoodooHDA-2.7.3 ma non è perfetto

Attached Files



#13
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Non andiamo bene

sostituisci il FakeSMC con questo e ricostruisci la kernel cache Attached File  FakeSMC.kext.zip   56.03KB   12 downloads

poi se ottieni ancora questi errori:


May 21 18:55:02 Mac-Pro-di-Pippo kernel[0]: ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed
May 21 18:55:02 Mac-Pro-di-Pippo kernel[0]: DSMOS has arrived
May 21 18:55:02 Mac-Pro-di-Pippo kernel[0]: ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed
May 21 18:55:02 Mac-Pro-di-Pippo kernel[0]: ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized


Aggiungi in org.chameleon.boot.plist:


<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>DropSSDT</key>
<string>Yes</string>


poi riavvii e riguardi il kernel.log

#14
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Ho fatto quello che mi hai detto questo è il nuovo kernel.log

Attached Files



#15
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Bene, ci siamo quasi ...

il FakeSMC l'hai installato però? Dal kernel.log sembra di no.

elimina prima il vecchio e poi reinstalla il nuovo, poi ricostruisci la kernel cache e riavvia.

#16
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Prova a vedere adesso, poi dimmi se hai qualche idea per l'audio

Attached Files



#17
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Sembrerebbe tutto regolare...

riguardo l'audio ..prima funzionava bene? Ma stavi usando l'AppleHDA oppure il VoodooHDA?

#18
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Prima usavo AppleHDA poi dopo l'aggiornamento ho installato VoodooHDA perché l'altro non andava questo però va ma non bene come prima

#19
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,536 posts
  • Gender:Male
  • Location:Italy
Si ma reinstallando il vecchio AppleHDA? Quando effettui l'aggiornamento è normale che il kext viene sovrascritto.
Riesci a passarmi quel kext?

#20
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 547 posts
  • Gender:Male
  • Location:Treviso
Non ne sono sicuro ma mi sembra questo

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy