Jump to content

BlackScreen - ATI HD 5650 - Acer Aspire 7741G - Lion 10.7.2

5650 7741G 5650m Acer Aspire 7741G ATI Mobility Radeon HD 5650

  • Please log in to reply
1 reply to this topic

#1
dj_reno

dj_reno

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hello all,

I'm having problems to configure the graphics card "ATI Mobility Radeon HD 5650" in my laptop Acer Aspire 7741G.

Laptop Components:

- Core i3 370M
- RAM 6 GB (
Pending up to 8GB)
- Mobility Radeon HD 5650
- 17.3" LED CineCrystal TFT


I performed the installation with DVD iAtkos L2 Hackintosh Lion 10.7.2 (Mac OSX). The installation was successful. This is the hardware that I detect:

1) Sound -> RealTek ALC272 -> is OK (By kext)
Attached File  Realtek_ALC272.png   260.24KB   45 downloads
2) Ethernet -> BroadCom BCM57780 --> is OK (By kext)
Attached File  Ethernet.png   326.19KB   45 downloads
3) Wifi -> BroadCom BCM43225 --> Non Ok (I tried several options without results)
Attached File  Wifi_BCM43225_01.png   267.71KB   29 downloadsAttached File  Wifi_BCM43225_02.png   265.8KB   11 downloads
4) VERY IMPORTANT!! Graphics Card -> ATI Mobility Radeon HD 5650 --> Non Ok (I tried several options without results)
Attached File  5650_ATI_01.png   267.96KB   140 downloadsAttached File  5650_ATI_02.png   312.85KB   127 downloads

Although the wireless does not work, does not worry me much, since I have Ethernet. My problem comes when I want to change the resolution to the laptop's internal display. Only I can choose 1024x768. I have been reading several forums and have followed the steps in this forum -> http://www.osx86.net...do=file&id=1502,

Using AtiConfig=Hoolock and GraphicsEnabler=Yes, This does not work, only lets me access by GraphicsEnabler = No.

I used ELDIM - EDIDViewer to get the EDID. Exhibits 3 monitors to choose:

1) AUO139E (Active 1600x900):

* RAW Data:

0x00 00 FF FF FF FF FF FF 00 06 AF 9E 13 00 00 00 00
0x10 01 13 01 03 80 26 15 78 0A C4 95 9E 57 53 92 26
0x20 0F 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
0x30 01 01 01 01 01 01 F8 2A 40 90 61 84 0C 30 30 20
0x40 36 00 7E D6 10 00 00 18 00 00 00 0F 00 00 00 00
0x50 00 00 00 00 00 00 00 00 00 20 00 00 00 FE 00 41
0x60 55 4F 0A 20 20 20 20 20 20 20 20 20 00 00 00 FE
0x70 00 42 31 37 33 52 57 30 31 20 56 33 20 0A 00 26

* Convert to Base64=>

AP///////wAGr54TAAAAAAETAQOAJhV4CsSVnldTkiYPUFQAAAABAQEBAQEBAQEBAQEBAQEB+CpAkGGEDDAwIDYAftYQAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTczUlcwMSBWMyAKACY=

2) SNY0801:

* RAW Data:

0x00 00 FF FF FF FF FF FF 00 4D D9 01 08 01 01 01 01
0x10 01 11 01 03 80 A0 5A 78 0A 0D C9 A0 57 47 98 27
0x20 12 48 4C 21 08 00 01 01 01 01 01 01 01 01 01 01
0x30 01 01 01 01 01 01 66 21 50 B0 51 00 1B 30 40 70
0x40 36 00 40 84 63 00 00 1E 01 1D 00 72 51 D0 1E 20
0x50 6E 28 55 00 40 84 63 00 00 18 00 00 00 FC 00 53
0x60 4F 4E 59 20 54 56 0A 20 20 20 20 20 00 00 00 FD
0x70 00 30 3E 0E 30 09 00 0A 20 20 20 20 20 20 01 72

* Convert to Base64=>

AP///////wBN2QEIAQEBAQERAQOAoFp4Cg3JoFdHmCcSSEwhCAABAQEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAQIRjAAAeAR0AclHQHiBuKFUAQIRjAAAYAAAA/ABTT05ZIFRWCiAgICAgAAAA/QAwPg4wCQAKICAgICAgAXI=

3) TCL0000:

* RAW Data:

0x00 00 FF FF FF FF FF FF 00 50 6C 00 00 01 01 01 01
0x10 01 15 01 03 80 3A 20 78 0A 0D C9 A0 57 47 98 27
0x20 12 48 4C 21 4B 00 01 01 01 01 01 01 01 01 01 01
0x30 01 01 01 01 01 01 66 21 50 B0 51 00 1B 30 40 70
0x40 36 00 44 40 21 00 00 18 01 1D 00 72 51 D0 1E 20
0x50 6E 28 55 00 44 40 21 00 00 1E 00 00 00 FC 00 20
0x60 20 20 20 20 44 54 56 20 20 20 20 20 00 00 00 FD
0x70 00 32 55 0E 46 10 00 0A 20 20 20 20 20 20 01 9B

* Convert to Base64=>

AP///////wBQbAAAAQEBAQEVAQOAOiB4Cg3JoFdHmCcSSEwhSwABAQEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAREAhAAAYAR0AclHQHiBuKFUAREAhAAAeAAAA/AAgICAgIERUViAgICAgAAAA/QAyVQ5GEAAKICAgICAgAZs=

----

I tested with 3 monitors, but the screen always shows wrong (Multiple screens with horrible resolution) Attached image of the error:

Example DisplayProductID-717:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>DisplayProductID</key>
<integer>1815</integer>
<key>DisplayProductName</key>
<string>Internal LCD Forced EDID</string>
<key>DisplayVendorID</key>
<integer>1970170734</integer>
<key>IODisplayEDID</key>
<data>
AP///////wAGr54TAAAAAAETAQOAJhV4CsSVnldTkiYPUFQAAAABAQEBAQEBAQEBAQEBAQEB+CpAkGGEDDAwIDYAftYQAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTczUlcwMSBWMyAKACY=
</data>
</dict>
</plist>

Thanks!

--------------------------------------------------------------------------------------------------------------------------------------------------------------

Second testing:

I made the modification to the start of many AtiConfig=<option> and EDID AUO139E.

Graphics Card detected in all AtiConfig is ATI 5000, except Orangutan, showing ATI Mobility Radeon 5650 HD.

Alouatta	  -   Same screen error (multiple screens) and horrible resolution.
Baboon	   -   Same screen error (multiple screens) and horrible resolution.
Cardinal	  -   Black Screen, access with VNC is perfect, HDMI OK.
Caretta		-   Not start, panic Error.
Colobus	   -   Same screen error (multiple screens), horrible resolution , VNC is perfect.
Douc		   -   Same screen error (multiple screens) and horrible resolution.
Eulemur	  -   Same screen error (multiple screens) and horrible resolution.
Flicker		 -   Same screen error (multiple screens), horrible resolution , HDMi is perfect.
Galago		-   Same screen error (multiple screens) and horrible resolution.
Gliff			 -   Black Screen, access with VNC is perfect, HDMI OK.
Hoolock	   -   Same screen error (multiple screens) and horrible resolution.
Hypoprion	-   Black Screen, access with VNC is perfect, HDMI OK.
Iago			 -   Same screen error (multiple screens) and horrible resolution.
Kakapo		-   Black Screen, access with VNC is perfect.
Kipunji		   -   Same screen error (multiple screens) and horrible resolution.
Lamna		  -   Black Screen, access with VNC is perfect, HDMI OK.
Langur		  -   Same screen error (multiple screens) and horrible resolution.
Megalodon	-   Black Screen, access with VNC is perfect, HDMI OK.
Motmot		  -   Not start, panic Error.
Nomascus	 -   Not start, panic Error.
Orangutan  -   Black Screen, access with VNC is perfect, HDMI OK. Graphics Card -> ATI Mobility Radeon 5650 HD
Peregrine	 -   Black Screen, access with VNC is perfect, HDMI OK.
Quail			-   Not start, panic Error.
Raven		  -   Black Screen, access with VNC is perfect, HDMI OK.
Shrike		  -   Not start, panic Error.
Sphyrna	   -   Not start. System HALTED!!!
Triakis		 - Without Testing.
Uakari		 - Without Testing.
Vervet		  - Without Testing.
Zonalis		- Without Testing.

Conclusion: Lion does not detect my laptop's internal monitor so the screen does not show well with GraphicsEnabler = Yes. The only configuration that detects the graphics card correctly is Orangutan, but I get black screen on laptop screen.

Examples Orangutan ScreenShots by VNC:
Attached File  5650_ATI_01.png   267.96KB   140 downloadsAttached File  5650_ATI_02.png   312.85KB   127 downloads

What should I do?

Thanks!

------------------------------------------------------------------------------------------------------------------------------------------------------

#2
dj_reno

dj_reno

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
ScreenShot when "Same screen error (multiple screens) and horrible resolution".

Attached File  20120320_161832.jpg   66.1KB   54 downloads





Also tagged with one or more of these keywords: 5650, 7741G, 5650m, Acer Aspire 7741G, ATI Mobility Radeon HD 5650


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy