Jump to content

Troubleshoot iATKOS v7 - HP Pavilion dv6-3120us Notebook

iatkos v7 dv6-3120us ioapic freeze 6b0d4f0 amd pavilion hp vectors

  • Please log in to reply
No replies to this topic



    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi there, I had been trying to install iATKOS v7 for my HP laptop. I must say that I've made it pretty far just Googling and what not, but now I need true help. :\
In case you were wondering, I am using another laptop to look up solutions and for posting this thread.

Now, I'll try and explain the steps that I took from the beginning...

I first of all formated and created two partitions, both HFS(?)+, one 100GB and the other 350GB using GParted. After that, I began booting from iATKOS v7's iso disc using "-v" param, and immediately, I was greeted by a frozen screen with "IOAPIC: Version 0x21 Vectors 0:23". On Google, I found only one fix, it stated that I had to disable "USB Legacy Mode" from BIOS settings, wait until the disc stopped spinning, and plug in a USB flash drive and unplug it before restart after installation, didn't work for me.
In one of the comments, I read about somebody trying out some other boot parameters before learning about the USB trick, it was to type "io=0x21 -s -f" and that his booting will go further than before, but get stuck and freeze at
Root device is mounted read-only

If you want to make modifications to files:
			/sbin/fsck -fy
			/sbin/mount -uw /

If you want to boot the system:

Same thing happened to me, except my screen wasn't frozen. So I followed the steps, and entered the two given commands, "/sbin/fsck -fy" and "/sbin/mount -uw /," and bam, a while later, I was on iATKOS OSx86's installation screen. These are the settings I chose (most of these are based off the device names, I had Ubuntu on before this and pulled out the device names and IDs through the Terminal):
iATKOS v7 Main System

Bootloader > Chameleon v2

X86 Patches > /Extra directory
X86 Patches > DSDT
X86 Patches > Decrypters > AppleDecrypt
X86 Patches > Disabler

Drivers > VGA > ATI > ATI HD
Drivers > System > SATA/IDE > ATI SATA/IDE
Drivers > System > CardBus Driver
Drivers > System > USB
Drivers > System > Sound > Voodoo HDA Driver
Drivers > Network > Wired > Realtek > Realtek RTL8139
Drivers > Network > Wireless > Ralink > Ralink RT2860 PCI

Post-Install Actions
Any package branch not mentioned above was not installed.

After the installation, I let the computer restart, and boot itself from the HDD. When Chameleon first shows up, I press "any key" for the startup options, then, with my correct partition selected, I type "-v" and press the Enter key, and after not too long, I get stuck at "IOAPIC: Version 0x21 Vectors 64:87" seem familiar? Like the last time I had an "IOAPIC" error, I restart my system, and this time, I use the parameters "io=0x21 -s -f", I yet again, make it a lot farther this time, but this time, my installation freezes at "config(6b0d4f0): terminating". (I also tried booting with "io=0x21" alone, but I still from at the "IOAPIC" line).

I feel like I've made it so far, just by collecting information from here and there, and I really don't have the heart to go back to Windows after coming so far with OSx86, any help will be great... :(

EDIT: I tried again, but now, my computer keeps restarting before booting.


Also tagged with one or more of these keywords: iatkos v7, dv6-3120us, ioapic, freeze, 6b0d4f0, amd, pavilion, hp, vectors

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy