Jump to content

Leo4All on Dell Inspiron 531s - stuck at identifying keyboard

10.5 dell 531s keyboard

  • Please log in to reply
5 replies to this topic

#1
DougJoseph

DougJoseph

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Clarksburg, WV, USA
I got OS X 10.5.2 installed on a Dell Inspiron 531s using the Leo4All distro.

I used the NVidia settings and the NForce settings.

This PC has no PS2 ports. The keyboard is attached via USB.

The PC boots into OS X and plays the Welcome animation video, then says the keyboard needs to be identified.

The OS asks me to press a couple of keys, which it detects, and then it allows me to complete the setup assistant, choosing language, etc.

However, then instead of going on into the OS main desktop screen, it loops back to the beginning and plays the Welcome animation video again, and then again says the keyboard needs to be identified.

It loops just like that as many times as I let it.

Does anyone know a way to trick the system into getting past this setup assistant saying it cannot identify the keyboard? It clearly can detect the key presses.

Thanks for any tips or suggestions or ideas.

#2
DougJoseph

DougJoseph

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Clarksburg, WV, USA
Update on progress:

I followed the direction on this post:

http://www.insanelym...dpost&p=1766283

...To remove the lines for:

  <string>DeviceSection</string>
  <string>KeyboardTypeSection</string>

That made the Setup Assistant not ask for the keyboard to be identified.

However...

The problem of the OS looping back to the Welcome animation video after completion, is still happening.

Anyone have any other ideas?

PS: In the linked post, the actual path was more like: System/Library/CoreServices/...

#3
DougJoseph

DougJoseph

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Clarksburg, WV, USA
Another quick update. I found this post:
http://www.insanelym...showtopic=84879

...which is from a different distro but the same problem. Worth a shot. I am redoing the install from scratch and this time leaving the Nforce network choice unchecked. Will post back.

#4
DougJoseph

DougJoseph

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Clarksburg, WV, USA
Leaving the Network option unchecked did not help. Still trying variations.

#5
DougJoseph

DougJoseph

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Clarksburg, WV, USA
Found a way past the endless loop of the repeating Setup Assistant.

Once you reboot after the installation completes, you will be told to help with identifying your keyboard. Then you will be asked if you want to transfer information from another Mac or backup and various other options. Regardless of your choice, this typically results in an endless loop of replaying the Welcome video and showing the Setup Assistant. You can bypass this step by booting with the -s option as follows:
  • When you boot the machine, at the initial screen where it says "press any key to enter startup options" press any key. Then press "-s" (without the quotes) and hit Enter.
  • You should now be at the terminal. Type "/sbin/fsck -fy" (again, without the quotes) and hit Enter.
  • Type "/sbin/mount -uw /" and hit Enter.
  • Type "cd /Volumes/YOUR DISK HERE/var/DB" and hit Enter. If your disk name has spaces, you may need to wrap it in quotes. (Not sure on that. I had to.)
  • Type "touch .AppleSetupDone" and hit Enter.
  • Type "passwd" and hit Enter. Follow the prompts to set a root password for the laptop. Do not forget this password.
  • Type "exit" and hit Enter to reboot.
  • At the login window, log in as "root" with the password that you just created.
  • Go to System Preferences and create a regular user to your specifications.
  • Log out as root and back in as the user you just created.


#6
DougJoseph

DougJoseph

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Clarksburg, WV, USA
Just found something during booting this AMD unit that caught my eye:

"ACPI: Button Driver prevents system sleep."

I searched and found this helpful topic by Spart:

http://www.insanelym...ndpost&p=321115

I have had an issue with my AMD Hackintosh (specs in the sig) since the first time I installed JaS 10.4.8: kernel_task is always at 20%.

I never could find any information about this issue, as most of the time kernel_task is at nearly 100% and it is due to settings in the BIOS like dynamic overclocking, or a poorly clocked processor. I tried messing with everything I could think of to no avail: kernel_task stayed at 20%.

Recently I updated with every security update available, and in the process switched my boot flag to -v so as to better watch for errors during boot.

One thing that I noticed that never caught my eye before was this:

ACPI: Button Driver prevents system sleep.

My system also hadn't been sleeping quite properly, it would shut down the hard drives and network connections but that was about it. So I decided to give a shot at fixing that.

I dug around in AppleACPIPlatform.kext and found the culprit: AppleACPIButtons.kext

To get rid of this little guy, do the following in single user mode:

cd /System/Library/Extensions/AppleACPIPlatform.kext/Contents/PlugIns/
mv AppleACPIButtons.kext AppleACPIButtons.kext.bak
cd /System/Library/
rm Extensions.kextcache
rm Extensions.mcache
reboot

My OS X is now purring along even smoother, sleep works very well now, and as a semi-random side-effect, kernel_task stays at a meek 2%.


However, whenever I try to follow these steps, my AMD Hackintosh (10.5.2) desktop becomes unbootable. Anyone have any advice?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy