Jump to content

Acer Aspire 5670/5671 10.6.X "work in progress" Guida

Aspire 5670 5671 Snow Leopard

  • Please log in to reply
7 replies to this topic

#1
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
Ciao Ragazzi,
per chi fosse interessato ed in possesso di un acer Aspire 5670 o 5671, sono riuscito a far girare Snow Leopard fino alla 10.6.7 con installazione da retail.
Le caratteristiche del portatile sono le seguenti:

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port [8086:27a1] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M56P [Radeon Mobility X1600] [1002:71c5]
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express [14e4:169d] (rev 21)
03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) Sostituita l'originale Intel 3945
07:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
07:06.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
07:06.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
07:06.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

Primo Passo:

Installazione SL 10.6.0 tramite disco retail e Nawcom Modcd 0.3 che potete trovare quì utilizzando i flag: mach_kernel -v
l'installazione sarà semplice e fluida, al primo riavvio dovrete utilizzare i flag:
-v cpus=1 (in caso contrario rimarrà bloccato su IOAPIC)

a questo punto avrete installato tutto perfettamente, quello che vi consiglio, è di installare subito il Combo update alla 10.6.7
quindi al riavvio -v cpus=1

Fatto ciò è il momento di personalizare le impostazioni di avvio per fare ciò dovrete inserire alcuni kext sia in Extra che in Extensions e poi cosa più importante estrarre il DSDT e patcharlo.

A breve posterò un pacchetto già pronto di file da sostituire in modo da risolvere i problemi di boot e riconoscimento delle periferiche, attualmente vi indico cosa va e cosa no:

Ati Radeon X1400: Funziona con QE/CI e risoluzione 1280x800, purtroppo solo a 32Bit :wallbash:

Audio ALC 883: Funziona perfettamente ma solo dalla 10.6.6 in poi, almeno con i kext che ho!

Firewire: OOB

Webcam: Non Funziona :hammer:

Wireless BCM4311: OOB

Ethernet BCM5789: purtroppo è l'unica cosa che non riesco a far funzionare e non riesco a capire il perche, i kext trovati mi danno tutti lo stesso problema all'avvio "Memory Dump Failed" ecco il motivo per cui non ho postato il kext pack per tutto il resto, voglio prima vedere se riesco a risolvere il problema.

Se qualcuno di voi riesce a darmi una mano con la scheda di rete lo apprezzo volentieri, anche perchè ci lavoro da 10gg ed il mio cervello è andato in Kernel Panic :help:

Good Luck to everyone!

*AGGIORNAMENTO*= molti utenti mi hanno scritto in merito a questo notebook ed a questa guida, chi volesse eseguire la procedura, ed ha bisogno di aiuto, scriva sul post e non tramite PM, in quanto non si creerebbero post ed info utili a chi volesse provare l'installazione. Non pensate che sia sgarbato, ma credo sia giusto nei confronti di chi segue e legge il forum. :wink2:


*NOTA* = Attenzione, a seguito di vari test con altri utenti, prima di utilizzare i file allegati, verificate esattamente il modello del notebook scritto sul fondo, in quanto ho notato che al variare dei modelli le differenze non sono minime.

*NOTA 2*: Qui di seguito troverete i file necessari all'istallazione.

Attached File  Extra.zip   486.3KB   17 downloads nella cartella Extra troverete anche il dsdt patchato, prima di usarlo verificate che sia uguale al vostro!!

Attached File  Ati X1400.zip   948.46KB   18 downloads Kext Ati X1400 solo 32Bit

Attached File  Audio 10.6.6.zip   1.21MB   21 downloads Kext Audio funzionante solo da 10.6.6 in su

Attached File  S-L-E.zip   25.27KB   18 downloads Kext da installare su System/Library/Extensions

#2
repe

repe

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Ciao io ho installato su l mio pc desktop leopard 10.5.3 e funziona tutto perfettamente ora sono entrato in possesso di un acer aspire 5673 wlmi e vorrei installarci sopra snow leopard.
Seguendo la guida di FilHAck sono riuscito con il Nawcomm mod Cd ad installare la versione retail 10.6.0 e poi ad aggiornare con la combo update 10.6.7; il problema é che non riesco a patchare il kernel ne' con ##### ne' con userDSDT, al riavvio ottengo "can't find match kernel".
Oltre a questo problema non riesco a capire se esistono kext funzionanti per la mobility radeon x1600 con id 71c5 e per la scheda di rete broadcom 5789(almeno in snow leopard) ho letto un bel po' di post su vari forum ma non mi e' ancora chiaro se qualcuno sia riuscito ad installare con successo queste due periferiche.
Ho provato anche iatkos s3 v2 e anche in questo caso ho problemi con la scheda grafica e la scheda di rete( la vga viene rilevata come 4890?!no CI e no QE).
Qualsiasi suggerimento e' ben accetto :D
Grazie e ciao

#3
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
allora il problema è questo, con il nawcom non devi usare ne ##### ne altro in quanto faremo un installazione con kernel originale quindi Vanilla...ora quello che ti consiglio è di ripartire da un installazione pulita con un semplice accorgimento, quando avvii da cd nawcom alla schermata nera metti la retail di snow premi f5 poi selezioni l'icona del dvd di installazione, quindi, digita: mach_kernel -v
a questo punto partirà la nuova installazione quindi appena fatto dovresti sapere già come và visto che lo hai già fatto, non devi fare null'altro che installare la combo 10.6.7 non oltre perché non ti si avvia più per problemi con iopcifamily.kext

intanto parti da qui, appena hai fatto tutto iniziamo con le modifiche per far funzionare quel che si può.

#4
repe

repe

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Ok scusami sono stato via nel week-end questa sera appena arrivo a casa provo.
Grazie ti faccio sapere al piu presto. B)

#5
repe

repe

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Ciao ho provato ad avviare l'installazione con mach_kernel -v ma il sistema si blocca su "virtual bool IOHIDEventSystemUserClient::initWithTask(task*, void*, UInt32): Client task not privileged to open IOHIDSystem for mapping memory" anche avviando aggiungendo il boot-flag -x.
Questa sera provero' a cercare una soluzione.

#6
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
ma hai usato nawcom mod cd?

#7
repe

repe

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Si nawcom mod cd con match_kernel non mi parte nemmeno l'installazione.....

#8
FiLhAcK

FiLhAcK

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
devi scrivere mach_kernel non match!!





Also tagged with one or more of these keywords: Aspire 5670 5671, Snow Leopard


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy