Jump to content

Asus GTX 560 (NON TI!) Support on Lion


  • Please log in to reply
49 replies to this topic

#41
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,064 posts
  • Gender:Male
  • Location:Brazil
Just like CUDA, OpenCL has no impact on framerate, unless you're benchmarking OpenCL or CUDA specifically. Neither is necessary in order to play games, there is no benefit to patching OpenCL or installing CUDA unless you're using production software that specifically requires them to be installed.

#42
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Sorry, was on windows playing guild wars 2. Gonna try moving to macpro 4,1 and all those suggestions


Last login: Fri Feb  8 20:29:33 on console

localhost:~ danny$ sudo perl -pi -e '$c++ if s|\x8b\x87\x1c\x0c\x00\x00\x89\x06\x8b\x­87\x20\x0c\x00\x00\x89\x02|\x31\xc0\xff\­xc0\xff\xc0\x89\x06\x31\xc0\x89\x02\x90\­x90\x90\x90|; END { unless ($c) { warn "No substitutions made\n"; $? =1 } }' /System/Library/Extensions/GeForceGLDriv­er.bundle/Contents/MacOS/libclh.dylib

Password:

Can't open /System/Library/Extensions/GeForceGLDriv­er.bundle/Contents/MacOS/libclh.dylib: No such file or directory.

No substitutions made

localhost:~ danny$ sudo perl -pi -e '$c++ if s|\x8b\x87\x1c\x0c\x00\x00\x89\x06\x8b\x­87\x20\x0c\x00\x00\x89\x02|\x31\xc0\xff\­xc0\xff\xc0\x89\x06\x31\xc0\x89\x02\x90\­x90\x90\x90|; END { unless ($c) { warn "No substitutions made\n"; $? =1 } }' /System/Library/Extensions/GeForceGLDriv­er.bundle/Contents/MacOS/libclh.dylib

Can't open /System/Library/Extensions/GeForceGLDriv­er.bundle/Contents/MacOS/libclh.dylib: No such file or directory.

No substitutions made

localhost:~ danny$





#43
KrazyKiwi

KrazyKiwi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Interests:Getting OSX to work with my PC

Just like CUDA, OpenCL has no impact on framerate, unless you're benchmarking OpenCL or CUDA specifically. Neither is necessary in order to play games, there is no benefit to patching OpenCL or installing CUDA unless you're using production software that specifically requires them to be installed.


Thats true but some users have reported doubling their FPS on the GTX 560 in Cinebench by enabling OpenCL.

It looks like terminal cant find the GeForceGLDriver.bundle. This either means that you dont have the GeForceGLDriver.bundle installed of that it cant find the file that will enable OpenGL for your card. Can you find the .bundle in the finder?

#44
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Yeah, it's there. I think I made that change a while back, which is why the substitutions were not made

http://d.pr/i/Nkbj

http://d.pr/i/uLEy

#45
KrazyKiwi

KrazyKiwi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Interests:Getting OSX to work with my PC

Yeah, it's there. I think I made that change a while back, which is why the substitutions were not made


That could be why, but the code said that it couldn't find the file or directory, so there might be a part of the .bundle that got deleted. Can you send me the .bundle?

#46
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,064 posts
  • Gender:Male
  • Location:Brazil

some users have reported doubling their FPS on the GTX 560 in Cinebench by enabling OpenCL.


That doesn't make any sense, Cinebench is an OpenGL 2.0 benchmark, OpenCL is not involved at all.

#47
KrazyKiwi

KrazyKiwi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Interests:Getting OSX to work with my PC

Cinebench is an OpenGL benchmark, it has nothing to do with OpenCL.

I know, it was just a suggestion I found on the TonymacX86 forums. A user posted that he saw significant increases in his GPU benchmark performance when he enabled OpenCL for his GTX 560 Non-TI.

Here is his post

Hello friend.

I use Asus GTX 560 Direct CU (not Ti), but I noticed something from my experiments.

1) I run ##### and selected:

2) "NVDIA GF100 Fermi Patches" and clicked on "Open ClEnabler 10.7.0." (first option)

3) Repaired kexts and permissions with Kext Wizard

4) Rebooted and run Cinebenchmark.

Final conclusion: I had 46.5 frames now rather than having 21.6 without this solution.

I DO NOT SWEAR this is gonna work for you, but try it out. I had to do a lot of kext repairs throughout my experiments...

As for the resolution, I found already patched kexts for my graphics card and worked!

Take care! Posted Image


My guess is that in the process of installing the OpenCLEnabler he managed to change an option in his GeforceGLDriver.bundle or something similar

My best guess is that something is missing in your GeForceGLDriver.bundle which is disabling your OpenGL hardware acceleration

#48
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male

That could be why, but the code said that it couldn't find the file or directory, so there might be a part of the .bundle that got deleted. Can you send me the .bundle?

It said it couldn't find it when i used the typo code. It found it, but made no substitutions when I corrected the error.

http://d.pr/f/ATM1

#49
KrazyKiwi

KrazyKiwi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Interests:Getting OSX to work with my PC
It said

Can't open /System/Library/Extensions/GeForceGLDriv­er.bundle/Contents/MacOS/libclh.dylib: No such file or directory

both times. I ended up taking the .dylib out of the bundle but you were right, the changes were already made.

Here is a kext from ML Developer Preiview 3.
http://d.pr/f/iXfC
Try it, the 10.8.2 kext might not be properly identifying your card
If this doesn't work, the last thing I can do is edit the AGPM.kext, which controls clock speeds.

#50
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Replaced it. Doing MyFix now. Will report back.

Gave me a KP





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy