Jump to content

[Guide] Lenovo Y560 Lion 10.7.1


  • Please log in to reply
1 reply to this topic

#1
Unshaped

Unshaped

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
Hello!

So, I've been trying a lot of times to start Lion on my Lenovo Y560, now I did it and made a small guide.

Working all, exept of sleep, HDMI, build in mic, and sometimes VoodooHDA makes some crackles.

My config:

CPU: Mobile QuadCore Intel Core i7-720QM
System board: Lenovo KL3
Chipset: Intel Ibex Peak-M HM55, Intel Lynnfield
Memory: 8Gb
Video: ATI Mobility Radeon HD 5730 (Madison)
Sound: Realtek ALC272 @ Intel Ibex Peak PCH - High Definition Audio Controller [B-3]
Wireless: Atheros AR9285 Wireless Network Adapter (192. [ TRIAL VERSION ])
Ethernet: Broadcom NetLink ™ Gigabit Ethernet

Guide:

1. Create Primary HFS+ partition in Windows (with Paragon partition marager for example)
2. Install iAtkos L1 with options:
- Bootloader Chameleon
- PS\2 enabler
- Voodoo Hda 2.7.2
3. Reboot in Windows, install Macdrive, and after that replace by files from archive:
- to root of your osx drive put the boot file from archive
- /name of your osx drive/extra put all files from /extra in archive
- /name of your osx drive/system/library/extensions files from s-l-e in archive
- /name of your osx drive/system/library/coreservices/Setup Assistant.app/Contents replace by info.plist zipped in SA folder, it's needed to stop keyboard check on first Lion start.

That's it ) Reboot and if it works - it works )))

Known issues:
- Sometimes KP on boot because of VoodoHda. I found patched AppleHDA.kext for ALC 272, but it doesn't work for me. I think, I have a problems with DSTS, but I cannot understand how to patch it by myself, so your help with it will be very appreciate. By now I'm using flag UseKernelCashe=Yes in boot.plist
I used the DSTS from this topic - http://www.insanelym...p...285&hl=y560 , but I have another config...
- Video doesn't looks like 32bit, has an artefacts on video, mostly on dark scenes.
- If you have problems with resolution after that - you need to follow this guide: http://www.insanelym...hp/t208410.html

Big thanks to BugsB, without bootloader, found in this topic - http://www.insanelym...p...269&hl=y560 - video didn't work properly.

Attached Files



#2
dahaka88

dahaka88

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Bucharest

Hy there, have you figured it out how to make the video work with REAL 32-Bit mode? i have the same problem, in system report it sais that it's 32-bit but i'm having troubles on shadows and gradients like it's in 16-Bit mode.

 

I played a bit with SwithResX, and still no fix here either! This happens on ML 10.8.4 (iatkos ML2 then combo updates to 10.8.4 and also in mavericks 10.9 DP4/5)







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy