Jump to content

[HELP] Gigabyte EP45T-DS3R-Lion 10.7 No sound!


Best Answer Kynyo, 10 September 2011 - 12:40 PM


Method (_DSM, 4, NotSerialized)
				{
					Store (Package (0x06)
						{
							"built-in", 
							Buffer (One)
							{
								0x00
							}, 

							"layout-id", 
							Buffer (0x04)
							{
								0x75, 0x03, 0x00, 0x00
							}, 

							"PinConfigurations", 
							Buffer (Zero) {}
						}, Local0)
					DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
					Return (Local0)
				}

Thanks Man :(
Actually is needed to edit my Gigabyte HDEF generated using your tool [DSDT Auto-Patcher]. What was wrong with this great project? You stopped working on it?
I think I'll edit using DSDT Patcher & Editor Tool or DSDTSE
Thanks once again MaLd0n, thanks Insanelymac!
In case I'll not succeed with editing DSDT I'll post here for help :(
PS: I'm new in DSDT editing and I please you to help me make those modifications and check if my DSDT it's oke.
I guess kexts must be installed in S/L/E with repairing permissions :P


Problem Solved using Legacy HDA Method!!!
Thanks insanelyMac, Thanks MaLd0n!
Now my system reports:
Posted Image
Posted Image
Posted Image Go to the full post


  • Please log in to reply
4 replies to this topic

#1
Kynyo

Kynyo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Not your bisnizz...
  • Interests:
Hello everyone! Actually I'm trying to install OS X Lion on my mobo Gigabyte EP45T-DS3R. I've installed successfully, all drivers ready, but I don't have sound.
I've tried all methods Like AppleHDA, ALC88xx, HDA Rollback but again, no sound.
I think I've need a proper HDEF DSDT, actually I'm n00b at DSDT editing, so if someone can help me effort will be greatly appreciated.
My System: Motherboard: Gigabyte EP45T-DS3R
CPU: Core2Duo E8400
GPU: nVIDIA Quadro FX 3700
RAM: 4GB KINGSTON @ 1066 Mhz
BIOS: F4c

System report says: Posted Image

Thanks in advance :D

Attached Files



#2
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro
Attached File  ALC889a.zip   1.64MB   39 downloads
Method (_DSM, 4, NotSerialized)
				{
					Store (Package (0x06)
						{
							"built-in", 
							Buffer (One)
							{
								0x00
							}, 

							"layout-id", 
							Buffer (0x04)
							{
								0x75, 0x03, 0x00, 0x00
							}, 

							"PinConfigurations", 
							Buffer (Zero) {}
						}, Local0)
					DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
					Return (Local0)
				}


#3
Kynyo

Kynyo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Not your bisnizz...
  • Interests:

Best Answer

Attached File  ALC889a.zip   1.64MB   39 downloads

Method (_DSM, 4, NotSerialized)
				{
					Store (Package (0x06)
						{
							"built-in", 
							Buffer (One)
							{
								0x00
							}, 

							"layout-id", 
							Buffer (0x04)
							{
								0x75, 0x03, 0x00, 0x00
							}, 

							"PinConfigurations", 
							Buffer (Zero) {}
						}, Local0)
					DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
					Return (Local0)
				}

Thanks Man :(
Actually is needed to edit my Gigabyte HDEF generated using your tool [DSDT Auto-Patcher]. What was wrong with this great project? You stopped working on it?
I think I'll edit using DSDT Patcher & Editor Tool or DSDTSE
Thanks once again MaLd0n, thanks Insanelymac!
In case I'll not succeed with editing DSDT I'll post here for help :(
PS: I'm new in DSDT editing and I please you to help me make those modifications and check if my DSDT it's oke.
I guess kexts must be installed in S/L/E with repairing permissions :P


Problem Solved using Legacy HDA Method!!!
Thanks insanelyMac, Thanks MaLd0n!
Now my system reports:
Posted Image
Posted Image
Posted Image

Attached Files



#4
jvamos

jvamos

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hey all I am using the same motherboard (GA-EP45T-DS3R) and I have a DSDT issue I think.

It is possibly causing an IRQ conflict with a device I don't recognize. (it looks like a pci lane?) Or maybe I am mistaken... (very likely)

I have read that looking at the DSDT you can find IRQs that are called in conflict but I didn't see any evidence of this. 

 

I found an older DSDT on OSx86 that is for this motherboard but it kps as soon as it reaches the desktop. I see my firewire drivers bounce in the dock twice so I know the DSDT is correct for the firewire settings.  I am going to post both DSDT's here. If anyone has any advice I'd love to hear it. Machine language is really complicated looking. 

Thanks for everything guys!

 

The DSDT which loads the desktop before a KP is posted here  

The DSDT which boots without firewire devices listed is posted here under gigabyte - p45 - EP45T-UD3LR-  f10

 

I know the dsdt I am booting with isn't right for my mobo but it at least will run. If I had installed using the wrong dsdt would that cause kp's when switching it? The most of the components are the same on those mother boards.

 

Thanks all for any help! This is where the learning curve gets steep.

 

Josh



#5
jvamos

jvamos

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I have installed a cheap third party (TI based) firewire card in a PCI slot and have firewire but I think it's rather silly to have to do that when the functionality is locked inside a DSDT. I am willing to commit my month to solving this if anyone can point me in the right direction it would be greatly appreciated.

 

Thanks!

 

Josh







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy