Jump to content

Different Guide to install Lion + Triple Boot


  • Please log in to reply
28 replies to this topic

#1
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male
Side Note:
i Followed every tutorial related to installing lion and every time i boot i get 1 of 2 things gray screen with mouse arrow or white screen with rainbow wheal
>Again ,this is a compilation of several tutorials + my own interpretation ,so this method should definitely work if everything else failed.

Why This ?
in case u later wanted to only install "7 + Lion" or ur HDD just got screwed no probs ,u can boot with the USB and install LION without the need for a pre-installed SL or maybe u tried every other tutorial and u ended up with the same scenario as above.

Before we Start:
*if you followed my SL tutorial Here ,it would be a good idea to make a backup dmg file of the USB b4 we continue ,so when u need to install SL later ,all u have to do is just restore the img to the usb without the need to do the whole process all over again.

MY CONFIG:
asus p5q deluxe
e8400 3.0 ghz oc to 3.6 ghz
ati sapphire 4870 1gb
4gb ram 800 mhz oc to 1066 mhz
also work on this config
Rampage Ex.2
i7 920
6gb ram
Ati sapphire 5850


USB PREPARATION:
1-Follow this Great Guide by Mald0n and escape to step 7.
OR
if u r not comfortable with the Terminal commands ,u can use this instead.

WHAT WE WILL NEED ?
1-An already Installed SL ,Follow This if u don't have it yet.
2-Multi.Beast & Kext.Beast
3-Extra Folder Here
4-Chameleon-2.0-RC5-r1083.pkg Here the newer versions didn’t work for me :(,so this one is good enough
5-Kexts u will need Here

USB PREPARATION:
1-right click Lion.app and Show content > chose SharedSupport > open InstallEsd
2-get ShowAllFiles ,search over Google > open it and click on Show.
3-inside InstallEsd u’ll find a .dmg file call BaseSystem < open it.
4-now open DiskUtil > chose ur USB and partition it as 1 partition > click on option and chose GUID.
5-click on restore and restore the BaseSystem img to the USB ,it will take sometime so go drink something while waiting.
6-when its finished go to System > installation > Delete the shortcut call Packages > open installESD again > copy Packages folder to the usb instead of the one u just deleted.

7-open InstallEsd again and copy this 5 files from it to the USB.
1.disk_lable
2.boot.efi
3.kernelcache
4.mach_kernel
5.MacOSX_Media_Background.png
8-open Chameleon-2.0-RC5-r1083.pkg and chose everything then install to the USB.

9-now open Extra Folder.pkg and uncheck ExtraFolder then press on Smbios arrow and chose the one that best suites ur spec ,check Mald0n guide at Post installation to find which one is urs ,then install it to the USB.

10-now open the USB > open Extra Folder > delete Extensions.mkext > then if u don’t have a one already then make a folder call Extensions > put ur Vga,Sound,Network kexts + the files from the Kexts.zip u just downloaded if u use PS2 Keyboard then copy those too VoodooPS2Controller + AppleACPIPS2Nub in it.

11-after that drag the Extensions folder over Kext Utility to fix the permission for them > u should now find a new file call Extensions.mkext in Extra folder instead of the one u just deleted [again this file is so important so make sure its there].

12-copy Multi.Beast & Kext.Beast to the USB as we will need them later. myhack 1.1.4 wont work on lion

INSTALLING LION:
1-now restart and boot with ur USB and when u get to the boot menu > chose ur USB ,in a min or so u will get the to the language screen.

2-chose ur Lion driver as ur install destination and continue ,now it won't take long like SL ,so be patient.

3-when done ,reboot and chose ur usb again to boot with ,this time chose ur Lion driver u just installed over.
*if u have a ps2 keyboard and got stuck at the searching for keyboard screen ,then restart and boot into ur SL.
>open ur Lion diver and search for
/System/Library/CoreServices/Setup\ Assistant.app/Contents/Info.plist
>open it and delete these lines
<string>DeviceSection</string>
<string>KeyboardTypeSection</string>

*if u have a USB keyboard ,just plug it in till u get pass the bluetooth screen then use ur ps2 normally.

4-now restart and boot to ur lion driver and magically the keyboard idiotic problem is gone.

5-complete the informations and when u r on the desktop > open ur usb and install the Multi.Beast check ##### + anything else u want
>open up ur USB and copy smbios.plist from ur Extra and put it on ur Lion driver in Extra also.
>get Kext.Beast & copy ur drivers kext from the Extensions folder from the USB to the desktop & run the app.

6-remove any duplicated kexts with S/L/E from E/E ,so u dont get any confliction or KP.
7-u r done.

TRIPLE BOOT:
1-its better to remove any other HDD except the one u have ur OS's on to avoid any confusion.
2-now restart and put ur windows 7 DVD and boot from it then > Click Repair your computer > System Recovery Options dialog box, click Command Prompt > then enter this commands

diskpart >
select disk 0 >
list partition >
*ignore 1st one.
select partition #<ur windos partition NO#>
active


3-restart and remove ur windows 7 DVD ,you'll boot to the SnowLeo Boot menu ,press any key and u’ll find the 3 OS’s < chose any and press enter
ps:
if anything went wrong ,boot with -x -v to find whats the problem.

*Parallels.Desktop.v6.0.12090 wont work with the Triple boot option.

Trouble Shooting:

-Mac OS X can't be installed on this computer.
>its because you are installing Lion on MBR not GUID ,get this File then open ur USB and and replace the one in System/Installation/Packages with it.

-PCI configuration error.
>boot with flag >npci=0x2000.

-USB boot not working ,use i.boot.
>boot with flag >mach_kernel.

-if u install Lion on Laptop.
>use MBR instead of GUID format for USB.

-Nvidia support ,sorry cant help u.
-Ati support ,anything above 4XXX series.
>dont use any GraphicsEnabler=Yes/No.

-screen flickering/artifacts after installing on Rampage Ex.2
>restart and it will be fixed. "found no logical exp"

-stuck @ "IOAPIC Version 0x20" on Rampage Ex.2.
>leave it for a couple of mins and unplug ur USB then plug it again. "found no logical exp"

-KP regarding "Atix3000 and 3 other ioapic" on Rampage Ex.2.
>remove ur vga kext.

-Slow Booting on Rampage Ex.2.
>move all ur important kext to S/L/E.

-working Sound on Rampage Ex.2.
>use voodooHDA 0.2.2 "no need to delete applehda".

-if ur cpu runs hot
>add this flags to ur boot.plist ,also check them in ur Bios.
<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

Notes:

if u use evoreboot dont use openhaltrestart.
if u use dsdt dont use nullcpupowermangment / smbiosresolver
if u cant find a modified bios for ur MB ,get dsdt from Here and add fixes then use it. 'this should fix ur restart /shutdown /sleep /built-in devices'
*u can also use the dsdt beside ur modified bios if u want.

ParallelsDesktop 7

*if u tried to install Parallels on ur OSX/Lion ,u will always get the boot0 thing
*in order to fix that use this Video but activate ur windows driver instead and then install the app.
*finish ur Parallels setup on windows ,go back to ur OSX/Lion and check if everything is working as expected in Parallels then use the same method in the video and this time activate ur Mac Driver not windows.


♠♣♥
Greetings goes to
[Netkas , Mald0n , TonyMacx86 & MacMan , LifeHacker Team , CaptainNemo , RoberT_XeS , ladiciuus , Others]
Thanx so much.

#2
AlSnow

AlSnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
can you tutorial be followed in case if i dont have a USb Pen drive and decide to create a new partition of about 10GB and follow the entire procedure.... but instead of USB pen drive I'l be using the newly created partition????? please let me know

#3
AlSnow

AlSnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

8-when finished install Extra_Lion_DP4.pkg by Mald0n to the USB.

9-now open Extra Folder.pkg and uncheck ExtraFolder then press on Smbios arrow and chose the one that best suites ur spec ,check Mald0n guide at Post installation to find which one is urs ,then install it to the USB.

10-almost there ,open Chameleon-2.0-RC5-r1083.pkg and chose everything then install to the USB.


I thought I would actually wait for your reply before trying this procedure. I created a new partition of 10GB on the HDD (Since I don't have a 8GB pen drive at the moment) and tried to follow all the steps but got stuck at step 8 and forward. I can run the installer but can't select the 10GB partition as the location. Its giving me the loaction for the 10GB partition but there's an exclamation mark over that partition.

Please tell me what to do..... Or would I require the 8GB pen drive for your procedure to work correctly????

#4
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

I thought I would actually wait for your reply before trying this procedure. I created a new partition of 10GB on the HDD (Since I don't have a 8GB pen drive at the moment) and tried to follow all the steps but got stuck at step 8 and forward. I can run the installer but can't select the 10GB partition as the location. Its giving me the loaction for the 10GB partition but there's an exclamation mark over that partition.

Please tell me what to do..... Or would I require the 8GB pen drive for your procedure to work correctly????


okey ,i think u get the yellow mark because its not HFS+ and i think its still NTFS ,so just format it as u would with the USB except u won't be apple to change the boot from MBR to GUID incase u have an MBR because to do that u will have to change the whole HDD structure ,then continue normally.
ps:
i would recommend the usb because u can do anything with it without effecting ur HDD + u can use it to install the OS on other pc's with simple modifications.

#5
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Followed your Guide and get stuck with "DSMOS arrvied" just before the Installation Screen should be shown. I just left out 1 instruction, i didnt used GUID for USB Stick. when i Format my USB Stick with GUID and boot it i always get "Operation System not found" Error.

Spec: Intel i5 2410m + 540m GT + 500gb MBR Hdd

#6
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

Followed your Guide and get stuck with "DSMOS arrvied" just before the Installation Screen should be shown. I just left out 1 instruction, i didnt used GUID for USB Stick. when i Format my USB Stick with GUID and boot it i always get "Operation System not found" Error.

Spec: Intel i5 2410m + 540m GT + 500gb MBR Hdd


did u installe the modified bios for ur MB ?
also ,how did u format the USB ,on a Mac 'VM/original" or with something else like TransMac or MacDrive?
and can u post ur Lap model ? ,it will be easier to find a solution that way for ur pc .

#7
AlSnow

AlSnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

okey ,i think u get the yellow mark because its not HFS+ and i think its still NTFS ,so just format it as u would with the USB except u won't be apple to change the boot from MBR to GUID incase u have an MBR because to do that u will have to change the whole HDD structure ,then continue normally.
ps:
i would recommend the usb because u can do anything with it without effecting ur HDD + u can use it to install the OS on other pc's with simple modifications.


I tried with the USB Pen drive... I performed all the steps except installing Chameleon on the Pen Drive. If i do that the system just gets stuck at the motherboard logo and if I remove the Pen drive the system boots fine and goes to the chameleon bootloader which is installed on the HDD along with Snow Leopard and other partitions.

When I perform all steps except chameleon and then try to boot with the USB Pen drive still plugged to the system it boots fine and comes to the chameleon and the USB Pen drive gets recognized.

Now, When I boot using the Pen drive (I normally do it using the -v so that I can see the progress) itloads a lot of information and then finally gets stuck on the screen mentioned below. It never gets past that.

Attached File  IMAGE604.jpg   470.39KB   39 downloads

What can be going wrong. I tried to do all steps on a system partition as well but the same thing happens. it gets stuck the same place as above.

P.S: I tried following MaLd0n guide again without installing the chameleon on the Pen drive.... same result as above

#8
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

I tried with the USB Pen drive... I performed all the steps except installing Chameleon on the Pen Drive. If i do that the system just gets stuck at the motherboard logo and if I remove the Pen drive the system boots fine and goes to the chameleon bootloader which is installed on the HDD along with Snow Leopard and other partitions.

When I perform all steps except chameleon and then try to boot with the USB Pen drive still plugged to the system it boots fine and comes to the chameleon and the USB Pen drive gets recognized.

Now, When I boot using the Pen drive (I normally do it using the -v so that I can see the progress) itloads a lot of information and then finally gets stuck on the screen mentioned below. It never gets past that.

Attached File  IMAGE604.jpg   470.39KB   39 downloads

What can be going wrong. I tried to do all steps on a system partition as well but the same thing happens. it gets stuck the same place as above.

P.S: I tried following MaLd0n guide again without installing the chameleon on the Pen drive.... same result as above



1st-how did u got to the installer window with ur HDD but now wither u use the USB or HDD u dont get past that msg ?
2nd-try to update ur MB with the latest modified bios ? ,sometimes the old bios make conflictions with the USB booting ,also dont forget to make the storage config as AHCI.
3rd-whats the chameleon version u use on ur SL ,old versions wont load because of the different mach_kernel >get the lastest ##### and boot with <mach_kernel> flag ,also boot with -x -v and tell me what u will get.

#9
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

did u installe the modified bios for ur MB ?
also ,how did u format the USB ,on a Mac 'VM/original" or with something else like TransMac or MacDrive?
and can u post ur Lap model ? ,it will be easier to find a solution that way for ur pc .


No i got my original Bios installed. I used a SL running on VMWare Workstation. My USB Stick is an Corsair Voyager 16GB 3.0 My Laptop is an Dell XPS 502x with BIOS x502 A06 with this speccs:
i5 2410m Sandy Bridge + Intel HD Graphics 3000 with Intel IGD VBIOS v.2117
540m GT with Optimus
500gb HDD with MBR
4GB Ram
FHD 15" Display

EDIT: i found a topic in dell support forum that states the the bios in some way block booting from GUID partitions. http://en.community....9/19876063.aspx

So formating the USB Stick with GUID wont work for me, could the installation be done with an MBR Stick? with this Stick the boot continues until DSMOS arrived and stops, as far as i know its a problem with the grafik card, as i use graphicsenabler=no the Intel HD 3000.

#10
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

No i got my original Bios installed. I used a SL running on VMWare Workstation. My USB Stick is an Corsair Voyager 16GB 3.0 My Laptop is an Dell XPS 502x with BIOS x502 A06 with this speccs:
i5 2410m Sandy Bridge + Intel HD Graphics 3000 with Intel IGD VBIOS v.2117
540m GT with Optimus
500gb HDD with MBR
4GB Ram
FHD 15" Display

EDIT: i found a topic in dell support forum that states the the bios in some way block booting from GUID partitions. http://en.community....9/19876063.aspx

So formating the USB Stick with GUID wont work for me, could the installation be done with an MBR Stick? with this Stick the boot continues until DSMOS arrived and stops, as far as i know its a problem with the grafik card, as i use graphicsenabler=no the Intel HD 3000.


okey ,no prob ,forget about the GUID thing and format the USB as MBR and do all the steps but dont forget to use Mald0n file if u encounterd this msg Mac OS X can't be installed on this computer.

#11
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Ok i give it a try, im preparing the new stick allready. will post the result in ~30 minutes.

#12
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

Ok i give it a try, im preparing the new stick allready. will post the result in ~30 minutes.


okey ,hopefully it work this time ,i'll check back on u asap.

#13
AlSnow

AlSnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

1st-how did u got to the installer window with ur HDD but now wither u use the USB or HDD u dont get past that msg ?
2nd-try to update ur MB with the latest modified bios ? ,sometimes the old bios make conflictions with the USB booting ,also dont forget to make the storage config as AHCI.
3rd-whats the chameleon version u use on ur SL ,old versions wont load because of the different mach_kernel >get the lastest ##### and boot with <mach_kernel> flag ,also boot with -x -v and tell me what u will get.


My HDD is partitioned as GUID... Currently I have the 1st Partition (GUID) with Snow Leopard, 2nd Partition with Windows 7 which ofcourse is active.. 3rd partition I have the clone of my working SL (GUID again)

I have the latest chimera bootloader through tonymacosx86's ##### which starts the system. Then I get choices from which I can the OS I want to start and from there I can either boot to SL/Windows/SL Clone

I have already updated my Motherboard with the latest modified Bios and the AHCI options is currently active.

As said before even if i try start Lion Installation from any partition on my internal HDD (10GB) it gets stuck at the same place and with the USB Pen drive the same thing.

I have tried with both the flags -x -v with same results............ Any other suggestions?????

#14
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Ok Im back with some good and some bad news. I redid my USB with MBR and your guide. i can boot it just fine.
My boostrings are
-v -f GraphicsEnabler=no cpus=1 busratio=23 RESULT IN i can boot but get stucked after DSMOS arrvied
-v -x -f GraphicsEnabler=no cpus=1 busratio=23 RESULT IN boot gets stucked right after kexts are loaded
-v -f GraphicsEnabler=no RELUTS IN much faster boot but stucked after DSMOS arrived
-v -f GraphicsEnabler=yes some weird nvidia error, no way to go with this

my usb stick LED keeps blinking for 4-5 seconds after DSMOS arrived and than dies.

#15
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
I GOT IT I GOT IT F**K YEAH! i was right with the Intel Graphics, it was the Problem why it didnt started. I edited the Intel SNB kext and got it working!!!!!!!!!

Ok, now im in the promt where i can select the harddrive to install, but the hard drive tool only offers me options to delete the partition i created for mac or to make a raid. It says i have to format it to Guid but it doenst offer me this option.

BTW i blew up the windows bootloader but who cares, i can still boot windows with cameleon

#16
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

I GOT IT I GOT IT F**K YEAH! i was right with the Intel Graphics, it was the Problem why it didnt started. I edited the Intel SNB kext and got it working!!!!!!!!!

Ok, now im in the promt where i can select the harddrive to install, but the hard drive tool only offers me options to delete the partition i created for mac or to make a raid. It says i have to format it to Guid but it doenst offer me this option.

BTW i blew up the windows bootloader but who cares, i can still boot windows with cameleon


okey great great great ,glad u made it ,am not very familiar with Nvidia but the graphicenabler=no in all ways or u have to install dsdt.aml to fix that "sorry i cant help in that part because i dont use dsdt " ,about the GUID prob ,here is the thing
i never encountered the MBR Lion prob because i formatted my HDD as GUID from the 1st time i installed SL ,
so try the one from Mald0n or from Aju Deeju Guide
5) Now extract the Nawcom's patch for MBR [http://blog.nawcom.com/Lion_OSInstall_GM.tar.bz2] to the Desktop. open the installation media and 
replace 
/Installation/Packages/OSInstall.mpkg 
with the one provided and also replace 
/System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/OSInstall


#17
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

okey great great great ,glad u made it ,am not very familiar with Nvidia but the graphicenabler=no in all ways or u have to install dsdt.aml to fix that "sorry i cant help in that part because i dont use dsdt " ,about the GUID prob ,here is the thing
i never encountered the MBR Lion prob because i formatted my HDD as GUID from the 1st time i installed SL ,
so try the one from Mald0n or from Aju Deeju Guide

5) Now extract the Nawcom's patch for MBR [http://blog.nawcom.com/Lion_OSInstall_GM.tar.bz2] to the Desktop. open the installation media and 
replace 
/Installation/Packages/OSInstall.mpkg 
with the one provided and also replace 
/System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/OSInstall


I GOT IT INSTALLED! Nothing but the Webcacm works, i have an account with i picture of me :) can boot lion fine!!!!
Everthing from now will work out i guess, thank u very much for your greatr guide!

I got Dell XPS 502x running with Lion on MBR with this great guide!

I just used your Guide but i deleted the AppleIntelCPUmangment kext, i coppied all your files but elft out the CPU null kext. Than i edited the AppleIntelSNB kext to include the ID of my Intel 3000 HD. In my case it was 0116.

#18
aufa333

aufa333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
  • Gender:Male

I GOT IT INSTALLED! Nothing but the Webcacm works, i have an account with i picture of me :) can boot lion fine!!!!
Everthing from now will work out i guess, thank u very much for your greatr guide!

I got Dell XPS 502x running with Lion on MBR with this great guide!


glad u finally made it to the safe zone ,if u can post a guide on what exactly u did and what errors encountered u it would be even better ,there are some ppl dying to get Lion working on this particular model.

#19
AlSnow

AlSnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

My HDD is partitioned as GUID... Currently I have the 1st Partition (GUID) with Snow Leopard, 2nd Partition with Windows 7 which ofcourse is active.. 3rd partition I have the clone of my working SL (GUID again)

I have the latest chimera bootloader through tonymacosx86's ##### which starts the system. Then I get choices from which I can the OS I want to start and from there I can either boot to SL/Windows/SL Clone

I have already updated my Motherboard with the latest modified Bios and the AHCI options is currently active.

As said before even if i try start Lion Installation from any partition on my internal HDD (10GB) it gets stuck at the same place and with the USB Pen drive the same thing.

I have tried with both the flags -x -v with same results............ Any other suggestions?????


Hurray! I got it installed..... HELL YEAH... After so many tries I finally got it

What I did was I created a 1 partition on my USB drive (MBR Partition) and then followed all your steps.

In the end checked this link:
http://www.insanelym...p;gopid=1725541

From the above link... Downloaded the boot file (As said by: kdawg and replaced it with the file that was already there after performing all your steps on the USB PEn drive)

Restarted and VIOLA was able to boot using the USB Pen drive (Since had selected MBR as partition format)

Completed the installation and now I have a successfully working LION and has the same speed as my Snow Leopard.

Thanx to all your guys and above all, ABOVE ALL THANX TO INSANELYMAC

>then open Chameleon-2.0-RC5-r1083 and check everything then install,when done


With respect to the above step... I'm currently booting using the USB Pen drive, And then select the Lion partition and it boots up fine with no issues.

Now if I install Chameleon-2.0-RC5-r1083 and select everything in the options...
Will I get chameleon preferences/options in my system preferences window OR not? (Something like the below screen)

Attached File  screenshot20101010at154.png   125.82KB   32 downloads Attached File  schermata20101219a15420.png   113.95KB   33 downloads

Because earlier in my Snow Leopard I had an option for chameleon which was in the system preferences window. From there I could easily change the graphics options such as what resolution I need, and other startup options that I wont have to write at F8 or modify any system file. that utility window or should I say chameleon window was able to do it perfectly.

Please let me know quick or if you could let me know of some utility or package that would bring back those chameleon options in the system preferences.... It would very much appreciated.

#20
Peterpower

Peterpower

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Congratulion AlSnow. I encouter some serious Post installation issues sadly... I tried to use the kexts from the Snow leo guide for x502 and my Lion wont boot anymore, i just stops while loading some HDA kexts and nija restarts. But i can approve my method works as i could flawlessly reinstall lion and try again. Somebody got the same issues whit Snow Leo DSDT and kexts crashing your lion?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy