Jump to content

[Aiuto] SL 10.6.8 Crash


  • Please log in to reply
24 replies to this topic

#1
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Salve,
come da oggetto, ho un problema di crash e blocchi che a volte si verificano mentre avvio la macchina e a volte mentre sto effettuando operazioni comuni, come vedere foto o semplicemente navigare su internet attraverso il browser (safari, firefox o Chrome non fanno differenza).
Dopo l'ultimo crash sono riuscito a recuperare dalla console, le informazioni ad esso relative e ve le riporto di seguito nella speranza che qualcuno di voi possa suggerirmi una soluzione, anche se in verità, di volta in volta non mi pare che essa riporti sempre il medesimo errore:


14/07/11 17.11.04	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
14/07/11 17.11.04	kernel	0000006e
14/07/11 17.11.04	kernel	00200000 00005039 00000474 00000002
14/07/11 17.11.04	kernel	0000047c 00000320 00000001 00000015
14/07/11 17.11.04	kernel	00000000 00000000 00000043
14/07/11 17.11.04	kernel	00000002 00000000
14/07/11 17.11.04	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.04	kernel	00000069
14/07/11 17.11.04	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.04	kernel	00000069
14/07/11 17.11.04	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.04	kernel	00000069
14/07/11 17.11.04	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.04	kernel	00000069
14/07/11 17.11.04	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.04	kernel	00000069
14/07/11 17.11.05	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.05	kernel	00000069
14/07/11 17.11.26	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.26	kernel	00000069
14/07/11 17.11.26	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	= 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.27	kernel	00000069
14/07/11 17.11.27	kernel	NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
14/07/11 17.11.28	kernel	069

ho evitato di riportare tutte le stringhe di questo crash perchè sono pressoché le stesse e si ripetono a centinaia.

Immagino sia un problema dovuto ai drivers della scheda video. La cosa assurda è che per diversi mesi dopo l'istallazione non ho avuto alcun tipo di malfunzionamento, tutto liscio come l'olio, dopo di punto in bianco ad un riavvio il primo crash e da allora ogni tanto, cadenza quotidiana quando effettuo operazioni di uso comune il sistema va in crash, schermo congelato e l'unica possibilità è il riavvio.
I drivers della scheda video Nvidia 9800GT sono aggiornati all'ultima versione; in firma trovate tutti i dettagli relativi all'hardware.

Grazie per l'eventuale aiuto. D.

#2
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Rieccomi, ho rimosso l'nvenabler64.kext nella speranza di usare come iniettore il graphicsenabler da apple.boot.com.plist, ho inoltre inserito una efistring relativa alla mia scheda video, purtroppo senza sortire l'effetto desiderato. In sostanza, senza l'nvenabler non riesco in nessun modo a far funzionare la mia nvidia 9800gt con osx. Sono apprezzati suggerimenti su come forzare il funzionamento della suddetta senza l'nvenabler, perchè sospetto che rsponsabile dei vari crash e congelamenti sia proprio questo iniettore. Grazie. D.

#3
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Questo è il mio com.apple.boot.plist, qualcuno sarebbe così gentile da dirmi se trova che ci sia qualcosa che non va e che impedisce al graphichenabler di far funzionare correttamente la scheda video? Grazie:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Boot Graphics</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string></string>
	<key>Quiet Boot</key>
	<string>No</string>
	<key>Timeout</key>
	<string>5</string>
	<key>arch</key>
	<string>-v X86_64</string>
	<key>device-properties</key>
	<string>d10300000100000001000000c50300001500000002010c00d041030a010000000101060000070101
060000007fff04003a000000400032002c0068007700730065006e0073006f0072002d0070006100720061006d007
3002d00760065007200730069006f006e000000080000000000000222000000400032002c0064006500760069006
30065005f0074007900700065000000120000004e5644412c6770752d64696f64650e0000004e00560050004d0000
0020000000010000000000000000000000000000000000000000000000000000001e00000072006f006d002d0072
00650076006900730069006f006e000000090000003331373261100000004e005600430041005000000018000000
04000000000003000c000000000000070000000022000000400032002c002300730069007a0065002d0063006500
6c006c0073000000080000000000000022000000400030002c006400650076006900630065005f007400790070006
50000000b000000646973706c6179100000006d006f00640065006c0000001e0000004e5649444941204765466f72
636520393830302047542045464914000000400030002c006e0061006d0065000000120000004e5644412c446973
706c61792d4120000000400032002c0063006f006d00700061007400690062006c0065000000160000004e5644412
c73656e736f722d706172656e7414000000400031002c006e0061006d0065000000120000004e5644412c44697370
6c61792d4212000000400032002c00720065006700000008000000000000021c00000064006500760069006300650
05f0074007900700065000000100000004e5644412c4765466f72636520000000400031002c0063006f006d0070006
1007400690062006c00650000000e0000004e5644412c4e564d616326000000400032002c00230061006400720065
00730073002d00630065006c006c007300000008000000000000010e0000006e0061006d00650000000f0000004e5
644412c506172656e7422000000400031002c006400650076006900630065005f00740079007000650000000b0000
00646973706c617920000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e564
4412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a00650000000800000000
00004036000000400032002c00680077006300740072006c002d0070006100720061006d0073002d007600650072
00730069006f006e000000080000000000000214000000400032002c006e0061006d00650000001100000073656e
736f722d706172656e74</string>
</dict>
</plist>


vorrei precisare che device-properties è stato inserito usando il programma efistudio (versione 1.1).
Ho selezionato il mio modello di scheda video "nVidia GeForce 900GT [G92] - 1024" dalla lista di quelle presenti e cliccato su AddDevice, così facendo mi si è aperta una nuova finestra dalla quale ho cliccato su "Write to com.apple.boot.plist" sono andato poi a verificare che i dati fossero stati scritti correttamente e come da copione, per quanto senza ottenere risultati tangibili, tutto sembra in ordine.
C'è qualche altra cosa che posso fare? Dove è che sbaglio?

Grazie. D.

#4
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,717 posts
  • Gender:Male
  • Location:Italy
Devi eliminare la key device-properties con tutta la stringa EFI e lasciare il GraphicsEnabler=Yes. Elimina tutti gli altri injector (Nvenabler.kext, EFI string, DSDT injection, etc).

E' come su windows quando c'è un "conflitto" di driver, per dirla breve, qui chi comanda? Comando io oppure tu? Cioè comanda GraphicsEnabler o EFI string? Per questo motivo crasha.

#5
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts

Devi eliminare la key device-properties con tutta la stringa EFI e lasciare il GraphicsEnabler=Yes. Elimina tutti gli altri injector (Nvenabler.kext, EFI string, DSDT injection, etc).

E' come su windows quando c'è un "conflitto" di driver, per dirla breve, qui chi comanda? Comando io oppure tu? Cioè comanda GraphicsEnabler o EFI string? Per questo motivo crasha.

Ciao Copil,
ti ringrazio innanzitutto per avermi risposto. In realtá ero approdato al graphicsenabler proprio per via dei vari crash sopraggiunti con nvenabler64.kext, quindi l'ho rimosso e aggiunto la stringa nel com.apple.boot.plist solo che con il solo graphichsenabler=yes la scheda video non ne vuole sapere di funzionare, ho provato ad aggiungere la efistring perchè in qualche guida si parlava di questa integrazione, ma ottenendo sempre un risultato negativo. Ora ho tolto di nuovo nvenabler64.kext e la efistring lasciando solo il graphicsenabler=yes nel com.apple.boot.plist, ho salvato e fatto ripartire la macchina, ma al riavvio parto con una risoluzione di 1024x768, assenza del supporto per il secondo schermo e totale assenza dell'accelerazione grafica. Non riesco a capire per quale motivo... :)
Avrei tranquillamente continuato ad usare nvenabler64.kext se non fosse stato per quei crash quotidiani e che tra le altre cose, vedo che sono frequenti anche sui veri mac, tanto che sul forum della apple ci sono un paio di threads aperti sull'argomento per quel tipo di errore ma senza apparente soluzione.
Ora vorrei tentare di usare un altro iniettore proprio per escludere che nel mio caso dipenda da nvenabler64.kext ma non riesco nell'impresa.

Grazie. D.

#6
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,717 posts
  • Gender:Male
  • Location:Italy
Quale versione di Chameleon usi?

#7
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Ciao,

Chamelon v2.0-RC4 r684

grazie. D.

#8
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,717 posts
  • Gender:Male
  • Location:Italy
Installa l'ultima revisione te la allego vediamo se la "vede".

#9
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Ciao e grazie dell'allegato,
ci deve essere però qualcosa che sbaglio perchè ho provveduto a fare l'installazione ma all'avvio vedo sempre la vecchia versione di Chamelon....la cosa mi sembra assai strana! Provo a fare qualche verifica.

#10
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,717 posts
  • Gender:Male
  • Location:Italy
Quando fermi il bootloader e vai al prompt di Darwin in alto a partire da destra non vedi la versione? Ma ora la scheda video viene riconosciuta?

#11
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Ho un sistema multiboot e quando ho fatto l'aggiornamento al nuovo chamelon poco fa, avevo tutti gli hd collegati e qualcosa non è andato per il verso giusto. Comunque ora, per fare una prova ho lasciato solo HD di OSX ed è partito con il nuovo chamelon, carino :) l'unico neo è che continuo ad avere problemi, carica il sistema come prima ma la scheda video non viene riconosciuta, bassa risoluzione e niente QE.
Altri suggerimenti? Grazie.

Saluti. D.

#12
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Ciao Copil,
anche con il nuovo chamelon, non ne vengo fuori! ;) Il problema è che OSX è diventato invivibile in quanto anche solo se guardo un video su youtube, dopo un po se lascio il video full screen per troppo tempo, sullo schermo si iniziano a formare delle linee, a tratti lampeggia ed infine il sistema si congela; unica possibilità di uscita è il reset! Se vado a leggere i messaggi della console non sempre ho lo stesso errore ma comunque è sempre qualcosa che ha a che vedere con la scheda video.
Questo tipo di messaggio però sembra una costante:

17/07/11 14.51.02	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
17/07/11 14.51.02	kernel	0000006e
17/07/11 14.51.02	kernel	00200000 00008297 00000474 00000004
17/07/11 14.51.02	kernel	0000047e 00001b0c 1000f010 00000010
17/07/11 14.51.02	kernel	00000000 00000000 01bfdc01
17/07/11 14.51.02	kernel	00000004 00000000
17/07/11 14.51.02	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
17/07/11 14.51.02	kernel	0000006e
17/07/11 14.51.02	kernel	00200000 00008297 00000474 00000004
17/07/11 14.51.02	kernel	0000047e 00001b0c 1000f010 00000010
17/07/11 14.51.02	kernel	00000000 00000000 011fdc01
17/07/11 14.51.02	kernel	00000004 00000000
17/07/11 14.51.02	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
17/07/11 14.51.02	kernel	0000006e
17/07/11 14.51.02	kernel	00200000 00008297 00000474 00000004
17/07/11 14.51.02	kernel	0000047e 00001b0c 1000f010 00000010
17/07/11 14.51.02	kernel	00000000 00000000 01000011
17/07/11 14.51.02	kernel	00000004 00000000

Devo trovare il modo di far funzionare il graphicsenabler affinchè possa escludere il problema dell'iniettore, ma non capisco per quale motivo non vuole saperne di partire! Dove è che sbaglio? C'è forse qualche altro iniettore che ho lasciato da qualche parte?
Tolto l'nvenabler64.kext in S/L/E restano:

nvdagf100Hal.kext
nvdanv40Hal.kext
nvdanv50Hal.kext
nvsmu.kext


Come posso fare una verifica generale?
il mio com.apple.boot.plist è questo:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Boot Graphics</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>No</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string></string>
	<key>Quiet Boot</key>
	<string>No</string>
	<key>Timeout</key>
	<string>5</string>
	<key>arch</key>
	<string>-v X86_64</string>
</dict>
</plist>

Non vorrei formattare, quanto capire quale è la ragione di questi errori!


Grazie per l'eventuale aiuto. D.

#13
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Salve a tutti, la "sxga" continua -_-
visto che con il Chameleon 2RC5 non avevo risultati, ho scaricato ##### e installato Chimera; lo so sembra una cacchiata, ma in realtà qualcosa è successo, prima quando eliminavo il NVEnabler64.kext e attivavo il GraphicsEnabler dal com.apple.boot.plist non succedeva nulla tranne che accedere a OSX con una risoluzione molto bassa e senza accelerazione grafica. Adesso invece, quando lo elimino, al riavvio giungendo alla fase di caricamento in cui dovrei vedere il desktop, il monitor è come se perdesse il sync, e ho praticamente lo schermo nero. Non so se ciò dipenda dal fatto che OSX entra in una risoluzione non supportata dal mio vecchio Samsung SyncMaster 204B oppure dal fatto che essendo collegato via DVI (ho due uscite DVI sulla mia scheda video) magari questa uscita non è abilitata.
Chiaramente se da Chimera avvio in modalità "-s" ho possibilità di ripristinare l'iniettore video nvidia e ritornare alla condizione di partenza.
Avete qualche buon suggerimento (che non sia formattare, non avrei risolto nulla nel caso in cui mi si ripresentasse lo stesso problema) per "cavalcare l'onda" visto e considerato che adesso sembra che il sistema effettivamente reagisca a quello che legge nel com.apple.boot.plist?

Saluti e grazie. D.

#14
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
La prima fase relativa alla sostituzione del vecchio iniettore NVEnabler64.kext che come avevo scritto in più 3d, di aggiornamento in aggiornamento era diventato instabilissimo, è andata a buon fine, i dettagli dell'operazione li trovate quì. Adesso sto usando semplicemente il Graphics Enabler; staremo a vedere se il fatidico e quotidiano errore con conseguente freeze del sistema, sparirà definitivamente. Vi terrò chiaramente informati :) ci tengo a ringraziare Copil che è stato l'unico che ha cercato di aiutarmi, suggerendo soluzioni e strategie!


A presto. D.

P.S. Chiaramente non pongo ancora la scritta RISOLTO sul 3d in quanto sono in attesa degli effetti di questa variazione.

#15
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Eccomi di nuovo, quest'ultimo aggiornamento on the road per comunicarvi fugacemente che stamane si è perpetuato nuovamente l'errore di sempre, nonostante il Graphics Enabler:

01/08/11 10.43.01	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
01/08/11 10.43.01	kernel	0000006e
01/08/11 10.43.01	kernel	00200000 00005039 00000476 00000002
01/08/11 10.43.01	kernel	0000047c 00000100 00000000 00000016
01/08/11 10.43.01	kernel	00000000 00000000 00000043
01/08/11 10.43.01	kernel	00000002 00000000
01/08/11 10.43.01	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
01/08/11 10.43.01	kernel	0000006e
01/08/11 10.43.01	kernel	00200000 00005039 00000474 00000002
01/08/11 10.43.01	kernel	0000047c 00000100 00000000 0000000d
01/08/11 10.43.01	kernel	00000000 00000000 00000047
01/08/11 10.43.01	kernel	00000002 00000000
01/08/11 10.43.01	kernel	NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
01/08/11 10.43.01	kernel	0000006e
01/08/11 10.43.01	kernel	00200000 00008297 00000474 00000040
01/08/11 10.43.01	kernel	0000047e 00001408 00000001 0000000d
01/08/11 16.43.01	kernel	00000000 00000000 01000013
01/08/11 16.43.01	kernel	00000040 00000000

con relativo sfarfallamento delle immagini, prima lieve e poi talmente invasivo da rendere necessario il riavvio. Ora proverò con una EFI String nel com.apple.boot.plist nella speranza che cambi la situazione, anche se non sono molto convinto che le cose andranno meglio. Quindi l'NVEnabler64.kext non era almeno in questo caso meno responsabile del problema quanto il Graphic Enabler....dopo l'Efi string (userò EFI Studio) mi rimarrà l'adozione del dsdt del quale ignoro completamente la logica, quindi cercherò di erudirmi sul forum e spero che ciò basterà ad aprirmi la mente! Ma non c'è nessuno in questo forum che ha la mia stessa scheda video e madre con un problema simile?

Grazie infinite. D.

#16
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Niente da fare, la Efi String mi da schermo nero, probabilmente è dovuto al fatto che le uscite DVI della scheda video non vengono abilitate. Qualche consiglio su come abilitarle?
Adesso son tornato in GraphicsEnabler, ma la situazione è sempre la stessa.

Girovagando in rete ho trovato diversi 3d aperti sul forum apple, con lo stesso errore:

NVDA(OpenGL): Channel exception!

NVDA (OpenGL) Channel Exception Errors When Dragging Photos into iMovie'09

e via dicendo...

la cosa mi spaventa perché non mi pare sia giunta alcuna soluzione dagli alti vertici della Apple; che ne dite?

Saluti. D.

#17
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Ho scaricato OpenGL Extensions Viewer 4.0 e fatto il test per verificare se tutto è in regola, questi sono i risultati con le impostazioni visibili nello screenshot:

Posted Image

qualcuno sarebbe così gentile da darmi conferma che rientrano nella norma?

Inoltre ho rilevato qualche anomalia per quanto concerne le funzionalità del processore, pare infatti che ci sia più di qualcosa che non e supportata; vi sarei molto grato se deste un'occhiata anche quì:

Posted Image

Durante il test, ripetuto più volte per mettere sotto stress la scheda video, non ho avuto problemi. La cosa strana però è che puntualmente facendo certe operazioni che non richiedono risorse grafiche esose, come sfogliare foto, aprire pagine web ecc, il sistema manifesta gli errori già ampiamente documentati nel 3d e spesso si rende necessario il riavvio.

***********

Ciao copil sulla casella di posta elettronica mi arrivano le tue risposte, ma quando vado a leggere il 3d quello che hai scritto non c'è, come se venisse cancellato. Ad ogni modo riporto quì la tua domanda e rispondo di conseguenza:

----------------------------------------------------------------------
Come crei la tua stringa EFI personalizzata?
----------------------------------------------------------------------

uso EFI studio 1.1 seleziono il modello della mia scheda video dall'elenco, in questo caso:

nVidia GeForce 9800 GT [G92] - 1024

clicco su Add Device, e poi salvo nell' apple.com.boot.plist. Andando poi a verificare ho un file di configurazione con la EFIString correttamente inserita. Ma sembra che la EFI string non contempli le uscite DVI della mia scheda, perché il sistema viene caricato ma è come se ci fosse qualche problema con le uscite video, in quanto si sentono suoni, se dalla tastiera provo ad aprire il lettore dvd si apre, quindi è solo un problema di DVI. Forse devo personalizzare ulteriormente la EFIString?

Grazie ancora. Saluti. D.

#18
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,717 posts
  • Gender:Male
  • Location:Italy
Prova a fare una custom EFI strings, dagli il nome che vuoi, dagli la ram 1024MB=1GB poi metti uscita dove chiede DVI-VGA etc. tu metti DVI-DVI. Usa org.chameleon.Boot.plist ormai si usa solo quello in /Extra.
Usa Osx86Tools, copia e incolla la stringa a mano una volta generata che a volte non te la fa aggiungere in automatico in boot.plist.

#19
damiafix

damiafix

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
Ciao Copil,
allora, partendo dalla EFI String che mi genera EFI Studio, cosa dovrei andare a modificare precisamente? Eccola quì:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
	<dict>
	<key>PciRoot(0x1)/Pci(0x7,0x0)/Pci(0x0,0x0)</key>
		<dict>
		<key>@0,compatible</key>
		<string>NVDA,NVMac</string>
		<key>@0,device_type</key>
		<string>display</string>
		<key>@0,name</key>
		<string>NVDA,Display-A</string>
		<key>@1,compatible</key>
		<string>NVDA,NVMac</string>
		<key>@1,device_type</key>
		<string>display</string>
		<key>@1,name</key>
		<string>NVDA,Display-B</string>
		<key>@2,#adress-cells</key>
		<string>0x01000000</string>
		<key>@2,#size-cells</key>
		<string>0x00000000</string>
		<key>@2,compatible</key>
		<string>NVDA,sensor-parent</string>
		<key>@2,device_type</key>
		<string>NVDA,gpu-diode</string>
		<key>@2,hwctrl-params-version</key>
		<string>0x02000000</string>
		<key>@2,hwsensor-params-version</key>
		<string>0x02000000</string>
		<key>@2,name</key>
		<string>sensor-parent</string>
		<key>@2,reg</key>
		<string>0x02000000</string>
		<key>NVCAP</key>
		<data>BAAAAAAAAwAMAAAAAAAABwAAAAA=</data>
		<key>NVPM</key>
		<data>AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==</data>
		<key>VRAM,totalsize</key>
		<data>AAAAQA==</data>
		<key>device_type</key>
		<string>NVDA,GeForce</string>
		<key>model</key>
		<string>NVIDIA GeForce 9800 GT EFI</string>
		<key>name</key>
		<string>NVDA,Parent</string>
		<key>rom-revision</key>
		<string>3172a</string>
	</dict>
</dict>
</plist>

non sono in grado di riconoscere con sicurezza la chiave inerente alle uscite video.

Tra l'altro facevo una riflessione, ma EFI Studio, in automatico recupera l'id della mia scheda video e lo inserisce nella EFI?

Nel frattempo ho ulteriormente aggiornato Chameleon alla versione 2.0-RC5 r1252 e installato Champlist; la gui è molto comoda, anche se mancano alcune istruzioni come il PCIroot ed altre he invece da Lizard è possibile selezionare. Infatti ho dovuto inserirle manualmente, per non correre il rischio che il GraphicsEnabler non fuzionasse al riavvio. Ora il mio org.chameleon.Boot.plist si presenta come segue:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Boot Graphics</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>1600x1200x32</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>Kernel Flags</key>
	<string>arch=X86_64</string>
	<key>PciRoot</key>
	<string>1</string>
	<key>Timeout</key>
	<string>5</string>
</dict>
</plist>

Ma non credo faccia molta differenza per quanto concerne il problema dell'errore sopracitato.

Grazie ancora. D.

#20
copil

copil

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,717 posts
  • Gender:Male
  • Location:Italy
Quello è un plist non c'è valore esadecimale dentro, verrà convertito in seguito, usa Osx86Tools ti da già il valore esadecimale. Elimina GraphicsEnabler=Yes e metti la stringa EFI.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy