Jump to content

Léger problème d'affichage avec Léopard sur un Samsung R20


  • Please log in to reply
8 replies to this topic

#1
Neobahamut

Neobahamut

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:France
Bonjour à toutes et à tous,

Ne pouvant plus voir mon Seven en peinture, j'ai décidé de tester une installation d'OSX sur un Samsung R20.
J'ai fait l'installation avec une 10.5.2 Kalyway, l'installation s'est super bien faite, impeccable mais au reboot, je me suis retrouvé avec du son mais un écran noir.
J'ai appliqué la méthode suivant après quelques recherches : http://www.insanelym...showtopic=82408
J'ai rebooté en safe mode puis normalement, c'est bon j'ai tout en français et un affichage. Malheureusement, j'ai besoin de votre aide pour la suite car je ne sais pas comment m'y prendre.

Mon chipset ATI est un XPRESS1200 référencé dans le wiki comme fonctionne avec une Kalyway justement. Mais là j'ai une résolution possible uniquement 1024x768 et c'est une peu lent, l'accélération graphique ne doit pas fonctionner correctement puisque plus de driver ATI.

Comment dois je m'y prendre pour installer le driver ? En réinstallation l'OS avec le DVD ? Et téléchargeant un driver quelque part ?

Merci d'avance pour vos éclairages !
Félicitations pour votre forum :rolleyes:

#2
Badaboum03

Badaboum03

    Mr. KFC

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Belgium
Si le Kext est sur le DVD de Kalyway, installe le programme Pacifist pour extraitre ce kext et installer la carte graphique !

#3
Neobahamut

Neobahamut

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:France
Merci de m'avoir répondu.

Quand j'insère le DVD une fois MacOSX lancé, en fait j'ai uniquement un programme en apparence qui me dit : installation de macosx et me prévient qu'il va redémarrer.

Il me faut donc Pacifist pour installer les Kext que je trouve ici ? : http://www.kexts.com...php?do=cat&id=6

C'est bien cela ? Encore désolé pour les questions basiques mais certaines choses du wiki en anglais m'échappent ;)

#4
Badaboum03

Badaboum03

    Mr. KFC

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Belgium
D'abord, fais une installation normale, sans sélectionner de kext. voir si ca boot
Si tout fonctionne a part la carte graphique, c'est une bonne nouvelle.
Pour installer un kext, pas besoin de tout réinstaller.
Par contre je sais pas où tu as vu que le chipset X1200 était compatible mais sur le Wiki , si tu aurais un lien

#5
Neobahamut

Neobahamut

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:France
Ok j'ai fait une installation avec kernel sleep pour laptop, installé uniquement le driver ATI X1000 series. Kext Help et Pacifist. Dans les informations système il est écrit qu'aucun kext n'est chargé au niveau carte vidéo / moniteur. Je ne sais pas si c'est important mais j'ai un affichage en 1024 x 768 uniquement proposé dans Display d'ailleurs ... Quartz Extreme est désactivé (c'est l'accélération graphique je suppose ?)

En fait j'ai un chip 1250 http://wiki.osx86pro...CL_10.5.2#ATI_2
ha zut, je lis actuellement ... There is no support currently for the x1250 integrated graphics.

Par contre, quelqu'un semble avoir réussi à trouver une super méthode pour avoir la résolution native de l'écran : http://www.insanelym...p...74483&st=20 qui indique http://wiki.osx86pro...8/Portables#ZA8

Est ce que tu peux me guider un peu, que dois je faire de ce fichier kext ? Il dise qu'il me faut : ACPIfix. Mais comment le trouver ? J'ai fait des recherches et rien :)

EDIT ---
J'essaye d'installer le .kext avec KextHelper, je n'ai pas le bouton Easy Install de dispo, je ne sais pas où cliquer ;)

EDIT -
Avec Pacifist, j'ai extrait le contenu de RadeonHD.kext.zip dans Système > Bibliothèques > Extensions mais cela ne semble pas suffir ..

EDIT -
Bon je vais me coucher, au redémarrage, il me dit que l'extension système ne peut être utilisé et on me conseille de réinstaller l'extension ... je patauge, je vais attendre un petit coup de pouce en cherchant encore, je dois rater quelque chose de vraiment basique

#6
Neobahamut

Neobahamut

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:France
C'est bon j'ai fait une réinstallation avec le patch ACP dans la distro Kalyway et j'ai pu installer le pilote Radeon et avoir ma résolution en 1280 par 800

C'est super ça roule malgré qu'une fois sur 3 j'ai un message qui apparait me demandant de maintenir le bouton d'alimentation afin de redémarrer :) Des idées ?

#7
Badaboum03

Badaboum03

    Mr. KFC

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
  • Location:Belgium
Demarre avec -v pour voir ou ca coince !

#8
Neobahamut

Neobahamut

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:France
Ok merci je vais essayer :D

#9
Neobahamut

Neobahamut

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:France
Bon bah super, ça roule au poil, après avoir vu que j'avais des Kernel Panic à cause d'un patch SEE2 j'ai fait une réinstal' en choisissant d'autres options et là ça tourne impecc avec ma résolution native !

Merci pour ton aide :unsure: Bonne continuation, je vais rester avec c'est le mieux que j'ai trouvé fonctionnel à part le Vista préinstallé. Il ne supportait ni Smeegol ni Gnome3 malheureusement.

@ pluche





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy