Jump to content

Intel HD Graphics / i7 2600


  • Please log in to reply
153 replies to this topic

#141
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,277 posts
  • Gender:Male

I eventually figured this out, and it is due to a bug in Chameleon. I described the cause in the Chameleon issue at http://forge.voodoop...eon/issues/123/. The problem occurs for versions of Chameleon after r1107. In the issue, I describe how you can fix it for more recent versions.

Great job finding that regression. I wish the chameleon team would keep track of the latest stable version. I guess everyone should stay at <= 1107. Not aware of any important changes since then anyways, are you?

That's generally true, but the 2405S and 2500K have HD 3000. You can see that in the processors in bold at http://en.wikipedia....ktop_processors

Hopefully apple will add more sandy bridge products and clean up their PCI match list in the process...

#142
dougaa

dougaa

    InsanelyMac Geek

  • Donators
  • 179 posts

Great job finding that regression. I wish the chameleon team would keep track of the latest stable version. I guess everyone should stay at <= 1107. Not aware of any important changes since then anyways, are you?
Hopefully apple will add more sandy bridge products and clean up their PCI match list in the process...

The Chameleon developers just fixed this in the trunk in r1221. So either <= 1107 or >= 1221. I know many changes are being made, not sure if any are very important. I wouldn't be surprised if they're trying to finish a stable release that works with Lion and also with Sandy Bridge.

#143
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,277 posts
  • Gender:Male

The Chameleon developers just fixed this in the trunk in r1221. So either <= 1107 or >= 1221. I know many changes are being made, not sure if any are very important. I wouldn't be surprised if they're trying to finish a stable release that works with Lion and also with Sandy Bridge.

The diffs I put together for the chameleon mainline for sandy bridge were commited 2 months ago, and the lion support was in even before that, so seems like a new stable rc is overdue... Oops getting off topic.

#144
ltoozdotcom

ltoozdotcom

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
I just want to thank Kyle_c and Lenovo3000, I got my Lenovo G770 10372LU run native resolution 1600x900 with full QE/CI/CL PAINLESSLY.

Using Quicktime screen recorder to record this

Using ##### 3.8 with these only selections

Attached File  Screen_shot_2011_08_29_at_1.48.33_PM.png   43.01KB   708 downloads

add device-properties from Lenovo3000 in com.apple.Boot.plist

Just follow Kyle_C instruction and it works perfectly.

Attached File  Screen_shot_2011_08_29_at_1.25.15_PM.png   67.7KB   627 downloads
Attached File  Screen_shot_2011_08_29_at_1.23.37_PM.png   1.12MB   402 downloads

Thanks again guys, I'm tired of trying the Gateway NV55C with HD5700- Wasted so much time.

I used the HDMI output and it automatically show the TV has dual monitor. I can drag the movie across the main screen to the TV. I can't switch the main screen to the TV.

Attached File  P1190218.jpg   160.27KB   278 downloads

Louis


#145
BloodyVlad

BloodyVlad

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:Ukraine
Thanks people! I've got my HD3000 0116 working in 10.6.8 with full resolution (1366x768) and fast speed! But! I have enormous artifacts, garbled icons and Youtube Flash Player hangs in Chrome. Safari fails to start. Even finder windows sometimes restart itself. I have much less artifacts and defects if I start with maxmem=2048, then when using all 4Gb of RAM. Now I have Lenovo3000's device string in Boot.plist, MBP8,1 smbios, and changed my GFX0 to IGD0 in DSDT, but I dont thinks it was really needed. And I have only 2 video kexts loaded - AppleIntelHDGraphics и AppleIntelSNBGraphicsFB. Please help to beat the last problems!

#146
LowRidinCrew

LowRidinCrew

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Cleveland, Ohio
How can I change my damn 5700 to 3000 ID might as well do that since no one is helping with 5700

#147
ltoozdotcom

ltoozdotcom

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male

Is anyone else here trying to get the build-in graphics of an i5/i7 Sandy Bridge CPU working (2xxx, H67 chipset)?

Doesn't look like there is solution yet so I would like to compile what doesn't work.

Not working:
- latest MacPro kext's

Not yet tried:
- latest 10.6.7 combo update
- Lion kext

Has anyone the these yet or can think about what might be worth a try?


For those who has Sandy Bridge Laptop and has artifacts, screen tearing and white lines after monitor sleep wakes, I fixed it by editing DSDT.

DSDTfix youtube video

PS: Lenovo3000, this may fix your black screen problem if you haven't fixed it yet.

#148
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 808 posts
  • Gender:Male

For those who has Sandy Bridge Laptop and has artifacts, screen tearing and white lines after monitor sleep wakes, I fixed it by editing DSDT.

DSDTfix youtube video

PS: Lenovo3000, this may fix your black screen problem if you haven't fixed it yet.

Please post your dsdt edit code. Thanks.

#149
ltoozdotcom

ltoozdotcom

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male

Please post your dsdt edit code. Thanks.


Here you go,
This one will show backlight slider + fixed the artifacts and tearing on the screen. I don't believe this one will work with HD3000 + Another graphic card. ONLY HD3000 stand alone laptop. 0x0116
Put this one in /Extra folder and chameleon will load it for you.


Attached File  dsdt.zip   15.26KB   198 downloads

Good luck,

Louis

#150
Tiago Aroeira Marliere

Tiago Aroeira Marliere

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male

Thanks people! I've got my HD3000 0116 working in 10.6.8 with full resolution (1366x768) and fast speed! But! I have enormous artifacts, garbled icons and Youtube Flash Player hangs in Chrome. Safari fails to start. Even finder windows sometimes restart itself. I have much less artifacts and defects if I start with maxmem=2048, then when using all 4Gb of RAM. Now I have Lenovo3000's device string in Boot.plist, MBP8,1 smbios, and changed my GFX0 to IGD0 in DSDT, but I dont thinks it was really needed. And I have only 2 video kexts loaded - AppleIntelHDGraphics и AppleIntelSNBGraphicsFB. Please help to beat the last problems!



Hello BloodyVlad, I have a notebook with 1.6.8 w HD3000 0116 without QE/CI. I had to delete de SNBGraphicsFB.kext to make system boot. If i use this kext, my system stuck on a gray screen.

Can u send me your AppleIntelSNBGraphicsFB.kext?

My system is:
Snow Leopard 10.6.8 retail
i7 2630QM - HD Graphics 3000 (0116)
4gb RAM
Realtek RTL8139/810X wired Ethernet (working with AppleRTL8169Ethernet.kext)
Poor Realtek RTL8191se Wlan changed by Atheros 5008x Wlan (working Oob)
Realtek alc662 sound (Noisy and garbled Sound VoodooHDA)

If i make QE/CI works, i`ll fix the sound and my notebook is OPERATIONAL TO USE!

Thanks for your help!

#151
BloodyVlad

BloodyVlad

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:Ukraine

Hello BloodyVlad, I have a notebook with 1.6.8 w HD3000 0116 without QE/CI. I had to delete de SNBGraphicsFB.kext to make system boot. If i use this kext, my system stuck on a gray screen.

Can u send me your AppleIntelSNBGraphicsFB.kext?

My system is:
Snow Leopard 10.6.8 retail
i7 2630QM - HD Graphics 3000 (0116)
4gb RAM
Realtek RTL8139/810X wired Ethernet (working with AppleRTL8169Ethernet.kext)
Poor Realtek RTL8191se Wlan changed by Atheros 5008x Wlan (working Oob)
Realtek alc662 sound (Noisy and garbled Sound VoodooHDA)

If i make QE/CI works, i`ll fix the sound and my notebook is OPERATIONAL TO USE!

Thanks for your help!

Just install Lion as i did. Everything will work.

#152
Tiago Aroeira Marliere

Tiago Aroeira Marliere

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male

Just install Lion as i did. Everything will work.


Thanks for answer my question!

I ll install lion.

I have a OSX Lion purchased on a App Store (the File, not the pendrive)
* I have a original Macmini and bought it.

Can I use him following the instructions over the internet or there some trick to install OSXLion in our System?

#153
BloodyVlad

BloodyVlad

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:Ukraine

Thanks for answer my question!

I ll install lion.

I have a OSX Lion purchased on a App Store (the File, not the pendrive)
* I have a original Macmini and bought it.

Can I use him following the instructions over the internet or there some trick to install OSXLion in our System?


I believe it's off topic.
I've bought Lion to pay it's authors for a good job. But I used a pre-installed dmg image, restored it to my partition and installed chameleon and needed kexts.

#154
Tiago Aroeira Marliere

Tiago Aroeira Marliere

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male

I believe it's off topic.
I've bought Lion to pay it's authors for a good job. But I used a pre-installed dmg image, restored it to my partition and installed chameleon and needed kexts.



OSX Lion 10.7.1 working like a charm!
Only a sleep issue and onboard speakers not working (headphone output, ok)

Thanks, now I have a operational notebook with osx.

If anyone is finding for kexts of CCE 745b Notebook on lion, here my setup:
Setup full CCE 745b oSX Lion





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy