Jump to content

[GUIDA] Snow Leopard Vanilla GA-X58A-UD3R rev 2.0 + ATI 5870


  • Please log in to reply
7 replies to this topic

#1
thefoul

thefoul

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
  • Gender:Male
  • Location:Rome, Italy
Snow leopard su GA-X58A-UD3R rev 2.0

Credits to

Tonymac86 per il suo blog, per ##### ATI e per il comodissimo #####
Lo user Jpa che ha postato la guida di base in Inglese
Lo user paulo dourado il cui DSDT mi pare per ora il migliore
Il grandissimo Netkas senza il quale molto di cio' che facciamo non sarebbe possibile

Riferimenti essenziali

Guida in Inglese di jpa
http://www.tonymacx8....php?f=3&t=4701

Official CustoMac Pro 2010 Install Guide
http://www.tonymacx8....php?f=3&t=4837

Boot cd per le ATI di ultima generazione
http://www.tonymacx8...php?f=18&t=3651

Support Group for Confused Owners of the GA-X58A-UD3R **rev 2.0**, Discussion about solutions for this unique model (*not* rev 1.0)
http://www.insanelym...howtopic=220199


Configurazione

GA-X58A-UD3R rev 2.0 (BIOS FA)
Core i7 930 2.80 GHz 4.80 QPI 4cores 8threads
(se avete un buon dissipatore potete anche overclockare)
6 GB di RAM DDR3 1333 MHz
XFX ATI Radeon 5870 1GB VRAM

Files

Boot cd = ##### ATI 5xxx-3
http://www.tonymacx8...-5xxx-3.iso.zip

Miglior DSDT (provato) : post #102 (user: paulo dourado)
http://www.insanelym...p...&start=100#

##### 2.1.4
http://www.tonymacx8.../MultiBeast.zip

Retail DVD di Snow Leopard con la 10.6.4
oppure
Retail DVD di Snow Leopard + Combo Update 10.6.4
http://support.apple...Combo10.6.4.dmg

Snow Leopard Graphics
http://support.apple...csUpdate1.0.dmg

FakeSMC per MacPro 4.1
http://www.mediafire...3h8zp2ai2i2tqai

Legacy HDA889
http://www.mediafire...pipm4mmr9gl7a05

IONetworkingFamily con modifiche per Realtek 8111D
http://www.mediafire...mc16ark31b0azfx

KextUtility
versione aggiornata su Kexts.com


Pre-install - Settaggi BIOS

boot Priority CD/DVD come primario
PCH SATA CONTROL cambiare in ACHI
ONBOARD SATA... all sata cambiare in ACHI
USB 3.0 per il momento…disabilitatelo per sicurezza
HPET cambiare 64-bit mode
ACPI SUSPEND tenere S3 STR

Installazione

1.) Fate il Boot dal cd di ##### ATI 5xxx-3
2.) Togliete il cd di ##### ed inserite il DVD di Snow Leopard
3.) Installate OS X e fate il primo Reboot utilizzando di nuovo ##### ATI 5xxx-3
4.) Rimuovete il cd di ##### ATI 5xxx-3.
5.) Lanciate ##### ma tenetelo aperto SENZA fare partire l'installer
6.) Installate Mac OS X v10.6.4 Update (Combo) SENZA farlo riavviare
7.) Installate Snow Leopard Graphics Update SENZA farlo riavviare
8.) Ora potete lanciare ##### e selezionare le seguenti opzioni:
- UserDSDT
- Advanced Options -> Kexts -> Audio -> LegacyHDA -> ALC889
- Advanced Options -> Kexts -> Disk -> JMicron36x (aka GSATA) -> JMicron36xeSATA oppure JMicron36xSATA a seconda che vogliate utilizzare le porte GSATA come interne o esterne
- Advanced Options -> Kexts -> Disk -> JMicron36x (aka GSATA) -> JMicron36xATA (per il supporto opzionale ATA/IDE)
- Advanced Options -> Kexts -> Graphics -> Enablers -> ATY_Init Vervet
- Advanced Options -> Kexts -> Network -> Realtek Gigabit Ethernet -> Realtek RTL8169 Ethernet
- Advanced Options -> com.apple.boot.plist -> 32-bit GraphicsEnabler=No
- Advanced Options -> smbios.plist -> Mac Pro -> Core i7
9.) Chiudete #####
10.) Copiate le tre kext che avete scaricato in /Extra/Extensions
11.) Modificate i file /Extra/com.apple.Boot.plist e /Extra/smbios.plist (vedi Addenda)
12.) lanciate KextUtility e fatelo girare
13) Cliccate su restart su Mac OS X v10.6.4 Update (Combo) o sullo Snow Leopard Graphics Update che ancora tenevate aperti
10.) Snow Leopard e' vostro

Addenda

In com.apple.Boot.plist dovreste includere quanto segue:
-v arch=i386 GraphicsEnabler=NO DropSSDT=YES

Dovreste anche modificare il vostro smbios.plist in modo da renderlo adattto.
Io per esempio ho indicato il MacPro 4.1, il tipo di processore (Core i7), il data transfer rate per QPI 4.8 e il memory type.

Ovvero:
<key>SMfamily</key>
<string>MacPro</string>
<key>SMproductname</key>
<string>MacPro4,1</string>

<key>SMcputype</key>
<string>1793</string>
<key>SMbusspeed</key>
<string>4800</string>

<key>SMmemtype</key>
<string>24</string>
<key>SMmemspeed</key>
<string>1333</string>

Se volete togliervi delle curiosità' in merito alle prestazioni e sapete bene dove mettere le mani, vi consiglio di provare diversi DSDT e addirittura di avviare senza DSDT.aml per fare dei raffronti.

Ricordatevi che essendo ATY.Init ancora a 32bit non e' possibile per il momento avere una configurazione stabile avviando a 64bit.
Appena netkas metterà' le mani su una ROM nativa Apple potremo fare un salto in avanti.

Ovviamente se avete schede grafiche NVIDIA il discorso si ribalta:
- dovrete utilizzare un cd di boot differente (##### NVIDIA)
- a seconda della scheda in uso potrete utilizzare GraphicsEnabler=YES oppure un injector
- se avete a disposizione kext NVIDIA a 64bit potrete fare a meno di arch=i386

#2
blengyo

blengyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male
ola! primo approcio ocn mondo apple..

ho la stessa mobo della guida, e stesso bios, ma non trovo dove modificare qusti 2 parametri

PCH SATA CONTROL cambiare in ACHI
ONBOARD SATA... all sata cambiare in ACHI

inoltre vorrei chiedere se è rilevante che io non abbia una 5870 ma una 5850, che il procio sia un i7 920, non la versione 930, e le ram siano da 1600

se faccio boot da cd con ##### ATI 5xxx-3 non so in che momento inserire il dvd di SL, col cd mi chiede sempre di riavviare

#3
David23

David23

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,921 posts
  • Gender:Male
  • Location:Como
e dai...
sto regolamento accidenti

#4
blengyo

blengyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male

e dai...
sto regolamento accidenti


grazie, mi ero scordato della firma, ora l'ho aggiunta
mi scuso per la dimenticanza

#5
thefoul

thefoul

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
  • Gender:Male
  • Location:Rome, Italy

ola! primo approcio ocn mondo apple..


In tal caso consiglio: vatti a leggere le guide di base...altrimenti dovrei fare incetta di analgesici e anti-depressivi.

ho la stessa mobo della guida, e stesso bios, ma non trovo dove modificare qusti 2 parametri

PCH SATA CONTROL cambiare in ACHI
ONBOARD SATA... all sata cambiare in ACHI


Do per scontato che tu abbia una rev.2.0 con l'ultimo BIOS installato.
In caso contrario devi usare un'altra guida oppure aggiornare prima il bios.

inoltre vorrei chiedere se è rilevante che io non abbia una 5870 ma una 5850,


Si lo e': la tua scheda video potrebbe non essere supportata dalle kext precaricate nel boot cd ATI di Tonymac.

che il procio sia un i7 920, non la versione 930, e le ram siano da 1600


Si lo e': dovrebbe cambiare FSB multiplier da passare come boot arg all'avvio. busspeed dovrebbe rimanere invariato.

se faccio boot da cd con ##### ATI 5xxx-3 non so in che momento inserire il dvd di SL, col cd mi chiede sempre di riavviare


Come dicevo un paio di righe sopra.....la scheda video non e' supportata.
Puoi provare ad usare un boot cd meno specifico (tipo il Supported) ed applicare le kext specifiche per la tua scheda video in un secondo momento (cioe' una volta installato e messo a posto il boot loader con #####).

Inutile dire che il tutto si complica un po'.

Consiglio: usa un'altra scheda video supportata al 100%.

AGGIORNAMENTO
Ancora sulla 5850: apparentemente l'hanno fatta funzionare usando lo stesso driver di netkas ma cancellando nvdanv50hal.kext, nvenabler 64.kext, nvdaresman.kext

Buona fortuna.

#6
blengyo

blengyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male
perfetto, grazie per la risposta

tra un tentativo e un altro, un giorno di pausa e altri di tentativi, sono riuscito ad installare una distro, ho messo iatkos

ho cercato di seguire un po questa utile guida, e un po questa questa: http://tonymacx86.bl...ac-os-x-on.html

al primo utilizzo, senza installare aggiornamenti alla 10.6.4 ne ##### ne il graphic update, la macchina risulta funzionante, internet, audio (non ho guardato il mic). devo quindi proseguire e mettere gli aggiornamenti?
l'unico problema è la risoluzione non modificabile. dovrò quindi aggiugnere i driver della mia 5850

per la vga ho fatto riferimento a questo link
http://netkas.org/?p=465
devo ancora effetuare i 2 passaggi, cioè scaricare aty_init e i driver segnalati

sta sera torno a casa e provo, vi tengo aggiornati

se ci sono segnalazioni, avvertimenti o correzioni sono benvenuti! e se sto andando troppo OT dato che questa è una guida specifica mi scuso, e cerco un altro thread in cui postare per essere assistito durante i vari passaggi

saluti ;)

#7
blengyo

blengyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male

perfetto, grazie per la risposta

tra un tentativo e un altro, un giorno di pausa e altri di tentativi, sono riuscito ad installare una distro, ho messo iatkos

ho cercato di seguire un po questa utile guida, e un po questa questa: http://tonymacx86.bl...ac-os-x-on.html

al primo utilizzo, senza installare aggiornamenti alla 10.6.4 ne ##### ne il graphic update, la macchina risulta funzionante, internet, audio (non ho guardato il mic). devo quindi proseguire e mettere gli aggiornamenti?
l'unico problema è la risoluzione non modificabile. dovrò quindi aggiugnere i driver della mia 5850

per la vga ho fatto riferimento a questo link
http://netkas.org/?p=465
devo ancora effetuare i 2 passaggi, cioè scaricare aty_init e i driver segnalati

sta sera torno a casa e provo, vi tengo aggiornati

se ci sono segnalazioni, avvertimenti o correzioni sono benvenuti! e se sto andando troppo OT dato che questa è una guida specifica mi scuso, e cerco un altro thread in cui postare per essere assistito durante i vari passaggi

saluti :P


allora ho messo i driver segnalati nell'ultimo link del mio post precedente e sembrano funzionare, ora posso cambiare risoluzione, pero vedo dei difetti grafici, ad esempio in certi video dove vengono inquadrate delle luci forti, vedo dei pixel, oppure alto esempio lo screen principale di snow leopard, vedo in basso a destra l'immagine un po pixellata, e colori non molto fedeli
ci son dei test che posso fare per verificare?

ora sto riprovando ad effettuare un'altra isntallazione su un altro hdd, tanto per vedere le differenze utilizzando ##### e i 2 aggiornamenti alla 10.6.4 e l'update grafico...

visto che il DSDT segnalato qua non va bene perche ho componenti un po diversi, dopo aver avviato ##### devo selezionare ##### e non user dsdt vero?
sapete consigliarmi cosa spuntare dopo? tra l'altro nella sezione ati non vedo x5xxx :S

grazie e scusate la niubbaggine, pian piano cerco di allinearmi :)

#8
blengyo

blengyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male

allora ho messo i driver segnalati nell'ultimo link del mio post precedente e sembrano funzionare, ora posso cambiare risoluzione, pero vedo dei difetti grafici, ad esempio in certi video dove vengono inquadrate delle luci forti, vedo dei pixel, oppure alto esempio lo screen principale di snow leopard, vedo in basso a destra l'immagine un po pixellata, e colori non molto fedeli
ci son dei test che posso fare per verificare?

ora sto riprovando ad effettuare un'altra isntallazione su un altro hdd, tanto per vedere le differenze utilizzando ##### e i 2 aggiornamenti alla 10.6.4 e l'update grafico...

visto che il DSDT segnalato qua non va bene perche ho componenti un po diversi, dopo aver avviato ##### devo selezionare ##### e non user dsdt vero?
sapete consigliarmi cosa spuntare dopo? tra l'altro nella sezione ati non vedo x5xxx :S


grazie e scusate la niubbaggine, pian piano cerco di allinearmi :)


up





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy