Jump to content

Overheating with AMD!


  • Please log in to reply
6 replies to this topic

#1
audio84

audio84

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hi there,

I've successfully installed OSX86 (iAtkos v7 10.5.8) onto my HP Pavilion DV6500 laptop. It has an AMD 3800+ (1.9ghz) processor, an 8400m GS nVidia GPU, and 2GB ram. The OS runs absolutely flawlessly and I'm very pleased, except the problem I have with overheating. The processor is extremely hot, and the fan is working at its best to cool the unit down.. except it's already turned itself off 3 times due to the heat.

Now I've looked into this and I've done everything I can think of. Deleting Thermo kexts from the Extensions folder (does nothing), installing CoolBook (doesn't read my CPU info), VoodooPower (gives a panic), VoodooPowerMini (doesn't do anything at all), tried booting with cpus=1 (nothing), tried an AMD throttling kext (modified ACPICPUthrottle.kext, still nothing), so I'm starting to run out of ideas. I've tried different graphics kexts to see if it was conflicting but there's no difference when I use different kexts for the gpu.

What, the hell, is going on!? The processor does cool down if its running off the battery, but still not as cool as it should be.. but when I plug it in to charge it'll heat up so ridiculous extents.

Please help, thank you!

Geraint.

#2
kalel83

kalel83

    Kryptonian

  • Donators
  • 191 posts
  • Gender:Male
  • Location:127.0.0.1
get a better cpu cooler + thermal paste and install it correctly before you burn it out
most likely it is running at full speed, without any power management.

and you will never get snow leopard working correctly on that. I know, because I used to use a 3800+ myself

#3
audio84

audio84

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

get a better cpu cooler + thermal paste and install it correctly before you burn it out
most likely it is running at full speed, without any power management.

and you will never get snow leopard working correctly on that. I know, because I used to use a 3800+ myself


I don't really want to go fiddling around with the insides of the laptop, it runs perfectly with Windows 7 and I plan to keep it that way. The OSX86 is installed to an external HD (plugged into the laptop, it'll start as a mac. Unplugged it'll start as Windows 7), so I'd rather give that a miss. I've heard people with 3800's and TK-55's with no heat problems at all, but I've tried what they did with no avail. Must be something I'm doing wrong..

I'm not using Snow Leopard by the way, it's just Leopard. I'm more than happy with that.. unless you think Snow Leopard would be better for cooling? Couldn't see how though.

#4
audio84

audio84

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Actually if I can point something out.. when the laptop is running on the battery, the fan does die down quite a bit, and the heat does calm down a drastic amount. It's not as cool or quiet as it normally is under windows, but it's definitely got some power management when running off the battery. Now if I plug it in and run it off the adapter, the fans start to build up gradually along with the heat, until it gets so hot it turns itself off.

Would that give a clue to what's wrong?

#5
kalel83

kalel83

    Kryptonian

  • Donators
  • 191 posts
  • Gender:Male
  • Location:127.0.0.1

Actually if I can point something out.. when the laptop is running on the battery, the fan does die down quite a bit, and the heat does calm down a drastic amount. It's not as cool or quiet as it normally is under windows, but it's definitely got some power management when running off the battery. Now if I plug it in and run it off the adapter, the fans start to build up gradually along with the heat, until it gets so hot it turns itself off.

Would that give a clue to what's wrong?


I actually totally overlooked that you said laptop, even tho its in the first sentence :)

It's the bios/hardware that detects the lack of AC power and then lowers the cpu processor/fan speed, not OS X (as OS X would have no idea to do so on AMD). Otherwise, an AMD processor in OS X has no instructions of fast or slow unless from a 3rd party kext or kernel. Saying "it has some power management because it slows down when you unplug it" is like saying "it has power management because it turns off when I hit it with a hammer".
Clean out the dust. Until you find proper Power Management your system will be working without a throttle control most likely, so you could expect a shorter life expectancy then usual (as in it could suddenly burn out).

I gave up on my amd 3800+ about 6 months ago, so if anything has changed, I wouldn't know. Maybe there is a new PM kext out there.. If I remember correctly Leopard 10.5 had some awesome kernels made(on the fly cpuid patching for one), maybe what you need is a different kernel, not kext

#6
audio84

audio84

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

I actually totally overlooked that you said laptop, even tho its in the first sentence :P

It's the bios/hardware that detects the lack of AC power and then lowers the cpu processor/fan speed, not OS X (as OS X would have no idea to do so on AMD). Otherwise, an AMD processor in OS X has no instructions of fast or slow unless from a 3rd party kext or kernel. Saying "it has some power management because it slows down when you unplug it" is like saying "it has power management because it turns off when I hit it with a hammer".
Clean out the dust. Until you find proper Power Management your system will be working without a throttle control most likely, so you could expect a shorter life expectancy then usual (as in it could suddenly burn out).

I gave up on my amd 3800+ about 6 months ago, so if anything has changed, I wouldn't know. Maybe there is a new PM kext out there.. If I remember correctly Leopard 10.5 had some awesome kernels made(on the fly cpuid patching for one), maybe what you need is a different kernel, not kext


That's not actually what I meant. When the system is running off the battery, the fan speed will raise and lower itself according to what I'm doing, like it should and like it normally does in Windows 7. Plugging it in will cause the fans to shoot to 100%.

But, I've found the solution. I tried to fix a crackling sound problem by entering the "idlehalt=0" options into the boot.plist file, and that's what's caused all of these problems. Removing that has made the system a lot cooler, and the fans work a lot better. Weird, but it works.

I'm actually typing this on the OS X now, so it's working great, but I'll be taking the laptop apart tomorrow (have done so before so I'm familiar with the process), and will put some fresh thermal paste on. Haven't changed it since I've bought the laptop 3 years ago... :/

Anyway, cheers for the time and help. Much appreciated!

- Geraint.

#7
kalel83

kalel83

    Kryptonian

  • Donators
  • 191 posts
  • Gender:Male
  • Location:127.0.0.1
not sure about the thermal past on the laptop.. i was speaking before about desktops.... tho if you know what you are doing it wouldn't hurt I suppose. laptops all you can really do is clear out all the dust.

glad to hear it got working, strange solution, i don't see how the two are related at all.. but whateva





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy