Jump to content

[GUIDA]Snow Leo by Hazard su Hp Pavilion dv6560el (dual boot con 7)


  • Please log in to reply
48 replies to this topic

#1
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy
Salve a tutti,

sono arrivato su insanelymac per istallare Snow Leopard sul mio Pc;

bene, grazie al materiale trovato ed alle molte guide ci sono riuscito.

Vorrei fare questa piccola guida per noobs da un noobs(preciso che sono nel mondo hackintosh da circa una settimana) :D ; ma chiedo anche l'aiuto del forum per sistemare il tutto :rolleyes:

(se dovevo postare in 'Guide E Trucchi per Note/Netbooks ' vi prego di scusarmi e spostare, grazie)

ricapitolando:



  • Avevo Seven istallato
  • ho creato una nuova partizione di 30gb poi formattata col live cd di gparted in HTFS+
  • Per l'istallazione ho seguito questa guida by hpdv6lover (GUIDA) fino al punto 23
  • nelle personalizzazioni ho messo:
    [b][color="#0000ff"]Mac OS X Update: [/color][/b]Mac OS X 10.6.1 Update, Mac OS X 10.6.2 Update Combo - BootLoader:entrambi Pcefi 10.3 e 10.5 (crea automaticamente il dual boot con seven;), ma dovete mettere il flag 'boot' sulla partizione mac con gparted live) - Kernel: Legacy kernel 10.2 - Patches:Voodoo Battery Manager, PS2 Fix - SATA Fix: AHCI Fix - Audio:appleHDA - Video: Graphics Enabler + NVIject (gli NVI è forse meglio toglierli data la mia scheda video?)
  • completata istallazione (saltando controllo dvd che è inutile), e riavviato
  • quando parte il nuovo bootloader (compare la schermata grigia con la mela e la barra di caricamento) premete un tasto qualunque per fermarlo e compare la schermata per il dual boot.
  • scrivete "-x cpus=1 busratio=20" (senza virgolette) (-x è per l'avvio in safe mode)
  • scaricate questi 2 allegati (primo post della discussione kekt pack pavilion)
  • copiate la cartella 'extra' del primo zip nella root del mac, sovrascrivendo quella già presente; mentre nell'altro zip troverete una sottocartella 'system extension', copiate i kexkt che sono dentro in root\system\extension
  • riparate i permessi dei kext con l'utility osx86tools.
  • istallate l'italiano come indicato nella guida di hpdv6lover
  • riavviate normalmente senza stringhe di avvio e il vostro hackintosh partirà senza problemi.

All'avvio è quasi tutto funzionante, persino i tasti a sfioramento per regolare il volume :D



PERIFERICHE:

seguiranno aggiornamenti, ancora non ho provato nuovi kekt, stò ancora testando.


-Audio - Realtek ALC268 @ Intel 82801HBM ICH8M - High Definition Audio Controller: Funziona sia dagli altoparlanti integrati che dalle cuffie, microfono ancora da testare, non funziona autosensing (switch automatico cuffie/altoparlanti) (kext: VoodooHDA)
alternativa: Trovati altri kext per l'audio: invece del voodoohda che usavo (senza autosensing e con problemi in entrata/mic ) ho provato questi(HDAenabler + AppleHDA):
http://www.insanelym...p...=190650&hl=
(nel primo post 'audio in out....') che sembrano funzionare in tutto, tranne che ogni tanto (e quasi sempre, prima di un 'suono di sistema' si sente un 'tump' davvero fastidioso, tipo quando inserisci unjack audio di una cassa). per ora li tengo in attesa di meglio (a proposito, secondo voi quale potrebbe essere la causa, lk'AppleHDA o l'enabler?)

-Video - NVIDIA GeForce 8400M GS (128 MB): 100% full working (con Q/E e CI)!!!!: nessun kext istallato, nessuna EFI string. bisogna semplicemente inserire l'ID della propria scheda nei driver in bundle con Snow Leopard by Hazard(direi di non istallare alcun driver video durante l'istallazione di snow leopard;)) (nel pomeriggio con il mio hack alla mano mi spiego meglio!:)

-Modem - usb huaweii e1692 (brand Tim, ma con Sim Wind): istallato con software 'WIND easy connect'. funziona perfettamente e con velocità altissime!! (naturalmente la chiavetta istalla anche il software alice, proverò se disistallandolo funziona comunque tutto ;)

-Restart/Stop: il restart funziona benissimo, lo stop mi mette il portatile in una speie di standby, con la lucina alimentazione che lampeggia sempre (tipo lo standby di windows, è corretto sia così?) (OpenHaltRestart in \extra e in system\library\extension)

Spegnimento: grazie a questo dsdt postato da 'kalevra' (grazie;)):
DSDT
ho semplicemente messo il file in \extra ora lo spegnimento avviene in max 5 secondi :D:D

-luminosità schermo: perfetto!!! anche questo è risolto, dopo aver messo il dsdt di kalevra ora ho sempre la luminosità alta, e comunque modificabile tramite la solita combinazione di tasti!

-HP Webcam integrata: col PhotoBoot viene rilevata, si accende il led vicino, ma mostra una schermata nera.

-Scheda wireless - intel® PRO/Wireless 3945ABG: è rilevata, si accende, rilevo la rete wireless (non protetta) appena cerco di collegarmi và in kernel panic ed al prossimo riavvio non funziona più l'audio. (ho trovato dei driver sperimentali, prima o poi proverò :) )

-Ibernazione in Seven: OK RISOLTO
mettendo il flag boot sulla parizione windows e istallando easybcd per inserire la voce mac nel bootloader windows che andremo ad usare, maggiori dettagli a fondo pagina

-Avvio come posso capire se avviene abbastanza velocemente?quanti secondi dovrebbe metterci un sistema configurato per bene?come agire eventualmente per velocizzarlo?

#2
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Per lo spegnimento hai provato EvOreboot.kext?

#3
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy

Per lo spegnimento hai provato EvOreboot.kext?


grazie per l'interessamento ;)

no, ancora non ho provato, dato che ho finito stanotte alle 2.30 :)

ma lo farò sicuramente.(altrove hanno consigliato anche 'Install_HDA_Fix_v3')

A tal proposito, dato che se combino casini, difficilmente riesco a riportare la normalità (essendo poco esperto nel campo), volevo farmi un backup dell'attuale situazione per poter ripristinare in caso di guai (vedi tentetivi col wireless :) ).

Ho provato con acronis che ho istallato su Se7en, ma mi dice che la partizione mac è danneggiata :rolleyes:

volevo provare time machine o il backup del disco (che stà in utility disco):

posso fare così senza problemi?: ho un hard disk da 1 tera, gli faccio una partizione htfs+ con gparted e poi posso usarlo senza problemi con time machine giusto?funzionerà correttamente il ripristino?

o mi consgli l'altra utility?

grazie ancora

#4
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Se installi MacDrive da Win puoi accedere alla partizione Mac e cancellare i vari kexts installati se ti danno problemi.

#5
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy
si, questo lo sò, lo stò già usando;9 è utilissimo :)

il fatto è che se non dipende da un kext?

con il wireless appena ho provato la connessione (come dicevo sopra), kernel panic ed al riavvio niente audio :(: non ho risolto nè rimettendo il kext appleHDA, nè ripristinando il backup dei kext fatto con osx86tools :(

in quel caso mi potrebbe salvare solo un backup:(

#6
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Certo.
Io ad esempio uso Time Machine, ma c'è anche CarbonCopyCloner che è ottimo.
Tieni presente che una volta che ripristini da un backup di TM devi poi reinstallare Chameleon perché non viene ripristinato.

#7
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy

Certo.
Io ad esempio uso Time Machine, ma c'è anche CarbonCopyCloner che è ottimo.
Tieni presente che una volta che ripristini da un backup di TM devi poi reinstallare Chameleon perché non viene ripristinato.



grazie, proverò sicuramente CCC,



-webcam integrata: col software in bundle per fare le foto 'pazze' (non ricordo l nome al momento) viene rilevata, si accende il led vicino, ma mostra una schermata nera.

-luminosità schermo: quando collegato alla corrente elettrica, è alta e funziona la regolazione da tastiera tasto fn+f7 o fn+f8 (mi sembra che siano quelli i tasti... non ricordo precisamente;)). invece se sono solo con la batteria la luminosità è molto bassa, e se tento di modificarla con le suddette combinazioni di tasti, si freeza tutto e deve spegnere forzatamente :(

#8
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy
Salve ragazzi, le cose cominciano a funzionare come dovrebbero :D :D

aggiornato il primo post con la situazione iniziale ed i problemi che mi rimangono :censored2:

intanto ho risolto con la scheda video :D:D

NVIDIA GeForce 8400M GS (128 MB) on HP pavilion DV6560el - Q/E and CI attivati!

(attenzione, consiglio a tutti di provare il classico 'graphic enabler' di chameleon prima di questo metodo più macchinoso, dato che in successive istallazioni ci sono stati dei problemi. Ora posso confermare che inserendo SOLO la stringa graphic enable tramite 'lizard' la scheda funziona perfettamente SENZA MODIFICARE ALCUN KEXT;))

comincio col dire che le ho provate tutte: NVinject, NVenabler, diecimila versioni e combinazioni degli stessi...; il 'graphicsenable' con chamaleon ecc, ecc. nulla, la scheda veniva riconosciuta (in sistem profile) ma non funzionava l'accelerazione hardware grafica e dunque niente FrontRow, barra superiore trasparente ecc...
Ma essendo uno smanettone (comunque novizio di osx - osx86) ho cominciato a smanettare negli info.plist dei kext :D

Come ho fatto? semplice:

1 cancellate i kext che avete istallato (NVinject, NVenable), cancellate l'eventuale stringa graphicsenable di chameleon insomma, tutto.
Nella cartella \System\Library\Extensionsn devono esserci solo i seguenti kext (la schermata è presa con windows perciò vedete le cartelle invece che l'icona del kext)

Posted Image

(dovrebbero essere quelli istallati di default da Snow Leopard by Hazard)

2 poi bisogna inserire l'ID della nostra scheda audio all'interno degli info.plist dei kext NVDANV40HAl e NVDAResman:

se fate da MAC: copiate il kext sulla scrivania, poi fate 'mostra contenuto pacchetto' cercate il plist ed editatelo con il plist editor (basta cliccare sul file e si apre il programmino); inserite il vostro ID nella chiave IOPCIPrimaryMatch (non potete sbagliare, ci sono una sfilza di ID in questa chiave, sostituite il primo di essi con il vostro)

se agite da Windows:
stessa identica cosa, solo che invece del plist editor potete farlo con un semplice blocco note :angel:
es:

Posted Image
il valore evidenziato è quello che ho inserito io.(anzi no, ho sbagliato ad evidenziare :D:D il valore inserito da me è quello subito dopo '042710de' )

il plist editor sul MAC invece:
Posted Image

inserite il suddetto ID in tutti e 2 i kexts e salvate.

dopo la modifica rimettete i kexts nella loro cartella (con windows basta trascinarli, con MAc meglio se usate kext helper), riparate i permessi e riavviate

al riavvio dovreste avere la barra trasparente, provate a lanciare frontrow ;)

il mio sistem profiler:

GeForce 8400M GS:

Modello Chipset: GeForce 8400M GS
Tipo: GPU
Bus: PCIe
Slot: Slot-1
Larghezza Lane PCIe: x16
VRAM (totale): 128 MB
Fornitore: NVIDIA (0x10de)
ID dispositivo: 0x0427
ID revisione: 0x00a1
Revisione ROM: xx.xx.xx - internal
Monitor:
Monitor:
Risoluzione: 1280 x 800
Profondità pixel: Colore 32 bit (ARGB8888)
Monitor principale: Sì
Mirror: Spento
Online: Sì
Integrato: Sì
Mostra connettore:
Stato: Nessun monitor collegato

l'ID della vostra scheda è formato dai due valori evidenziati;)
(qualcuno sà spiegarmi il significato di Revisione ROM: xx.xx.xx - internal :)?!)

un bech delle prestazioni video attuali fatto con xBench:

Results 122.59
System Info
Xbench Version 1.3
System Version 10.6.2 (10C540)
Physical RAM 3072 MB
Model Sokun Mac Pro 3,1
Drive Type WDC WD1600BEVS-60RST0
Quartz Graphics Test 182.89
Line 145.68 9.70 Klines/sec [50% alpha]
Rectangle 177.72 53.06 Krects/sec [50% alpha]
Circle 147.48 12.02 Kcircles/sec [50% alpha]
Bezier 174.16 4.39 Kbeziers/sec [50% alpha]
Text 430.08 26.90 Kchars/sec
OpenGL Graphics Test 72.66
Spinning Squares 72.66 92.18 frames/sec
User Interface Test 190.77
Elements 190.77 875.54 refresh/sec

(qualche guru può confermarmi che questi valori sono buoni?)

il metodo della modifica del plist, l'ho appreso qui:
http://www.insanelym...howtopic=221316
http://www.insanelym...p...11893&st=20

dove è spiegato anche meglio :)


edit:
mrmojorisin17 grazie per aver ripulito il 3ad;)

Edited by sweetpiggy, 16 September 2010 - 09:46 AM.
Fatto! ;)


#9
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy
aggiornamenti:

Fixato il problema dello spegnimento!!!!
grazie a questo dsdt postato da 'kalevra' (grazie;)):
http://www.insanelym...p...p=1322129
ho semplicemente messo il file in \extra ora lo spegnimento avviene in max 5 secondi :thumbsup_anim::D


Trovati altri kext per l'audio: invece del voodoohda che usavo (senza autosensing e con problemi in entrata/mic ) ho provato questi(HDAenabler + AppleHDA):
http://www.insanelym...p...=190650&hl=
(nel primo post 'audio in out....') che sembrano funzionare in tutto, tranne che ogni tanto (e quasi sempre, prima di un 'suono di sistema' si sente un 'tump' davvero fastidioso, tipo quando inserisci unjack audio di una cassa). per ora li tengo in attesa di meglio (a proposito, secondo voi quale potrebbe essere la causa, lk'AppleHDA o l'enabler?)

#10
ciripiri

ciripiri

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Salve a tutti,
copiate la cartella 'extra' del primo zip nella root del mac, sovrascrivendo quella già presente; mentre nell'altro zip troverete una sottocartella 'system extension', copiate i kexkt che sono dentro in root\system\extension



ciao sweetpiggy, innanzi tutto grazie per la preziosissima guida. Vole chiederti, come faccioa copiare la cartella extra da windows al leopard? Ho provato con una chiavetta usb ma leopard non me la riconosce, ho provato a masterizzarlo su cd, lo legge ma non mi da alcun contenuto :(

potresti gentilmente dirmi qualche espediente pe riuscire a far riconoscere la mia penna usb al leopard, o un modo alternativo per copiare quei file da winzozz al leopard? Grazie 1000!

#11
David23

David23

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,921 posts
  • Gender:Male
  • Location:Como

ciao sweetpiggy, innanzi tutto grazie per la preziosissima guida. Vole chiederti, come faccioa copiare la cartella extra da windows al leopard? Ho provato con una chiavetta usb ma leopard non me la riconosce, ho provato a masterizzarlo su cd, lo legge ma non mi da alcun contenuto :(

potresti gentilmente dirmi qualche espediente pe riuscire a far riconoscere la mia penna usb al leopard, o un modo alternativo per copiare quei file da winzozz al leopard? Grazie 1000!

se la chiavetta è ntfs usa ntfs mounter

#12
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy

se la chiavetta è ntfs usa ntfs mounter


esatto :)
anche se: se la chiavetta è formattata in ntfs, dal mac dovresti comunque leggerci e copiare il file (invece il programma consigliatoti dovrebbe servire per scrivere su ntfs :D)

in alternativa, su windows istalla 'mac drive' e poi agisci da windows sulla partizione mac e sovrascrivi la cartella :D


ciao,
buone ferie a tutti :)


ciripiri, ti ricordo che è obbligatorio mettere le specifiche hardware del tuo pc in firma, altrimenti non potremmo neanche risponderti;)

#13
cirinohack

cirinohack

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
ciao ho un dv6599el con una configurazione hw quasi identica alla tua. ho messo il kernel panic nella sezione new users QUI

Potresti darmi una mano?

#14
ciripiri

ciripiri

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

in alternativa, su windows istalla 'mac drive' e poi agisci da windows sulla partizione mac e sovrascrivi la cartella :D


grazie 1000 ho risolto proprio con mac drive!!! :D

ora, l'ultimo problema è come attivare lo scrolling sul track pad! :)


ciao,
buone ferie a tutti :D


ciao, grazie e buone ferie anche a te! :P

ciripiri, ti ricordo che è obbligatorio mettere le specifiche hardware del tuo pc in firma, altrimenti non potremmo neanche risponderti;)


risolto, grazie!

#15
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy
ibernazione Seven:
risolto! ;)
istallando easyBCD su windows ed aggiungendo al bootloader di windows una nuova entrata 'mac' (MBR)
poi spostando il flag 'boot' (con gparted live) sulla partizione windows.
all'avvio si sceglie windows o snow leopard (nel qual caso poi riparte il bootloader chameleon ;))

#16
ciripiri

ciripiri

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
sei un grande, io purtroppo non riesco ancora ad abilitare scheda grafica, microfono e trackpad :)

#17
David23

David23

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,921 posts
  • Gender:Male
  • Location:Como

sei un grande, io purtroppo non riesco ancora ad abilitare scheda grafica, microfono e trackpad :(


per il microfono hai provato a modificare voodoohda?
per il trackpad se con i kext voodootrackpad non va non credo che ci siano altre soluzioni.

#18
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy

sei un grande, io purtroppo non riesco ancora ad abilitare scheda grafica, microfono e trackpad :(

non preoccuparti, oggi ti sistemo io :D
-per la scheda grafica: prima di provare la modifica che ho proposto io, abilita con 'lizard' il graphic enable di chameleon (oppure a mano modificando il plist del boot che hai in system/extra (con il programmino lizard ci vuole un secondo ;)) in questo caso però devi cancellare eventuali NVinject, NVenabler dalla cartella extension

-trackpad con i voodoo funziona benissimo, anche lo scrolling a 2 dita ;) probabilmente è qualche conflitto con altri kext (appleps2, ecc....); oggi ti posto tutti i kext di cui hai bisogno.

-il microfono e tutto l'audio funziona con un appleHDA modificato ed HDAenabler, lascia stare i voodooHDA che funzionano solo per sentire l'audio dalle casse integrate, e basta. oggi ti passo anche questi kext.

(anche se solo ora noto che non hai il mio stesso Pc.... passo comunque i vari kext, non si sa mai funzionino;))

per il microfono hai provato a modificare voodoohda?
per il trackpad se con i kext voodootrackpad non va non credo che ci siano altre soluzioni.


come detto: voodooHDA funziona solo al 10%, per il trackpad i voodoo sono ok, ma vi posto io la versione precisa;)


ATTENZIONE(SE AVETE IL DUAL BOOT):
NON PROVATE AD ABILITARE IL SUPPORTO NATIVO DI SNOW LEOPARD PER LA SCRITTURA SU
NTFS
:
mi ha causato la non-avviabiità di Seven; poi reistallando seven non partiva di nuovo Snow Leopard... insomma un altra mezza giornata di smanettamenti.
Usate invece l'ottimo 'paragon NTFS for MAc? (purtroppo non-free)

un altra segnalazione:
con la mia configurazione attuale, quando ho un HD esterno collegato, facendo 'spegni' da Snow Leopard, il Pc si riavvia invece di spegnersi; il problema scompare se spegni senza hd esterni collegati;)



Ecco 2 pacchetti:
AUDIO:
dovrebbero essere gli stessi che ho linkato nel primo post, comunque funzionano abbastanza bene, tranne che per il 'tump' che si sente ogni tanto. funziona comunque tutto, autosensing all'inserimento cuffie, microfono, regolazione volume con tasti a sfioramento e mute ;) (prima di istallarli cancellate eventuali voodooHDA)

LINK:
AUDIO



TRACKPAD
funzionanti in tutto; tap, scrolling laterale, scrolling a 2 dita. Istallate i 3 kext avendo cura di eliminare eventuali applePS2 precedentemente. gli unici kext contenenti la parola PS2 devono essere questi che vi passo.
se non si abilita di default il pannello delle impostazioni 'Trackpad' (quello di default, non parlo di quello 'voodoo'), trovate il relativo file nel mio pacchetto, sostituite l'originale (di cui vi farete un backup prima) in system/library/preferencepanes.

TRACKPAD

#19
ciripiri

ciripiri

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
prima di tutto, caro sweet piggy, grazie veramente per la tua impareggiabile gentilezza :D

dovessi passare dalle mie parti hai come minimo una colazione offerta :)


allora, il trackpad funziona magnificamente! :D La cosa divertente e' che funziona meglio sul Leopard che su Win 7 per il quale, essendo un PC, dovrebbe essere appositamente disegnato.... davvero pazzesco :P


l'audio purtroppo non c'e' :), ho fatto esattamente quello che hai scritto, ma quando riavvio non riesco piu a sentire nulla e la barra per regolare l'audio sulla barra dei menu appare spenta e quando ci clicco sopra e' praticamente in mute.

avro' sbagliato qualcosa? Sta sera riprovo e vi faccio sapere...



grazie ancora! :P

#20
sweetpiggy

sweetpiggy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:Caserta - Italy

grazie ancora! ;)


di nulla :)
perfetto per il pad :), la scheda audio è diversa dalla mia, perciò i kexkt che ti ho passato potrebbero non funzionare adeguatamente :(
ciao





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy