Jump to content

ASUS P5W DH Deluxe

- - - - -

  • Please log in to reply
223 replies to this topic

#161
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 586 posts
  • Location:Paris
Salut

pour le wifi cela ne marche qu'en 32 bit , verifie dans A propos de ce mac, menu pomme, Logiciels ; "Noyau et extensions 64 bits : Non"
et pour ce faire il faut impérativement l'option arch=i386 dans smbios.plist
avec certains claviers usb l'écran reste noir au réveil mais pas de problème avec Apple Alu Keyboard

bonne chance "John" ?

#162
coltrane35

coltrane35

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
:wallbash: :wallbash: :wallbash: :wallbash:

Merci Aliab pour tous tes conseils, malheureusement la situation a évoluée et pas en bien ....
Je reviens un instant sur mon dernier post :
- j'ai réussi à faire fonctionner le wi-fi avec les drivers realtek: il suffisait de persévérer et ça a fini par fonctionner (comment, je sais pas trop)
-concernant le message d'erreur pour le disque dur, il m'a suffit de le repartionner en une seule partition et le problème fut résolu. En glanant des infos, il apparait que ce problème arrive avec des DD de grosse capacité et lorsqu'une partition frise le TO (ex pour un DD de 2To avec une partition avoisinant le TO ça va planter alors que si elle dispose de 4 partitions de 500 Go ça marche) ...

Mais bon, de SL 10.6.4, je reviens à LEO 10.5.6 (fausse manip, obligé de tout réinstaller) Et là, j'en ai :) un max.
Impossible de booter sur la partition hébergeant l'image de SNOW.
Je me suis rendu compte (plusieurs jours plus tard) que mon fichier com.Apple.Boot.Plist n'était pas correctement édité:
il manquait : arch=i386 ainsi que DropSSDT (ceci expliquait sans doute les messages d'erreur mach_kernel et -pciRoot ...

Le fichier corrigé, je parviens à présent à booter sur la partition hébergeant l'image de SL MAIS ça bloque à la ligne suivante :
yukon: Ethernet address 00:17:31:e8:BB:9E et là je ne comprend pô !
juste avant ça, j'ai également :
Sound assertion "0 !=createAudioEngines (fPathmap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver .cpp" at line 172 goto Exit
Là je ne comprend pas ce que cela vient faire là vu que je n'ai pas ajouté le kext HDA dans le dossier Extra.

Bref, je sèche et reste désespérement sur le bord de la route .... :help:

Actuellement, le dossier EXTRA comprend les fichiers suivants :
- com.apple.boot.plist (normalement édité comme il faut)
-dsdt.aml
-Extension.mkext
PAS de smbios.plis car désormais inutile si j'ai bien compris

j'ai remplacé le fichier boot par PC EFI V 10.6 récupéré sur le blog de netkas mais cela ne change rien ...

Désolé, je pensais que mon prochain message serait pour vous annoncer la bonne nouvelle ... mais on va légèrement reporter ça ... :D


P.S : au début du post, il est dit de restaurer l'image de SL sur une partition PUIS d'installer chameleon? Or, je n'ai jamais pu procéder dans ce sens.
D'abord install de chaméléon puis restauration de l'image sinon l'installeur de chameleon freeze. Normal ??

Bon, je retourne écumer le net en quête de réponses.
Merci pour votre aide et désolé si je suis passé à côté de la solution sans m'en apercevoir( :tomato: ), mais là je commence à fatiguer ... :stretcher:

EDIT : lorsque je lance en safe mode + verbose, le message
Sound assertion "0 !=createAudioEngines (fPathmap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver .cpp" at line 172 goto Exit
disparait par contre ça bloque toujours sur :
yukon: Ethernet address 00:17:31:e8:BB:9E

Help please ! J'ai horreur que mon ordi me nargue plusieurs jours de suite ! :jester:

#163
coltrane35

coltrane35

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
:) Bon, j'ai désactivé les 2 ports ethernet dans le bios, je ne suis plus bloqué sur Yukon. ...
Par contre
Sound assertion "0 !=createAudioEngines (fPathmap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver .cpp" at line 172 goto Exit
est toujours là. ...
Et en tapant ce message d'erreur sur Google, je tombe sur sur des posts évoquant ce problème APRES installation de SnowLeopard ... et non pas pendant (en fait je n'arrive même pas à lancer l'install...)

A vot' bon coeur messieurs, dames !

#164
coltrane35

coltrane35

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
:( :trumpet: ayé ! l'install est en cours.
Si je n'avais eu autant de :censored2: dans les yeux, je me serais rendu compte que mon fichier com comportait des erreurs de frappes !!!!! :tomato:
Je croise les doigts pour gérer une install stable de la 10.6.4 en espérant pouvoir gérer tout seul comme un grand !
:smoke:



:yoji:
Et bé voila, j'ai perdu un temps impressionnant tout ça à cause de ma négligence ! Si j'avais mieux regardé mes fichiers, ça aurait marché tout de suite.
Voila le déroulement de l'install (pour mon cas):

1 - A partir de Léopard (situé sur HD1) Partitionnement de mon HD2 en 2 partitions avec l'utilitaire de disque:
SNOWLEOPARD = 100Go et BOOTSL = 400 Go
2- Installation de Chameleon RC5-r568 (installation standard, toutes les autres options sont décochées) sur BOOTSL et SNOWLEOPARD (je l'ai également installé sur la partition hébergeant LEOPARD, mais je ne crois pas que cela soit nécessaire ...).
3- Ensuite restauration de l'image de MAC OS X INSTALL DVD vers BOOTSL (si l'image est restaurée d'abord, je ne parviens pas à installer chameleon)
4- Création d'un dossier intitulé EXTRA sur les partitions BOOTSL et SNOWLEOPARD
5- Ajouter dans les deux :
fichier dsdt.aml + fichier com.appleboot.plist + smbios.plist + Extension.mkext
Voici le contenu de smbios.plist
[codebox]<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>20/08/2008</string>
<key>SMbiosversion</key>
<string>MP31.88Z.00C1.B00.0802091544</string>
<key>SMcputype</key>
<string>1281</string>
<key>SMexternalclock</key>
<string>1,33</string>
<key>SMfamily</key>
<string>iMac</string>
<key>SMmanufacter</key>
<string>Apple Inc.</string>
<key>SMmaximalclock</key>
<string>2,50</string>
<key>SMmemmanufacter_1</key>
<string>Team Elite</string>
<key>SMmemmanufacter_2</key>
<string>Team Elite</string>
<key>SMmempart_1</key>
<string>50M3P4R7</string>
<key>SMmempart_2</key>
<string>50M3P4R7</string>
<key>SMmemserial_1</key>
<string>50M353R14L</string>
<key>SMmemserial_2</key>
<string>50M353R14L</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMserial</key>
<string>...</string>
<key>SMsystemversion</key>
<string>1.0</string>
</dict>
</plist>
[/codebox]

et le contenu de com.appleBoot.plist
[codebox]<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=i386</string>
<key>DropSSDT</key>
<string>No</string>
<key>Timeout</key>
<string>5</string>

</dict>
</plist>[/codebox]

6- Redémarrage et sélection de BOOTSL. L'installateur se lance, je choisis la Partition cible SNOWLEOPARD.
7- Une fois l'install achevée, reboot, puis sélection de la partition SNOWLEOPARD. Une fois arrivé sur le bureau, je lance directement la mise à jour avec le comboupdate 10.6.4.

Une fois relancé, on se retrouve en 10.6.4 et il reste à installer le voodooHDA et le drivers realtek pour le wifi et voilà !

Il ne me reste plus qu'à tester tout ça en espérant que l'install soit vraiment stable.

En tout cas merci à vous tous, car même si je ne capte pas tout en ce qui concerne la manipulation de kext, le "compilage" et tutti quanti, j'ai l'impression d'avoir un peu progressé. Cependant, "longue est la route vers la connaissance petit scarabée" ! :) :( :wallbash: :help: :hammer: -_- :pope: :angel: :yoji:

#165
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 586 posts
  • Location:Paris
Mise a jour en 10.6.5 update combo sans problème
il faut reinstaller
AppleHDA.kext avec le script sur le premier post (mis a jour pour 10.6.5)

#166
cyp75

cyp75

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Mise a jour en 10.6.5 update combo sans problème
il faut reinstaller
AppleHDA.kext avec le script sur le premier post (mis a jour pour 10.6.5)


Merci beaucoup Aliab, une fois de plus tout fonctionne à merveille !

#167
metalmaniac

metalmaniac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
Tu a utliliser quel installer de chameleon. Sur la lien il y a plein des options, et quand jai utiliser le pkg, il nya pas de /Extra.

Sil te plait, est ce que quelqun peut mettre le contenu de /extra ici. Jarrive pas a voir ou je trouve toutes les kexts

merci

ash

#168
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 586 posts
  • Location:Paris
Attached File  Capture_d_____cran_2010_12_05____09.19.42.png   177.64KB   78 downloads

celle-ci installe le dossier "Extra" configure com.apple.Boot.plist
il ne reste qu'a mettre Extensions.mkext a l'interieur

#169
metalmaniac

metalmaniac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
merci, jai mal compris

a toute

#170
wonderjacky

wonderjacky

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Bonjour à tous,

J'ai un E6420 et si je comprends bien la dernière version de Chameleon génère les P-States et les C-States à la volée et je n'ai pas besoin de toucher au fichier dsdt.aml pour faire fonctionner les SpeedStep. Est-ce que c'est exact?

Ma carte graphique est une 9800 GTX. Est-ce qu'elle est aussi prise en charge par la dernière version de Chameleon?

Merci d'avance pour votre aide,

François

#171
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 586 posts
  • Location:Paris

Bonjour à tous,

J'ai un E6420 et si je comprends bien la dernière version de Chameleon génère les P-States et les C-States à la volée et je n'ai pas besoin de toucher au fichier dsdt.aml pour faire fonctionner les SpeedStep. Est-ce que c'est exact?

Ma carte graphique est une 9800 GTX. Est-ce qu'elle est aussi prise en charge par la dernière version de Chameleon?

Merci d'avance pour votre aide,

François


Exactement

pour la carte graphique je pense que oui mais je n'ai pas verifié ?

#172
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 586 posts
  • Location:Paris
Mise a jour en 10.6.6

update sans probleme sauf le son qu'il faut reinstaller (voir le debut du topic pour les nouveaux fichiers)
AppleHDA a été patché avec HexEdit selon cette procedure

Attached File  Capture_d_____cran_2011_01_07____09.23.14.png   33.55KB   29 downloads

on peut également patcher AppleHDA avec le terminal directement après la mise a jour en 10.6.6

sudo perl -pi -e 's|\x85\x08\xec\x10|\x82\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

et ALC882v32.kext a été rajouté dans Extra/Extentions

la sortie numérique devrait fonctionner mais je n'ai pas testé ?

une autre solution est d'installer VoodooHDA.kext avec Kext Utility sans modifier AppleHDA ni rajouter ALC882v32.kext

celui-ci Attached File  VoodooHDA.kext.zip   157.58KB   20 downloads

#173
Dphil

Dphil

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Mise a jour en 10.6.6

update sans probleme sauf le son qu'il faut reinstaller (voir le debut du topic pour les nouveaux fichiers)
AppleHDA a été patché avec HexEdit selon cette procedure

Attached File  Capture_d_____cran_2011_01_07____09.23.14.png   33.55KB   29 downloads

on peut également patcher AppleHDA avec le terminal directement après la mise a jour en 10.6.6

sudo perl -pi -e 's|\x85\x08\xec\x10|\x82\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

et ALC882v32.kext a été rajouté dans Extra/Extentions

la sortie numérique devrait fonctionner mais je n'ai pas testé ?

une autre solution est d'installer VoodooHDA.kext avec Kext Utility sans modifier AppleHDA ni rajouter ALC882v32.kext

celui-ci Attached File  VoodooHDA.kext.zip   157.58KB   20 downloads


Pareil pour moi, sauf que c'est bizarre j'ai pas eu à réinstaller le kext AppleHDA contrairement aux autres MAJ.

Attached File  Capture_d_____cran.png   62.15KB   17 downloads


J'ai une petite question. Je suis en téléchargement auto des MAJ, donc quand une MAJ est prête à être installée j'ai un message et en principe elle est quelque part. J'ai essayé de trouver où étaient stockées ces MAJ avant de faire la MAJ en regardant la dâte des dossiers. J'ai pas trouvé. J'utilise invisibliX, donc pas de dossiers et fichiers cachés à priori. Si quelqu'un peut éclairer ma lanterne.

Merci.

#174
topomac2

topomac2

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Salut,

je sui toujours en 10.6.2 depuis un bout de temps.
Je viens de m'acheter une nouvelle CG et il faut que je passe au mini en 10.6.5 pour qu'elle soit utiliable.

En téléchargement les MAJ comb0 6.5 et 6.6, l'installation échoue...

Vous auriez une idée par hasard?

#175
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts

Salut,

je sui toujours en 10.6.2 depuis un bout de temps.
Je viens de m'acheter une nouvelle CG et il faut que je passe au mini en 10.6.5 pour qu'elle soit utiliable.

En téléchargement les MAJ comb0 6.5 et 6.6, l'installation échoue...

Vous auriez une idée par hasard?

Si c'est la version combo, tu peux faire uniquement la 6.6 car elle contient les versions précédentes.

Tu fais l'install de la combo, et avant le reboot tu fais l'install des derniers kexts (à récupérer sur la première page du post) qui sont nécessaires au reboot en 6.6, et seulement après tu reboot.

Bon courage

#176
topomac2

topomac2

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Merci HArrycau,

comment "si c'est la version combo"?
A mon install de Snow leo, je pense avoir utilisé la MAJ d'apple pour passer en 10.6.2 ( mais pas sur a 100% ca date un peu...)

En tout cas lorsque je tente la MAj combo 10.6.6, j'ai un message d'erreur quasi immédiat apres le lancement.
Bref c'est ..... embêtant! :(

Je tentes un MAJ par les maj d'apple? (j'ai qq mauvais souvenirs sous Léo...)

#177
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
La différence entre une combo et une maj "simple" est que la combo contient toutes les maj (ce n'est pas la peine de faire les maj intermédiaires). Donc si c'est une combo 10.6.6 ce n'est pas la peine de faire la 6.5 avant car la 6.6 suffit.

C'est qui le message d'erreur que tu as ?

#178
topomac2

topomac2

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
LE message d'erreur: " l'installation a échoué"..... tout simplement!

Bon je vais peut etre tenté l'install par les Maj auto du System.

#179
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
Quelques questions: Ton user est bien admin de la machine ? Le disque dur n'est pas full ?

Tu as tenté une réparation des autorisations avant de lancer l'install

Sinon la maj automatique est normalement la même que ta combo, et je suppose que ça fera pareil.... Par contre si l'install se fait ne laisse pas rebooter avant d'installer le dernier package de kext, sinon ça risque de ne pas booter...

#180
topomac2

topomac2

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Bien vu..... :thumbsup_anim: :blink:

Pour l'admin c'était ok. Pour le full.... il ne me restait que 2GO de libre.... Install in progress... :D :P
Y a des fois on se demande on va notre tete.
J'espere que ca va rouler pour la suite
Merci beaucoup

Ca y est. Je suis en 10.6.6.
Reste a retrouver le son, AppleHDA me fait des caprices.

Encore merci.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy