Jump to content

ASUS P5W DH Deluxe

- - - - -

  • Please log in to reply
223 replies to this topic

#21
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
Pas testé la sortie numérique... je sort en analogique pour branchement sur mon écran.
L'extinction marche bien par contre.

Une question qui n'a rien à voir.... Il sont branchés où vos graveurs ? et vous arrivez à booter dessus ?
Je m'explique, dans le bios c'est le 4ème IDE pour moi et il met du temps à apparaître quand je regarde le bios. Ce qui fait que je n'arrive pas à booter dessus (sur une image faite avec BootCDMaker). Il n'apparait pas dans la liste quand je fais F8.....

Autre pb, mais moins gênant et plus ancien que le passage en 10.6, si après gravure je laisse le CD ou DVD dans le lecteur, il devient inaccessible jusqu'à un reboot. Je suppose que c'est un peu lié....

C'est un lecteur SATA Pioneer (216 il me semble)

#22
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
mon lecteur DVD est sur le JMicron (mode AHCI), ça marche

@ WonderJacky : as tu un Apple Keyboard ? certains clavier usb induisent ce problème d'extinction sur Leopard aussi

#23
gizmos41

gizmos41

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Bon alors moi, je viens de remarquer un autre problème, c'est un de mes disque dur qui n'est pas détecté... Par contre, il se trouve sur une carte PCI avec chipset VIA (le 6421 je crois) . Une idée de comment le faire fonctionner, AppleVIA.kext ? Mais fonctionnera-t-il sous SL ? Il fallait mettre l'ID du matos nan pour que ça fonctionne ?

#24
wonderjacky

wonderjacky

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Personne n'a de solution pour le digital output de la carte son?
Aliab, Sais-tu si les solutions à base de AppleHDA peuvent fonctionner sous SL?
J'ai installé AppleHDA.kext et HDAEnable.kext mais pas de carte son disponible...

Merci d'avance,

François

#25
wonderjacky

wonderjacky

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

J'ai pas essayé la sortie spdif

La solution HDAEnabler.kext en patchant AppleHDA.kext ne fonctionne pas du tout comme tu as pu le constater
il faut passer par l'édition des ""info.plist" des LegacyHDA et sans doute modifier aussi le fichier DSDT
c'est une manip que j'ai déjà faite pour le Sigmatel 9227 sur une carte intel, il faut éplucher toutes les strattes du registre avec IORegistryExplorer et relever les informations au bon endroit, c'est laborieux mais ça devrait fonctionner

en tous cas rien d'impossible mais simplement cela représente un certain travail et je sais pas si j'aurais le temps de me lancer

Piste ;

rassembler les codec_dumps linux
patcher les info.plist de ces trois kext :
/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAController.kext
/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHardwareConfigDriver.kext
/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAPlatformDriver.kext

visiblement cela a été fait pour l'ACL883 pour info /

Salut Aliab,

Merci encore pour ton aide.
Sais-tu où je pourrais trouver des infos là-dessus? Ou un tutoriel? Car je galère un peu à démarrer.

Merci,

Wonderjacky

#26
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris

Salut Aliab,

Merci encore pour ton aide.
Sais-tu où je pourrais trouver des infos là-dessus? Ou un tutoriel? Car je galère un peu à démarrer.

Merci,

Wonderjacky


j'ai trouvé des pistes intéressantes
1
http://www.projectos...?...
http://ipwn.me/HDA/

on pourra peut être y travailler
bon courage

#27
RedF

RedF

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Salut a tous!

Juste un petit post pour vous faire part de mon expérience qui touche presque a la réussite!

Mon matos :
Asus P5WDH Deluxe
C2D e6400
3Go PC 6400 Corsair
1 Sapphire HD4890 1Go
1 SSD Super talent 32Go
1 DD Sata 500Go

Voilou apres des jours d'arrachage de cheveux je suis enfin arrivé a installer puis booter sur SL en 32 et 64 Bits.
Ma methode d'install :
Une 10,5,7 iPC (avec update 10,5,8)
Un dvd SL acheter a la fnouc
Chameleon RC3
Un dsdt "maison" et le mkext du premier post

L'install nickel la CG reconnue et fonctionnelle mais j'ai encore quelques petits soucis et je viens vous demander un peu d'aide apres toute celle que vous m'avez fourni en postant ici entre autre.

J'ai deux soucis:
- Ma souris "lag" a intervals réguliers (je m'explique: Elle se stop pendant 1 a 2 scd toutes les 30 secondes. C'est excessivement chiant et enervant. J'utilise un ensemble clavier/souris logitech sans fil. Et le soucis est le meme avec d'autres ensemble, en usb comme en PS/2)

-Ma carte graphique fonctionne mais juste sur le connecteur DVI et je sais qu'elle peut fonctionner a 100% mais impossible de trouver... j'ai tester des tonnes de choses et ce qui est encore plus etrange c'est que le probleme de clavier n'apparait que quand j'installe le patch de netkas (QE_CI_Exotic_cards_10.6.1.pkg) ...

Y'a un conflit ou un soucis quelque part mais impossible de savoir ou ...

Si vous pouvez m'éclairer un peu ca serait le bienvenue ...

Merci a vous.

Edit : plus trange encore j'ai un kernel panique si je boot avec -v -x
Nerf pas envie de rinstaller tout ...

#28
wonderjacky

wonderjacky

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Bonjour,

J'ai trouvé un driver son qui permet d'utiliser la sortie optique digital de la P5W.
Je l'ai trouvé dans ce post : DSDT for ALC882 and others
Cette solution est basée sur l'utilisation d'un AppleHDA que l'on peut trouver là http://rapidshare.co...pleHDA.kext.zip
J'ai aussi ajouté le HDAEnabler que l'on peut trouver sur darwinx86.

Wonderjacky

@ WonderJacky : as tu un Apple Keyboard ? certains clavier usb induisent ce problème d'extinction sur Leopard aussi

Hello,

J'ai toujours un problème d'arrêt : il n'y a pas de mise hors tension du système lorsque je choisis shutdown.
J'ai un clavier PS2 et une souris USB.

* Dans mon répertoire /Extra j'ai le DSDT dispo dans ce post

* Dans le répertoire /Extra/Extensions j'ai les kexts suivants :
AHCIPortInjector.kext
fakesmc.kext
IOAHCIBlockStorageInjector.kext
JMicronATA.kext
LegacyMB36xSATA.kext
NullCPUPowerManagement.kext
OpenHaltRestart.kext
PlatformUUID.kext
SleepEnabler.kext

* Dans mon /System/Library/Extensions j'ai installé
AppleHDA.kext
HDAEnabler.kext
VoodooPS2Constroller.kext

* J'ai supprimé le HDAHPET.kext

Cependant toujours pas possible d'arrêter. Le redémarrage, OK mais la la veille.
Si j'ai démarré avec le -v dans chameleon, le dernier message que j'ai, c'est CPU Halted, mais pas de mise hors tension...
Vous avez une idée?

Wonderjacky

#29
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
Cool
voila une bonne piste

marche en 32-bit kernel en ayant oté AppleHPET
sinon marche en 64-bit uniquement en conservant AppleHPET (si l'on peut se passer de l'USB HISpeed, de la veille, .. )

pro : Main Stage se remet a fonctionner

le support de PS2 sur snow ? je n'utilise pas, mais cela a certainement un rapport avec ton problème




@+

#30
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
314TeR nous a pondu le dsdt magique en corrigeant le HPET
voir la mise a jour au début du topic


tout fonctionne désormais sur 32 ou 64-bit Kernel avec une mise en oeuvre simplissime

#31
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
Salut Aliab,

Encore merci pour cette nouvelle release. Quel travail ! c'est génial

J'ai eu pas mal de difficultés à me défaire des strings du Boot.plist. En effet la syntaxe suivante
<key>EthernetBuiltIn</key>
<string>y</string>
<key>GraphicsEnabler</key>
<string>y</string>
ne marche pas chez moi, en tout cas pour la prise en compte de l'injection video.

Il faut que je le mette de la manière suivante dans le boot.plist:
<key>Kernel Flags</key>
<string>-v arch=i386 -pci0 GraphicsEnabler=Yes</string>
Of course on peut enlever le -v
j'ai pas tester sans le -pci0, mais d'après le commentaire de Netkas je pense qu'il faut ce paramètre

Pour l'injection Ethernet, je pense que ce n'est pas la peine de mettre car le DSDT contient le patch pour TM ce qui doit correspondre à la même chose si j'ai tout suivi (à vérifier tout de même)

#32
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris

Salut Aliab,

Encore merci pour cette nouvelle release. Quel travail ! c'est génial

J'ai eu pas mal de difficultés à me défaire des strings du Boot.plist. En effet la syntaxe suivante
<key>EthernetBuiltIn</key>
<string>y</string>
<key>GraphicsEnabler</key>
<string>y</string>
ne marche pas chez moi, en tout cas pour la prise en compte de l'injection video.

Il faut que je le mette de la manière suivante dans le boot.plist:
<key>Kernel Flags</key>
<string>-v arch=i386 -pci0 GraphicsEnabler=Yes</string>
Of course on peut enlever le -v
j'ai pas tester sans le -pci0, mais d'après le commentaire de Netkas je pense qu'il faut ce paramètre

Pour l'injection Ethernet, je pense que ce n'est pas la peine de mettre car le DSDT contient le patch pour TM ce qui doit correspondre à la même chose si j'ai tout suivi (à vérifier tout de même)


J'avoue que je suis perdu dans les options de boot avec ou sans -pci0 ne change rien chez moi ?
j'ai remis ma string video car l'injection graphique <key>GraphicsEnabler</key>/<string>y</string> ne fonctionne pas non plus
par contre je viens de constater avec cette nouvelle install que le reboot ne marche pas sans l'aide du bouton reset (j'ai pas testé en 32 encore, d'après ta boot.plist tu boot en 32)
si je supprime OpenHaltRestart le système ne boot plus ?

pour le TM je confirme le DSDT l'injecte bien

j'ai pas encore essayé la 2504.ROM qui selon 314TeR avec le DSDT apporte le speedstep vanilla ??

conclusion : encore dans les test et pendant ce temps la on fout rien..
mais c'est vrai qu'on ne devrait pas être très loin du but


boot en 64, string video, TM par le DSDT

voici ma plist :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1920x1200x32</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>GUI</key>
<string>Yes</string>
<key>Boot Banner</key>
<string>Yes</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>EthernetBuiltIn</key>
<string>No</string>
<key>USBBusFix</key>
<string>No</string>
<key>EHCIacquire</key>
<string>No</string>
<key>UHCIreset</key>
<string>No</string>
<key>Wake</key>
<string>No</string>
<key>ForceWake</key>
<string>No</string>
<key>device-properties</key>
<string>6c0200000100000001000000600200000d00000002010c00d041030...c506172656e74</string>
</dict>


merci pour les retours d'infos @+

#33
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
T'as raison, j'étais en 32 bits....
En fait, j'avais oublié de remettre le ApplHPET, et du coup ça ne bootait pas en 64 bits

Voici mon boot.plist complet en mode 64 bits

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string></string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>-pci0 GraphicsEnabler=Yes</string>
<key>Timeout</key>
<string>1</string>
<key>Legacy Logo</key>
<string>Yes</string>
</dict>
</plist>

Je n'ai pas fait d'autres tests sur le -pci0.
Je préfère cette solution par rapport au string, maintenant que la syntaxe est bonne, car la carte est mieux reconnue dans les info systèmes.
Autrement, j'ai juste gardé l'option Legacy Logo mais c'est pour la forme uniquement ;-) Tout le reste n'est pas nécessaire tant qu'on veut laisser les options par défaut.

J'ai le même pb que toi sur le reboot..... Et cela depuis que j'ai remis le AppleHPET. Je pense qu'il ne reste que ça traiter.

Par contre si quelqu'un pouvait me donner quelques explications sur le fonctionnement de kext utility 2.3.2 car je n'ai pas compris comment désarchiver un mkext et comment refaire un mkext. Quand je fais glisser un mkext, après avoir entré mon password, j'ai uniquement un sorry, could not unpack.....
Et tant que je n'ai pas ça, je ne peux traiter ma seconde config qui est IDE.....

#34
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
Kext Utility ne marche pas pour unpacker chez moi non plus
voici la commande du terminal

mkextunpack -d

puis tu glisses un dossier dans la fenêtre et le .mkext a unpacker


qu'est ce que tu rajoutes pour ton IDE ?

#35
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
Le restart fonctionne en 32-bit Kernel avec une petite modif
voir le haut du topic

#36
HarryCau

HarryCau

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
Je voulais tester avec la nouvelle version de AppleIntelPIIXATA et avec les divers UUID.

Le tout par BootCDMaker qui me permet sans pb de booter la machine SATA (et de faire l'install à partir du DVD retail), mais pas la machine avec lecteur et disque IDE. ça bloque au tout début sur le disque RAM.....

En tout cas, ça ne marche toujours pas....

#37
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
pour visionner les modifications du fichier dsdt voir le haut du topic

#38
guarino85

guarino85

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
il y à quelqu'un qui est réussi à faire travailler le wi-fi avec snow leopard? je m'excuse pour mon français mais je l'ai étudié à l'école et aujourd'hui j'ai oubliè tout! :blink:

#39
aliab

aliab

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 590 posts
  • Location:Paris
Yes

it's working perfectly in 32-bit Kernel with 87_Mac10.4_v1309
in realtek website (see the link at the top of topic)

Attached File  Capture_d_____cran_2009_10_02____08.51.31.png   105.2KB   65 downloads

#40
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
Speedstep work to SL 64 bit?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy