Jump to content

Logic 7.2 Express and my MIDI controllers...why not work?


  • Please log in to reply
10 replies to this topic

#1
snaper

snaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
I have an SB128PCI II sound card...and its work with the maxxuss ES 137x driver...but no MIDI ...WHY??????

#2
-JD-

-JD-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 141 posts

I have an SB128PCI II sound card...and its work with the maxxuss ES 137x driver...but no MIDI ...WHY??????


What do you mean no MIDI? Do you mean that the MIDI drivers do not show up, or do you mean that there is no data going through them?

Heres a test: go to the window menu and select open environment, then find a blank space and click the NEW button (its in the top left of the environment window). Select "Physical Input" from the menu - a new box should open up in the environment with "SUM" at the top of it and your MIDI driver below. If there is just SUM then the problem is the MIDI interfacing. If a driver is listed, you just havent connected it up to a sequencer input :P

To connect a sequencer input, click the New menu again and click sequencer input. Then simply take a wire from (click and hold the white triangle next to) where it says SUM on your physical input and drag it to the new sequencer input module. Logic will now send all incoming MIDI data to whichever track you select in the arrange window and arm :)

Hope that helps....

-JD-

#3
snaper

snaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
so, my problem:
i have a midikeyboard and a midi drum trigger pad...i plug my keyboard to my soundcard...but logic see it not...no in no out transfer...:D((((

#4
-JD-

-JD-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 141 posts

so, my problem:
i have a midikeyboard and a midi drum trigger pad...i plug my keyboard to my soundcard...but logic see it not...no in no out transfer...:(((((


Have you checked what's happening in your coreaudio settings?

-JD-

#5
snaper

snaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
No...
In Audio/MIDI Settings in System Preferences?

#6
elRey

elRey

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 273 posts
  • Gender:Male
  • Location:Germany
  • Interests:computing<br />producing music<br />range: progressive psytrance
hey JD

his soundcard is a soundblaster pci
and he connect his midi thru that card
i dont think that the soundblaster pci is working

#7
dubhead

dubhead

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
Emagic USB Midi Interfaces are supported on the Hackintosh. They get Installed by Logic 7.2 express or Pro.

:( Good to have a Tiny MT4

#8
snaper

snaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
Posted Image

JD i screenshot my environment...it is that...NO MIDI...:sorcerer:(((

sorry
http://www.users.atw...rebreak/pic.png

#9
-JD-

-JD-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 141 posts

hey JD

his soundcard is a soundblaster pci
and he connect his midi thru that card
i dont think that the soundblaster pci is working


If its a creative soundblaster it may be the card...creative fell out with apple a long time ago so there have been no mac driver releases - im guessin snaper's connecting through the joystick port, and that may be it - as far as i know, osx doesnt support them! As dubhead said, a usb MIDI interface seems to be the way forward here-there are lots of manufacturers of them that support osx so have a shop around...the emagic ones are good though :)

Posted Image

JD i screenshot my environment...it is that...NO MIDI...:pirate2:(((

sorry
http://www.users.atw...rebreak/pic.png


snaper i can't see that pic for some reason...im getting an error message. Can you upload it again? I think we've found the problem though (see above).

-JD-

#10
snaper

snaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
http://www.snaper.uw.hu/pic.png

pr in pm i give you a username and pass

#11
-JD-

-JD-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 141 posts

http://www.snaper.uw.hu/pic.png

pr in pm i give you a username and pass


Hmmm, thats a weird one. When i get back on my hac ill have a look in more detail :)

-JD-





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy