Jump to content

My com.apple.Boot.plist is Read-Only


  • Please log in to reply
6 replies to this topic

#1
TheElementWithin

TheElementWithin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
I tried this to fix it, thought it did, but it didn't.

sudo chmod 777 /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

When looking at the file stuff, it says Read + Write, but then it tells me I STILL can't write to the file.

#2
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Did you boot in Single User mode (-s) ?

#3
TheElementWithin

TheElementWithin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
Nope. :-\

Does this declare me as retarted?
What do I do?

#4
docoma

docoma

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Use
sudo -s nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

Works for me

#5
TheElementWithin

TheElementWithin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
chmod: /bin/chmod: cannot execute binary file


:blink:

#6
TheElementWithin

TheElementWithin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
It did something new when I took out the -s.

Lets see whats happening!

#7
TheElementWithin

TheElementWithin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
This just screwed up my mac install. Not it wont even boot. :(

I used Quiet Boot, and under Kernel Flags I put platform=X86PC





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy