Jump to content

[GUIDA] Dual Boot XP/Leopard


  • Please log in to reply
89 replies to this topic

#1
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
Dato che tutti la cercano ma la guida non c'č mai, mi sono deciso a scrivere 2 parole sul dual boot XP/Leopard con il metodo del chain0
Per prima cosa dovete riuscire ad avviare XP.. se vi si avvia siete a buon punto.. se non vi si avvia dovete impostare la partizione di XP attiva.

Sotto XP, copiare il chain0 (o qui un'altro link) (scompattato) sulla root di windows XP (C: per chi non lo sapesse..)
Aprire il file C:\boot.ini ed aggiungere la seguente stringa

C:\chain0="Mac OS X86"
dove al posto di "Mac OS X86" potete mettere la descrizione del vostro mac (insomma, il titolo che vi affaccia per avviare il mac..)

Il risultato del boot.ini dovrebbe essere il seguente:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\chain0="Mac OS X86"


Spero che questa guida possa essere utile a molti.. ciao!!

#2
ilghan

ilghan

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
xp non mi si avvia, mi avvai solo leo
cosa significa impostare la partizione xp attiva e come si fa?
tnx

#3
ilghan

ilghan

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
ok come non detto
basta premere f8 all'avvio e sceglier la partizione win
problema risolto :mellow:
allla grande!

#4
kreza

kreza

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
ho copiato tale file nella root (che nel mio caso č H) ma non trovo il file boot.ini (nella root non c'č)

mi sapete aiutare?

#5
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
nella root di windows? imposta che ti mostra tutti i files nascosti e di sistema...

#6
kreza

kreza

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
non c'č...
ma č nella cartella windows o direttamente nell'hard disk?

#7
kreza

kreza

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
allora...sono riuscito a cambiare il file...
ma quando spunta il boot e seleziono leopard, mi dice che manca il file "hal.dll"

Che devo fare?

#8
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
direttamente nell'hd.. su c:\

sicuramente hai impostato il boot male.. posta il tuo boot.ini..

#9
kreza

kreza

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

direttamente nell'hd.. su c:\

sicuramente hai impostato il boot male.. posta il tuo boot.ini..


ehm..siccome il boot.ini non me lo fa vedere...ho fatto un file .ini dal blocco note e l'ho sovrascritto..copiando questo testo:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\chain0="Mac OS X86"



#10
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
il chain0 l'hai messo nella root di xp? su che partizione č xp? e leopard? descrivimi precisamente la fase di boot, da quando accendi il pc a quando ti dŕ l'errore..

#11
zio Tom

zio Tom

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Sardinia
Dato che l'unica versione di Leo che sono riuscito ad installare č una Flat Image (dovrei rimetterla) e all'avvio mi dava

un errore del tipo "...Chain0...", credi che utilizzando questo metodo potrei risolvere? :blink:

#12
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
mmm dubito.. non hai il bootloader.. imposta attiva la partizione di leopard, quindi inserisci il dvd di qualunque versione, aspetti il conteggio alla rovescia.. ti si avvia leo dall'hd, quindi scarichi osx86tools by pcwiz (google o forum internazionale) e da la installi il bootloader efi..

ciao!

#13
zio Tom

zio Tom

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Sardinia
Io ho Windows Vista; neppure dal suo Boot Loader riuscirei a gestire la cosa? In ogni caso appena posso

reinstallo la Flat Image e provo il procedimento che mi hai consigliato :D

#14
gaspacho

gaspacho

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ho installato la kaly 10.5.2 in seguito a windows xp e utilizzo il suddetto metodo per il dual boot.
se un domani volessi installare qualche distro linux, come verrebbe gestito il boot?
verrebbe installato grub che mi farebbe scegliere tra linux e windows? e una volta scelto windows, "partirebbe" il suo boot manager che mi farebbe scegliere tra windows e leopard?

#15
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
si.. perň se vuoi puoi aggiungere mac a grub (cerca con google.. ci dovrebbero essere delle guide) e linux al bootloader di xp.. cosě in qualunque bootloader ti trovi puoi sempre "tornare indietro" se hai fatto la scelta sbagliata...
ciao!

#16
cavallo27

cavallo27

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Location:italy
ho aggiunto "C:\chain0="Mac OS X86" al "chain0".
all' avvio seleziono Mac OS X86 e mi dice HAL.DLL mancante o dannegiata.
ho provato a sostituire la dll presa da una istallazione xp simile ma il problema
persiste. faccio notare che Mac OS lawless 10.5.4 AMD e su un disco da 160GB
mentre XP media center e su un disco da 250GB.

la mia configurazione e la seguente:

mainboard................asus m2n vm dh mcp61.......work
cpu..........................athlonx2 4800+..................work
ram.........................kinstone 2x1GB drr800........work
video.......................asus 7300GT 256mb............work
hd...........................seagate 160gb+250gb sata..work
audio.......................ad1988 solo out stereo........work..50%
wireless...................realtek8187........................work
dvd.........................ld sata dvd-rom h62n...........work
..............MAC OS X Lawless ppc 10.5.4. AMD..............

Posted Image

#17
alex5800

alex5800

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:monte san pietrangeli marche
xp leopard chain0

scompatta chain0 in c:
esegui:c:\boot.ini
aggiungi C:\chain0="Mac OS X86"
chiudi
riavvia
seleziona leopard
prima del conto alla rovescia di darwin premi un tasto
seleziona leopard
invio
leopard si caricherŕ!!!

#18
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
cavallo, mi sa che hai danneggiato il bootloader di leo.. ma non ne sono sicuro.. prova a reinstallare il bootloader..

#19
cavallo27

cavallo27

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Location:italy
problema risolto con BOOT-132 (vedi post).
ho scaricato il file iso generic.iso, masterizzato su cd, ed ho avviato il pc dal cd generic.iso
ho selezionato la partizione con Mac OS & voilŕ, ecco avviato il mio mac.
in seguito ho reinstallato il boot-loader.


mainboard................asus m2n vm dh mcp61.......work
cpu..........................athlonx2 4800+..................work
ram.........................kinstone 2x1GB drr800........work
video.......................asus 7300GT 256mb............work
hd...........................seagate 160gb+250gb sata..work
audio.......................ad1988 solo out stereo........work..50%
wireless...................realtek8187........................work
dvd.........................ld sata dvd-rom h62n...........work
..............MAC OS X Lawless ppc 10.5.4. AMD..............
..................Windows XP media center sp3..................

#20
weekdgl

weekdgl

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
ho installato XP e poi kaly 10.5.2, ma basta che spingo invio all'inzio che darwin ha giŕ XP !!!! tanto che adesso levo il chain0 da xp visto che scelgo xp dopo windows mi chiede se usare xp professional o mac osx86 ...
cmq in kaly non va il riavvio, poi tutto in inglese anche se ho scelto italiano,l'audio niente.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy