Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
jamiethemorris

Freeze at login window (white screen) with fusion drive

2 posts in this topic

Recommended Posts

Ok, so I successfully created a fusion drive from a kingston 64gb SSD and a seagate momentus xt (Yes, the hybrid. Could be part of the issue). It's mostly an experiment, so it's not a big deal if it doesn't work, but I really would enjoy having the os do the work for me instead of having to put specific items on the SSD myself.

 

After cloning my original OS back over to my fusion drive and copying over boot0, boot1h, and boot with dd, I booted into the fusion drive just fine, but it was acting strangely and kind of slow. I happened to be using AppleAHCIPort and IOAHCIFamily from Lion for faster boot times already, but I thought maybe the fusion drive did not like the older kexts. So I reinstalled the 10.8.2 kexts with kext utility, repaired disk permissions, and rebooted. It got stuck with a white screen and PWOD right before getting to the desktop. It looks a lot like when you install the wrong framebuffer kext or something. I tried boot with -s and switched the kexts back to how I had them before, but it still did the same thing. -x -s -f gave me a kernel panic.

 

I can still use the chameleon bootloader on the fusion drive to boot into my clone drive, which works fine.

 

I looked in the system log and found a bunch of strange new messages that aren't usually there, but it looks like the issue is starting at Nov 13 20:19:00 and it's obviously related to windowserver.

 

For some reason I'm not permitted to upload my system.log, so here is a link: https://docs.google.com/open?id=0B41jV5CAC_grOFY5QUJUUEwyX1E

 

Thanks in advance.

 

UPDATE: I was just being impatient. It started up eventually after a while. It seems to be a little faster now but I'm not sure. I compared the system.log with the one from my clone and I'm not seeing any differences. This is strange. I thought it might be chameleon, so i updated to the latest but it didn't make any difference. I think the Sea gate's firmware for the hybrid drive may be conflicting...

Share this post


Link to post
Share on other sites

Solved! The issue was one of three things, all of which probably weren't a good idea for this configuration:

-I was using a hybrid drive with built in firmware along with the SSD, which could have been interfering

-I was using the SSD attached to my motherboard. Although I'm not using the built in firmware (intel extreme hard drive or something like that) it's still there. This could've also been interfering.

-The SSD was in a 6 GB/S port, and the hybrid drive was on a 3 GB/S port.

 

On the motherboard SSD chip, I will either be cloning my arch install over or doing a fresh install of Linux Mint/Ubuntu.

 

Here's what I did:

-I used a regular 2.5 inch SSD i was not using. It's twice the size of the other anyway.

-I have a clone of my hackintosh drive with a dual HD setup that I use to boot up on the macs at school. It has a 750gb hybrid drive and a 750gb Hitachi. I swapped the hybrid for the hitachi and put it in my hack.

-I followed the same procedure I did before, and it worked properly the first time! It starts up way quicker than with the hybrid drive. Logic uses about 100 something AU plugins, and used to take 2 minutes to load all of them. Now it takes about 10-15 seconds!

 

So... The moral of the story is, don't take shortcuts for these types of things. 2 types of conflicting firmware along with a possible software conflict=bad idea. I hope this helps someone with a similar issue.

 

Here is the result:

 

post-969691-0-97084600-1352963509_thumb.png

 

UPDATE: Nevermind. It's still sitting at the white screen with PWOD for like 10 mins. It looks like I'm on my own with this issue so I'm deeming it unfixable and giving up. Please close this thread. Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×