Jump to content
InsanelyMac Forum
Sign in to follow this  
whelderwheels613

unsupported installation troubles

Recommended Posts

I have recently been working on performing an unsupported installation of Leopard onto an old Powermac G4 (Digital Audio) running at 533MHz with 1.12 gigs of ram and a Geforce2 MX. From what I have read, Leopard has a limit of 867MHz (or something like that), but I have found that the speed of the cpu can be spoofed by modifying some things in the open firmware. So I did, running the following commands:

dev /cpus/PowerPC,G4@0

d# 867000000 encode-int " clock-frequency" property

boot cd:,\\:tbxi

and it worked, getting past the speed barrier, until I ran into another problem I need a little help with. When I boot from the leopard dvd with the verbose switch, everything seems fine until it looks like the screen was blended or something like that. In non-verbose mode, after about 30 seconds of the spinning grey wheel, I get the "You need to restart your computer" error, and it goes no further. Rebooted into tiger (which is already on the computer) and ran dmesg to find out it has something to do with the graphics card. This is log from dmesg of the boot:

 

standard timeslicing quantum is 10000 us

vm_page_bootstrap: 284869 free pages

mig_table_max_displ = 70

69 prelinked modules

Copyright © 1982, 1986, 1989, 1991, 1993

The Regents of the University of California. All rights reserved.

 

using 2949 buffer headers and 2949 cluster IO buffer headers

FireWire (OHCI) Lucent ID 5811 built-in now active, GUID 003065ff fec7f5fc; max speed s400.

Security auditing service present

BSM auditing present

disabled

rooting via boot-uuid from /chosen: 08091ABA-117B-3D66-8BAE-DE9FA059BD26

Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>

Got boot device = IOService:/MacRISC2PE/pci@f2000000/AppleMacRiscPCI/mac-io@17/AppleKeyLargo/ata-4@1f000/KeyLargoATA/ATADeviceNub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/IBM-DTLA-307045 Media/IOApplePartitionScheme/Apple_HFS_Untitled_1@10

BSD root: disk0s10, major 14, minor 9

Jettisoning kernel linker.

Resetting IOCatalogue.

Matching service count = 2

Matching service count = 4

Matching service count = 4

Matching service count = 4

Matching service count = 4

Matching service count = 4

NVDANV10HAL loaded and registered.

ROM ndrv for NVDA,NVMac is too old (0xb6481dc3)

 

And thats where it stops and the computer {censored} itself.

 

I did a little research and found that Leopard relies on Core Image instead of Quartz Extreme or something along the lines of that, the former which the Geforce2 Mx doesn't support.

 

So basically my question is will it boot with the Geforce2 MX at all, even if I installed Leopard with target disk mode, or would I need a different card, one that supports Core Image?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×