Jump to content
InsanelyMac Forum
Sign in to follow this  
Ricardo Filho

Tem jeito de atualizar do SL para Lion?

Recommended Posts

Advertisement
Não

faça uma instalação limpa seguindo o tutorial

Cara eu baixei a golden master e coloquei no meu pen drive mas dá essa mensagem quando vou selecionar o disco aparece a seguinte mensagem:

 

Para instalar neste disco abra o Utilitário de Disco, escolhendo Utilitários>Utilitário de Disco e particione novamente este disco usando a "Tabela de Partição GUID". Importante: você perderá todos os dados deste disco ao particioná-lo.

Tú pode me ajudar?

Share this post


Link to post
Share on other sites
Se já tem o pen drive pronto até pode, usando o TransMac, mas por que, se você tem o Snow?

Tô com pen pronto e não tenho mais o snow: uma besteira q eu fiz aê e formatei sem querer

Share this post


Link to post
Share on other sites

Então usa o TransMac

/System/Installation/Packages/OSInstall.mpkg
/System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/OSInstall

Share this post


Link to post
Share on other sites
Old valeu pelos arquivos e eu consegui instalar. Mas qual a pasta de extra q eu copio eu tenho um dual core e2160 mas o mac reconhece como core 2 duo

use iMac9,1

e o seu processador tem de ser reconhecido como Core2Duo

Apple não usa Dual-Core

Share this post


Link to post
Share on other sites

Cara eu to usando esse extra e nao testei iniciar normal mas depois de instalar o [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] fica na tela carregando com o logo da apple e nada, so consegui iniciar pelo chameleon q vc indicou la no tuto do usb. Eu tentei instalar ele aki mas ficou o darwin. E so iniciei com -f -v. E agora ta com som, mas o QE e CI nada eu tentei executar o dsdt auto patcher mas ta dando esses erros:

[Line 169 type Error message Object does not exist (OSTP)]

[Line 174 type Error message Object does not exist (\_SB.PCI0.PX40.AG3E)]

[Line 175 type Error message Object does not exist (SLPE)]

[Line 180 type Error message Object does not exist (\_SB.PCI0.PX40.AG3E)]

[Line 182 type Error message syntax error, unexpected PARSEOP_ELSE ]

[Line 184 type Error message Object does not exist (\_SB.PCI0.PX40.AG3E)]

[Line 194 type Error message syntax error, unexpected PARSEOP_METHOD, expecting $end ]

E ai posso por o meu dsdt q usava no SL?

Share this post


Link to post
Share on other sites
[Line 169 type Error message Object does not exist (OSTP)]

[Line 174 type Error message Object does not exist (\_SB.PCI0.PX40.AG3E)]

[Line 175 type Error message Object does not exist (SLPE)]

[Line 180 type Error message Object does not exist (\_SB.PCI0.PX40.AG3E)]

[Line 182 type Error message syntax error, unexpected PARSEOP_ELSE ]

[Line 184 type Error message Object does not exist (\_SB.PCI0.PX40.AG3E)]

[Line 194 type Error message syntax error, unexpected PARSEOP_METHOD, expecting $end ]

roda esse comando no terminal e me envia o DSDT que vai ser gerado no desktop

perl -e 'open(CMD, "ioreg -lw0 \| grep DSDT|") or die; while(<CMD>) { chomp; if($_ =~ /\"DSDT\.?\d?\"=<([^>]*)>/) { $buff = $1; open(PIP, "|xxd -r -p > ~/Desktop/dsdt.aml") or die; print PIP "$1"; } }'

Share this post


Link to post
Share on other sites
roda esse comando no terminal e me envia o DSDT que vai ser gerado no desktop

perl -e 'open(CMD, "ioreg -lw0 \| grep DSDT|") or die; while(<CMD>) { chomp; if($_ =~ /\"DSDT\.?\d?\"=<([^>]*)>/) { $buff = $1; open(PIP, "|xxd -r -p > ~/Desktop/dsdt.aml") or die; print PIP "$1"; } }'

Tá falando q eu não tenho permissão para o upload então tá aê http://www.mediafire.com/?65l9r8a3q274432

Share this post


Link to post
Share on other sites
o DSDT já está editado

por isso os erros

E aÊ o q eu faço sendo q o auto patcher tá dando esses erros

Edit: Cara pelo chameleon do pen drive inicia perfeitamente não precisa de nada até mostra o carregamento na minha resolução. Não tem jeito de eu copiar esse chameleon do jeito que tá pro lion?

Obrigado pela atenção.

Share this post


Link to post
Share on other sites
E aÊ o q eu faço sendo q o auto patcher tá dando esses erros

Você tem que estar usando a DSDT original (não ter feito boot usando um dsdt.aml) para rodar o Auto-Patcher.

 

Edit: Cara pelo chameleon do pen drive inicia perfeitamente não precisa de nada até mostra o carregamento na minha resolução. Não tem jeito de eu copiar esse chameleon do jeito que tá pro lion?

Use no HD o mesmo instalador que usou no pen drive. Se não tiver mais, copie o arquivo boot da raiz de um pro outro. Também pode ser algo na pasta /Extra.

Share this post


Link to post
Share on other sites
Você tem que estar usando a DSDT original (não ter feito boot usando um dsdt.aml) para rodar o Auto-Patcher.

 

 

Use no HD o mesmo instalador que usou no pen drive. Se não tiver mais, copie o arquivo boot da raiz de um pro outro. Também pode ser algo na pasta /Extra.

Então cara eu tô sem nenhuma dsdt na pasta extra tô esperando pra ver qual eu ponho e o instalador desse bootloader não instala do mesmo jeito q eu instalei ele instala sem modo gráfico, mesmo eu marcando themes e tal.

qual é esse arquivo?

Share this post


Link to post
Share on other sites
Então cara eu tô sem nenhuma dsdt na pasta extra

o DSDT editado está sendo lido

por isso pedi pra vc rodar aquele comando e me enviar o DSDT gerado no desktop

 

Use o Auto-Patcher com DSDT original, somente

Share this post


Link to post
Share on other sites
o DSDT editado está sendo lido

por isso pedi pra vc rodar aquele comando e me enviar o DSDT gerado no desktop

 

Use o Auto-Patcher com DSDT original, somente

Eu deletei ele da pasta extra reiniciei e mesmo assim continua os erros e não tá iniciando congela no logo da apple e fica piscando o ponteiro do mouse no canto da tela. Pelo pen drive entra perfeitamente. E com modo verbose fica quase do mesmo jeito só que conjela com uma tela preta com um quadradinho branco e às vezes aparece o ponteiro do mouse. Não tô entendendo nada disso. Obrigado pela atenção.

PS: Será q é pq eu instalei usando o dsdt no pen?

Share this post


Link to post
Share on other sites

Valeu cara tá iniciando normal agora. Valeu mesmo salvou minha vida. Só duas dúvidas. Eu to notando q o launchpad tá meio lento, tipo quando eu clico em utilitários, abre meio engasgado. E outra quando monta alguma imagem não aparece no desktop, como eu faço para aparecer?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×