Jump to content

How I got AMD QE/CI Nvidia Jas 10.4.6 + 10.4.8 Update


  • Please log in to reply
No replies to this topic

#1
letni

letni

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
This explains the process I took to get 10.4.8, Semthex 8.8.1 kernel, and Nvidia working.

Here is my hardware
Athlon 64 X2 3800 +
Nforce 410 mATX based motherboard
PCIe Geforce 7600GT

Here is what I started out with:

Jas 10.4.4 + 10.4.6 DVD installed

Here is what I used:

JaS.10.4.8.AMD.SSE3.Only.Combo.Update - to bring to sort-of 10.4.8
MAC OS X 10.4.8 Intel Only Jas re-seed - To obtain real 10.4.8 kexts and OpenGL Framework
Semthex kernel grabber script found HERE

Here is my process.

0. Installed JaS.10.4.8.AMD.SSE3.Only.Combo.Update onto my 10.4.6 install

1. I installed the real 10.4.8 Intel Only onto a real SSE3 Intel machine
- This was the easiest way for me to grab the folders
/System/Library/Extensions/
/System/Library/Frameworks/OpenGL.framework/

2. Set this install up as a slave drive on my AMD 10.4.6-> 10.4.8 sort-of machine and booted

3. Moved /System/Library/Extensions/ to /System/Library/Extensions.pre8/ and
/System/Library/Frameworks/OpenGL.framework/ to /System/Library/Frameworks/OpenGL.framework.pre8/

4. Copied Extensions folder from real 10.4.8 Intel install (slave drive) to /System/Library/Extensions
and OpenGL.framework from real 10.4.8 to /System/Library/Frameworks/OpenGL.framework/

5. Removed /System/Library/Extensions/AppleIntelCPUPowerManagement.kext as this will kernel dump
on AMD Cpus when trying to boot real 10.4.8 (8.8.1) Kernel

6. This step is only because I use an Nforce based motherboard and the kexts for the IDE controller
isn't included in the real 10.4.8 Intel Only. I deleted IOATAFamily.kext out of /System/Library/Extensions
and copied over the one from Extensions.pre8 ( this adds AppleGenericPCATA.kext in the Plugins in IOATA...)

7. Copied over other Extensions pertaining to 3rd party hardware.. Like I copied over forcedeath.kext from .pre8
to ensure networking still worked.

8. I installed Titan.kext into the Extensions folder

9. I followed the guide here: HERE to add my Video card VenID to the proper kexts in /System/Library/Extensions

10. I ran Semthex's kernel script to go grab the latest version of his kernel build and rebooted.

Came back up with QE/CI enabled on my PCIe Nvidia card running kernel 8.8.1.

Hope this helps some of you out there.

Letni

Edited by letni, 02 January 2007 - 05:38 AM.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy