Jump to content

Problemas con Hd5770 en Mavericks


  • Please log in to reply
8 replies to this topic

#1
Javikoyote

Javikoyote

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Hola, 

He vuelto hace unos días con el tema del hackintosh. Tengo instalado mavericks 10,9,1 en un amd phenom II 955 black edition. He instalado la distro modificada, Mega Torch. Y la verdad es que muy bien, solo tuve que instalar los kext del sonido y el adaptador de red. 

La gráfica la detectó automáticamente, algo que no me pareció raro pues algunos Mac pro traían esta gráfica de serie. El caso es que tras una semana de testeo todo funciona bien, salvo por una cosa. Tras instalar Final cut y también en imovie. El programa inicia perfectamente pero al importar video, el video se ve como corrupto. Da igual el formato, incluso en imovie me lo hace con los videos de ejemplo de los trailers. He cambiado los kext de la gráfica, los que instalo mavericks cuando se instaló por unos de osx86 pero todo sigue igual. ¿Que os parece?. 

Ah, también desinstalé una versión de Final cut "no oficial" que instalé y me baje la versión de prueba por treinta días, a ver si instalaba el original algún codec adicional, pero nada de nada.

Gracias de antemano. 
Se supone que debajo de este texto aparecerán añadido unas capturas del problema. 

 

Attached Files



#2
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,078 posts
  • Gender:Not Telling

Tu problema es probable se relacione con tu CPU AMD, que si bien esta bastante resuelto el tema con kernels parchados, no creo que la compatibilidad sea del 100%. Supongo que esa distro usa Chameleon no? Has probado arrancar con y sin el graphics enabler?



#3
Javikoyote

Javikoyote

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Hola, gracias por tu interés.

 

La verdad he de decirte que no he probado con la sin el Graphics enabler. Lo probare a ver. Una cosa que no he comentado es que la reproducción de video en cualquier otro programa funciona perfectamente, el problema es unicamente en final cut y imovie. Incluso los videos que uso en ellos claro.

 

Voy a probarlo, gracias.

 

P.D: Si uso Chameleon.



#4
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

para esta grafica  use esta configuracion en org.chameleon.boot.plist

 
<key>GraphicsEnabler</key>

<string>No</string>

<key>AtiConfig</key>

<string>Vervet</string>
<key>AtiPorts</key>
<string>4</string>
<key>UseAtiROM</key>
<string>Yes</string>

 

 

 

Attached File  rom hd5770.zip   39.7KB   5 downloads ponga en tu Extra



#5
Javikoyote

Javikoyote

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Nada, que no hay manera. He probado tanto con Graphics Enabler como sin ella. Y todo igual, me detecta 

 

Hola, gracias por tu interés.

 

La verdad he de decirte que no he probado con la sin el Graphics enabler. Lo probare a ver. Una cosa que no he comentado es que la reproducción de video en cualquier otro programa funciona perfectamente, el problema es unicamente en final cut y imovie. Incluso los videos que uso en ellos claro.

 

Voy a probarlo, gracias.

 

P.D: Si uso Chameleon.

Lo he probado y sin ninguna diferencia. Sin el graphics Enabler la única diferencia es que detecta la gráfica como Hd5000 pero el problema igual.


para esta grafica  use esta configuracion en org.chameleon.boot.plist

 
<key>GraphicsEnabler</key>

<string>No</string>

<key>AtiConfig</key>

<string>Vervet</string>
<key>AtiPorts</key>
<string>4</string>
<key>UseAtiROM</key>
<string>Yes</string>

 

 

 

attachicon.gifrom hd5770.zip ponga en tu Extra

He realizado los cambios que me comenta y el ordenador sigue funcionando bien, pero el defecto en el final cut sigue exactamente igual.

 Captura%20de%20pantalla%202014-02-16%202



#6
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

usas DSDT ? si no , te recomiendo que haga el tuyo, algo puede ajudar., pero no te olvides esto puede ser um problema com el kernel amd, prueba otros kernels hay muchos por ahy:

 

 Patched Kernels - OSx86     to AMD 

 

 

https://www.dropbox....o/AMD GUIDE.zip



#7
Javikoyote

Javikoyote

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

usas DSDT ? si no , te recomiendo que haga el tuyo, algo puede ajudar., pero no te olvides esto puede ser um problema com el kernel amd, prueba otros kernels hay muchos por ahy:

 

 Patched Kernels - OSx86     to AMD 

 

 

https://www.dropbox....o/AMD GUIDE.zip

Si te soy sincero, no se hacer el DSDT. Y tampoco cambiar el kernnel. Cuando instalé el macos si que instalé un archivo que se llamaba AMD_kernel. ¿Es esó?. ¿Sería solo Grabar el nuevo kernel encima?



#8
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

DSDT/SSDT Patch request - DSDT - OSXLatitude Forum   como extraer tu DSDT mira aqui, esta bien explicado, luego postea aqui para Editar

 

para cambiar el kernel mira en este video esta bien explicado  Install Preparation for Mavericks on AMD - AMD - InsanelyMac Forum



#9
Javikoyote

Javikoyote

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Hola, Gracias de nuevo por vuestro interés. He sacado tanto el DSDT como el SSDT y aquí os lo presento.

 

https://www.dropbox....f/acpi_dsdt.bin

 

https://www.dropbox....7/acpi_ssdt.bin

 

En cuanto al kernel por lo que he podido deducir, es para parchear el usb de instalación y luego volver a instalar todo. ¿No?. ¿No se puede sin reinstalar?.

 

Gracias.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy