Jump to content

SSDT help - LAN1 on P9X79 WS


  • Please log in to reply
4 replies to this topic

#1
warduck

warduck

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Not Telling

Hello, I'm having some problems adding 'Ethernet Built In' into rampagedev's SSDT for the P9X79 WS board. At the same time, I'm trying to use the secondary LAN device (LAN1, Intel 82574L) rather than the primary (LAN0).

 

I can't seem to have GIGE@0 appear in IOreg for LAN1, and the other injected entries are missing. Could anyone have a quick look at this?

 

I need 'Ethernet Built In' to fix my Mac App store login issue.

 

Thanks very much for any assistance.



#2
warduck

warduck

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Not Telling

I suppose my request is really quite unusual? For whatever reason, some input would be appreciated. Even rampage ignored my e-mail. :cry:

 

Oh well.



#3
warduck

warduck

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Not Telling

Looks like rampage has silently updated the P9X79 WS DSDT to incorporate EthernetBuiltIn (link). I guess my request was quite valid. :D

 

If anyone has this board and is using the secondary LAN device, simply edit the current DSDT to have PEX0 point to PEX7 and delete the PEX1 section. You should also take the chance to add or change entries to better reflect the device in OS X.

 

Edit: Earlier above, I mixed up the DSDT's for P9X79 WS and P9X79-E WS. But you can just copy out the entry for GBE in the latter, which has the EBI change, and it will work.


Edited by warduck, 10 January 2014 - 12:30 AM.


#4
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male

It does not matter for the second port. Never has and the patch has Always been there for at least one USB port. Your request is not valid or needed at all... 



#5
warduck

warduck

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Not Telling

Rampage, the overall point is to avoid using EBI in Chameleon. Without EBI, the Mac App store does not work for me. Now, your DSDT for P9X79 WS does not have EBI at all, whereas the one for P9X79-E WS has it for both LAN devices. So yes, my request is very much valid, since I can use the Mac App store once again.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy