Jump to content

[help] Installing Mavericks on Microsoft Surface Pro


  • Please log in to reply
27 replies to this topic

#21
JahStories

JahStories

    Brainstormers killer.

  • Moderators
  • 1,756 posts
  • Gender:Male
  • Location:Sicily, Egypt.
  • Interests:Everything that got a screen on it, Hoverboarding, Broken CrossFaders, Commodore Amigas and repl...

is there a patched bios out there for the surface pro? btw i'm deleting these kexts



#22
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

No, but you can download  your bios and Patch it, see in section developers and look if is possible patch it

 

 

 

[PMPatch] UEFI patching utility



#23
JahStories

JahStories

    Brainstormers killer.

  • Moderators
  • 1,756 posts
  • Gender:Male
  • Location:Sicily, Egypt.
  • Interests:Everything that got a screen on it, Hoverboarding, Broken CrossFaders, Commodore Amigas and repl...

ok i've deleted the kexts now i can see the spinning whell that spins in front of the gray apple loading screen no more...


btw right now i prefer to keep my surface clean no patched uefi at least not now...


tips?



#24
JahStories

JahStories

    Brainstormers killer.

  • Moderators
  • 1,756 posts
  • Gender:Male
  • Location:Sicily, Egypt.
  • Interests:Everything that got a screen on it, Hoverboarding, Broken CrossFaders, Commodore Amigas and repl...

okay i'm installing, worked with clover r2165



#25
JahStories

JahStories

    Brainstormers killer.

  • Moderators
  • 1,756 posts
  • Gender:Male
  • Location:Sicily, Egypt.
  • Interests:Everything that got a screen on it, Hoverboarding, Broken CrossFaders, Commodore Amigas and repl...

ok i've reached the desktop and did the first configuration, but it boots only in safe mode, no qe ci if i try to boot without -x  i get stuck on boot with this screen...

2ltol02.jpg


Opening a new topic on post installation



#26
chinatownabc

chinatownabc

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

ok i've reached the desktop and did the first configuration, but it boots only in safe mode, no qe ci if i try to boot without -x  i get stuck on boot with this screen...

2ltol02.jpg


Opening a new topic on post installation

 

 

Hey @JahStories i was wondering how to get past this im having the same issue as you mentioned here thanks.  



#27
vindu

vindu

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

try adding dart=0 to your boot arguments, apparently it disabled vt-d which is supported by the 3317u

helped with my error on mavericks



#28
chinatownabc

chinatownabc

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I tried dart = 0 doesnt work





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy