Jump to content

Wrong sound output names in System Preferences

output names system preferences wrong

  • Please log in to reply
1 reply to this topic

#1
AT0MAC

AT0MAC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Location:Copenhagen, DK
  • Interests:Hi-Fi, Mac & Music

Before I move into the wrong direction I better ask you guys.

 

After a month away from home I turn my hack back on and find my self for some reason without audio... So I reinstall the driver but something went wrong, audio works but the names in system preferences are way off, kind of hard to guess which output does what...

 

I have a MSI Z77GA-M45 motherboard with the ALC892 codec, this mb have no digital out, only two line ins and 4 surround analogue outs.

 

 

In my system prefs it looks like this:

 

vy1k.png

 

The four outputs are there, problem is that on the backpanel it looks like this:

 

xgr1.png

 

I have found multiple links describing how to edit the files necessary, but I dont seem to figure out exactly how to edit only the names.

 

https://github.com/t...ster/README.txt

 

This one here describes a lot of good stuff, but as I understand it my audio id is correct as i have 6 ports, all analogue just that they are not the 6 ports named in sys prefs.

 

 

 

 



#2
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,113 posts
  • Gender:Male

So I reinstall the driver but something went wrong, audio works but the names in system preferences are way off, kind of hard to guess which output does what...

 

toleda/audio_ALCInjection · GitHub see ML-Realtek ALC AppleHDA Screenshots.pdf

Hint:

Internal Speakers is the motherboard green Line-Out port

(1st) Line Out is the motherboard black RS-Out port (rear surround)

The rest is easy to figure out.

For motherboard grey (SS-Out), an edit to AppleHDA.kext is required; no issue on your system as there is no SPDIF out. See the Customization guide in the same repo.

Welcome to OS X and the nearly native AppleHDA,kext.







Also tagged with one or more of these keywords: output names, system preferences, wrong

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy