Jump to content

Cannot get USB Bluetooth Dongle to work


  • Please log in to reply
5 replies to this topic

#1
bmarkovic

bmarkovic

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello all,

I've recently purchased an USB dongle for my Hackintosh. It's a very cannonical build (I3 3225, Z77-DS3H, HD4000) running ML 10.8.0, and it otherwyse works great.

The dongle is recognized by the computer in the sense that it shows up as this:

Bluetooth USB Host Controller:

Product ID: 0x0001
Vendor ID: 0x0a12 (Cambridge Silicon Radio Ltd.)
Version: 19.15
Speed: Up to 12 Mb/sec
Location ID: 0x1a130000 / 4
Current Available (mA): 500
Current Required (mA): 0

in System Information. However there is no Bluetooth Icon in System Preferences or Menubar.

The whole thing is odd since it's a CSR dongle already defined in /S/L/E/IOBluetoothFamily.kext/Contents/Plugins/CSRBluetoothHCIControllerUSBTransport.kext as this:

<key>CSRUSBBluetoothHCIController</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.iokit.CSRBluetoothHCIControllerUSBTransport</string>
<key>IOClass</key>
<string>CSRBluetoothHCIControllerUSBTransport</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>idProduct</key>
<integer>1</integer>
<key>idVendor</key>
<integer>2578</integer>
</dict>

(I checked the DevID and VenID values against hex from SysInfo and they're the same)

I googled and browsed and found no clue (most stuff I find are people whose Wake on Blueetooth doesn't work).

Any ideas?

#2
XploRa

XploRa

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male
  • Location:Cape Town South Africa

Same Dongle with other issue though - Mine stopped working after 10.8.5 update and now i'm stuck,

although it comes on, it does not function properly.

I see another person used his settings from 10.8.4 via Time Machine and got it to work, but I do not have that 10.8.4 plist to

apply the old settings.



#3
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

I don´t understand you guys, in MAC OS X 10.6 10.7 10.8 10.9  THIS bluetooth work OOB and you posting problems with bluetooth!!!!!

 

 

http://www.amazon.es...o/dp/B001BROKXO

 

 

Attached File  31Vm7TFOxqL._SX385_.jpg   6.44KB   12 downloads



#4
XploRa

XploRa

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male
  • Location:Cape Town South Africa

@bmarkovic - your USB dongle should work fine in 10.8.0 that you are running without any problems at all, I

think you must have a configuration problem - try repairing permissions and rebuilding kext cache and also try another

USB port maybe to see if it shows up in System Preferences.

 

@iFIRE - sorry for the confusion, I am having problems with this dongle in 10.8.5 (after combo update) and in 10.9 DP8, but

not in 10.8.4 (works without any problems). 

 

It does work OOB (in all versions for sure), in 10.8.5 and 10.9 once you toggle the bluetooth off, it does not go off at all (just stays on with wheel spinning), and there is nothing

one can do besides changing the value: ControllerPowerState back to 1 again in "com.apple.Bluetooth.plist" and then reboot  ------  understand?

So in other words ---- you cannot toggle it on and off at will ....  :rolleyes:

However this could maybe be due to the way I upgraded 10.8.4 via Apple Store - but I cannot see why though, surely one does not have to

download the whole 10.8.5 that's 5Gig to get it to work?

 

Attached File  Untitled 2.jpg   96.31KB   2 downloads

 

This is my CSR dongle:

 

Attached File  sitecom_bluetooth_20_usb_micro_adapter_100m-1.jpg   280.05KB   11 downloads



#5
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

try this one:IOBluetoothFamily.kext.zip



#6
XploRa

XploRa

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male
  • Location:Cape Town South Africa

Have to reboot into 10.8.5 and try it - thank you.

No nothing .... But here is the solution ....

 

http://www.insanelym...-out/?p=1948485







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy