Jump to content

Installed macos 10.6.8 on Gigabyte 770ta-ud3 with AMD phenom ii x6 proccesor


  • Please log in to reply
No replies to this topic

#1
nikosd

nikosd

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Hello.After trying very hard to find a distro and kernel suitable for a six core amd phenom ii i did it:)

i have a Gigabyte 770ta-ud3 with AMD phenom ii x6 proccesor and 4 gigabytes of ram,a nvidia gts 250 1 gigabyte ram,and focusrie saffire firewire card.

I installed macos 10.6.2 first then updated to 10.6.8 used the legacy_kernel-10.8.0.v2.pkg then i did the needed steps with ##### to fix the pci error and to boot,installed the correct usb kext ,and i have succesfully used booted to 10.6.8 with usb rollback working.

I have not installed any bootlader,the macos 10.6.8 partition is on a extended partition,and the primary one has windows 7,i have OSX86_ModCD-032311-151021.iso burned to a cd and i boot it with this ,i use the following kernel options after i choose my partition

legacy_kernel arch=i386 maxmem=4096 -force64 -v

1)Is it problematic if i dont install a bootloader?What is the correct way to do it without messing up windows?I tried to install with the osx86 by using the install efi/fdisk but i didnt see any bootlader after,or the partitions to select like i do from the cd.I know that booting from this cd make my system have this boot options (i took them from the kext utility in tools folder)

ProductName: Mac OS X ProductVersion: 10.6.8 BuildVersion: 10K549
Kernel: Darwin Kernel Version 10.8.0: Mon Jun 27 20:06:12 EDT 2011
Bootargs: boot-uuid=AEED9C84-9113-3E70-AFEF-85031A5AFF52 rd=*uuid -v maxmem=2048 cpus=1 arch=i386 arch=i386 maxmem=4096 -force64 -v
Model ID: OSX86Hack1,1
CPU Signature: Ox100FA0 (1052576)
CPU TYPE: AMD Phenom™ II X6 1055T Processor
Core: 2810(2810) MHz x 112.4(112.4) Bus: 25 MHz FSB: 100 MHz
Cache L2: 512 Mb
RAM: 4096 Mb
SwapUsage: total = 64.00M used = 0.00M free = 64.00M
HibernateMode: 0

Now is uses my own kernel options along with those on cd so it goes like maxmem=2048 cpus=1 arch=i386 arch=i386 maxmem=4096 -force64 -v
How can i fix this?How can i have the correct bus ratio for my system?

2) i tried to use the kernel from this thread http://www.insanelym...it-in-progress/ while it works and i can succesfully boot in to x64 by using
mach_kernel arch=x86_64 maxmem=4096 -v then it works for maybe 10-15 minutes and sometimes i have lockups ,32 bit applications do not work,i read the article regarding the patch of some files here http://www.osx86.net...-will-work.html but right after i patch dyld i get illegal instruction and cant use finder to do anything,if i reboot then there are tons of errors and kernel panics
So :how can i patch the 64 bit kernel that i got from http://www.insanelym...it-in-progress/ to work with 32 bit applications?what is the correct way to patch all these files without risk to destroy the system?I tried to do it in arch=i386 and arch=x86_64 but result was the same,illegal instruction and had to reinstall macos after.Should i boot with -x to do it?

Right now i have a very functional system that almost everything works,sound card (a saffire focusrite in firewire mode with voodoo.kext),nvidia gts 250 1 gigabyte works with qe enabled,usb works ok.ethernet too,and with the -force64 i load all applciations,though i would love to boot with a
3)i have not patched anything with the amd marvin utility,should i patch something with it?
4)before finding legacy kernel and the new 64bit one i didnt have gfx acceleration so i used dsdt editing,i learned to use the utility ,should i patch my system with it?
Are there any tips to enable sleep?Right now i just close power supply to my monitor and i use caffeine program because the system does not wake up if it goes to sleep.
Thank you





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy