Jump to content

Quale Bootloader?

Chameleon Clover

  • Please log in to reply
1 reply to this topic

#1
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,654 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Salve a tutti, ho voluto provare a cambiare bootloader, installando Clover su una chiavetta, e sorprendentemente mi trovo delle cose in info di sistema che con Chameleon risultavano scorrette, quali la velocità del processore e la diagnosi all'avvio; per il resto non è cambiato nulla a livello di gestione energetica (ancora non va lo sleep anche cambiando i parametri "al volo" nelle opzioni di avvio).

Una cosa alla quale non sono riuscito a porre rimedio è la risoluzione errata della grafica integrata quando scelgo di avviare Clover in UEFI; con Chameleon avevo lo stesso problema ma ho risolto semplicemente aggiungendo la stringa Graphics Mode con la risoluzione desiderata in ocbp.
La grafica integrata è connessa in HDMI ad un TV LG 22" (l'unica altra connessione possibile è in D-SUB ma con SMBIOS iMac 13,1 non credo funzioni, e se anche funzionasse, la definizione sarebbe terribile), in attesa di acquistare un monitor vero e proprio.

I parametri che uso per Chameleon li uso anche per Clover, compreso SMBIOS e DSDT (anche se Clover di default, in base al mio HW aveva deciso di assegnare iMac 12,2).
In pratica vorrei sapere:

1- Se ci sono delle opzioni in Chameleon (o enoch) per correggere gli errori che non ho con Clover.

2- Se e come posso fare in modo che Clover gestisca lo sleep (ho cercato di capire il più possibile traducendo in italiano tutto ciò che trovavo, ma sono ancora in alto mare).

Grazie a chiunque mi darà una mano

Attached Files



#2
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,654 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Aggiornamento:
ho estratto SSDT con lo script di Revogirl (estraendolo normalmente me ne genera 3, tutti con errori o warnings che non riesco a correggere), ancora lo sleep non funziona, ma è cambiato qualcosa: inizialmente il sistema si ibernava per poi risvegliarsi e riaddormentarsi 3 volte prima di risvegliarsi definitivamente tranne il monitor e le usb, costringendomi a forzare lo spegnimento; ora si spegne il monitor e le usb ma il resto rimane acceso e devo ancora forzare lo spegnimento.
Da che può dipendere?
Grazie





Also tagged with one or more of these keywords: Chameleon, Clover


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy