Jump to content

Help me enable sleep on Intel DP965LT. (Tried lots of DSDT patches and editing)

DP965LT sleep

  • Please log in to reply
27 replies to this topic

#21
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,515 posts
  • Gender:Male
  • Location:Tampa, Florida
1095:3132 SiI 3132 Serial ATA Raid II Controller
1131:7162 Pinnacle PCTV 3010iX/7010iX TV Card
11ab:6101 Marvell RAID 614x
lots of stuff going on pci i see, i dunno if or which can cause the issue here.

#22
babylonx

babylonx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
The first 2 I had them removed during testing but I need them so I hooked them up again. They are definetely not the proble since I added them later.

The third one is probably the legacy IDE controller. There is no option to turn this of from the BIOS. Can I dissable it somehow through OS X? Maybe remove it from my DSDT?

#23
babylonx

babylonx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I found the source of the issue! It sleeps if I disable Core Multiplexing! Of course this means cutting my speed to the half and it is not a solution but I think it's a very good point to start troubleshooting!

Does having to disable secondary cores give anyone any clue of what might be wrong?

#24
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,515 posts
  • Gender:Male
  • Location:Tampa, Florida
first try voodootscsync

or might need ssdt generated
http://rampagedev.wo...-own-ssdt-17-2/

#25
babylonx

babylonx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I just had a little time to try all these.

I tried voodootscsync alone, SSDT alone, both of them together, I also tried dissabling SpeedStep in my bios while I tried them but no difference.

According to Chameleon my CPU Speed is 2131 but according to HWMonitor it is 2128. I tried both during SSDT Generation but no difference.

Actually, no matter what I do, even if I disable SpeedStep in the bios, I can see speedstep working: In HWMonitor my speed is altered all the time between two modes:
x6 1596MHz
x8 2128MHz

No matter what I didn't it didn't seem to make it stop changing states.

So I guess there is something else that overrides what I set...

Also using flag cpus=1 does not help. The only thing that makes it possible is disabling Core Multiplexing which makes it look like just one processor (when I used cpus=1 I noticed I had 2 processors but the second one was set to 0 MHz and that didn't help).

#26
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,515 posts
  • Gender:Male
  • Location:Tampa, Florida
u are using GeneratePStates and CStates right ?

#27
babylonx

babylonx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Yes but I tried removing these options from the plist and also didn't do any difference.

Also, I installed Mountain Lion and updated to 10.8.2. I did a clean install. Nothing changed. If I dissable Core Multiplexing sleep works! With it enabled it freezes.

#28
babylonx

babylonx

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Should I start a new topic now that we found the source of the problem? I see nobody is answering.. Maybe if its clear from the title that "core multiplexing" breaks sleep function more people could help me?





Also tagged with one or more of these keywords: DP965LT, sleep


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy